Assetto Corsa PC Mods General DiscussionPC 

  • Thread starter Paiky
  • 134,361 comments
  • 35,486,348 views
Untitled-1.png
Does anybody know why this would out of the blue start happening? Literally, ran a race, finished race, exited back to CM, went to re run the race and this error, try to watch replay of the first race, this error....

EDIT: Seems to be something to do with Legions M8E (the M8D is fine) was working suddenly it no longer does.
 
Last edited:
Is there a means to correct the height of the suspension? I am a R34 GT-R fan (thanks to GT 1). The R34 Z-Tune by RWB Bansky Kai sits a bit high in the wheel wells both on track and in the images. I'd like to lower it a bit more without causing the car to bottom out.
View attachment 1257619
In suspensions.ini you can play with the BASEY values both Front and Rear. As you'll be modifying the suspension, it will have an effect in the behavior of the car, though small changes are usually unnoticeable in terms of physics.

If you want to change only the visual aspect without affecting the physics you can also do so by modifying the GRAPHICS_OFFSET value in car.ini. The value in the middle is the Y axis so that one will modify the height of the car (-0.49 in this example).

[BASIC]
GRAPHICS_OFFSET=0,-0.49,-0.08
 
Thanks, but that's not what's causing the problem at my end.
Seems to be whenever a brand new car/track combo is loading, I get 'race cancelled' quite early in the loading, as if a file is being created or something.
IDK, it doesn't really make sense, but it's very similar to something that happened across several CSP builds a few years ago.
Same here, and only with latest CSP Preview. I assumed it was something to do with AI generation, but will confess I remain stumped on exactly what is causing it 🤷🏼‍♂️
 
Same here, and only with latest CSP Preview. I assumed it was something to do with AI generation, but will confess I remain stumped on exactly what is causing it 🤷🏼‍♂️
The crash always does seem to happen when the AI spline is being initialised.
Maybe something to do with one of the 'New AI Behaviour' options?
 
Last edited:
Last edited:
I checked and do have version 1.6 of the config so I have no idea why I see such a different looking track. Honestly, it's not worth trying to figure out anymore because I don't know what else to try. I tried different filters, reseting sol\pure, etc. and it still looks basically the same. Different filters do make a small difference but not to where it looks like @slider666 picture. I'll just use my modified version for when I drive\race the track. While not as nice as @slider666 picture, it's good enough.
Sorry, I have to apologize. It was late, and I was tired, so unfortunately I didn't check it correctly. :(

I knew it never looked as nuclear on my side as it does on @racingjoe's 1st screenshot. So before I went to bed, I quickly fired up AC. Took some time to find the right spot for comparison, took my screenshot, posted it here and went to bed. Then I had a hard week and unfortunately no time to answer.

Well, now I do.
Since I wasn't too fit any more, I overlooked that I had adjusted it a bit for myself last year in an extra config file. Without my config, it looks something like what @Fanapryde posted.

So, actually, it's less FFP relevant than I thought first. But I'm still puzzled why @racingjoe's 1st screenshot looks so violently nuclear.
I just wanted to avoid spending too much time unnecessarily, and others complaining about a far too dark config afterwards.

I wouldn't have guessed that the whole thing ultimately made such high waves. Sorry again for that. :(

But long story short, I know the woods around the track very well. It's on the "Teutoburg Forest" and accordingly I adapted it to my observations at the time.
However, as @Fallguy has already pointed out, there is a legal problem with the track mod, so I didn't want to get Fat-Alfie into trouble and didn't publish my config. I was also not completely satisfied with the grass config.

Anyway, to be on the safe side, so that I don't make a complete fool of myself again, I have now completely reset all my stuff and taken another screenshot. Fortunately, it looks more or less the same as the one I already posted.

I would still try to adjust the grass a little better if I find the time. But then I will only share the config with the appropriate additions. But without the track itself, of course.

1684524809489.png
 
Last edited:
Hello,

I guess this has already been asked but does anybody know the maximum car mods CM can handle ?
That's a very good question, I'm just sorting it out, I've got about 2100 cars and it feels like my RAM (12Gb) is empty after a short time, I can make a few previews, listen to music, have tube and the cm showroom open and KSeditor to edit an car and, bang, the crash came, and my pc freezed to death, caused by ACS.exe according to the windows debugger.

Somehow AC is having a hard time emptying the ram properly? Anyway since the latest CSP it is far worse i think.

Is it the 2100 car's or the new CSP? I don't know it...

I've had some crashes of the game itself in the past due to out of memory, :(but nothing ever froze or the PC rebooted by itself
...
 
Last edited:
That's a very good question, I'm just sorting it out, I've got about 2100 cars and it feels like my RAM (12Gb) is empty after a short time, I can make a few previews, listen to music, have tube and the cm showroom open, edit an car and, bang, the crash came, and my pc freezed to death, caused by ACS.exe according to the windows debugger.

Somehow AC is having a hard time emptying the ram properly? Anyway since the latest CSP I've been crashing which I've never had before, is it the 2100 auto's or the new CSP? I don't know it...
Legend has it there's a CM memory leak that's been known about for years but never solved.
Restarting CM occasionally helps as a one-off, but sometimes only a full PC restart will completely clear it.
 
Bilster Berg ext_config\track skin update I made for myself because for some reason the grass and trees were over-exposed for me and I couldn't figure out why. You can give it a try if you'd like. PPFilters can make a huge difference so you might not like how things look. I just know it looks fine on my end with my own personal filter.

Bilster Berg Update

This is for the version of the track done by Fat-Alfie, Legion and nobody. It makes no changes to the track itself other than how the grass and trees look. Please make sure to rename or backup your current ext_config file so you can easily revert back if you don't care for the changes.

Notes:

-- Always leave the Grass and Trees track skin enabled.
-- There are two ways the grass can look, all green and patchy. I saw pictures of the track that looked both ways, so I made two versions. Patchy grass is active by default because I prefer it. To change grass styles, simply choose either the Grass Green or Grass Patchy track skin.
-- Other config additions include seasonal changes and a change to the lights so that they come on at night and when it rains. I didn't change their settings so they should look exactly as they did before.
-- Any ambient and diffuse shader values I changed are in the Shader Values section of the config so you can easily adjust them to get the brightness you prefer for the grass, trees and road. They are setup to look good for my system.

sunrise.jpg
 
Last edited:
...and @samdale12, and @El Locho, and @Alguecool, and @noroardanto, and @SthrnOldskool, and @Ant78, and everyone else who has the 'RACE CANCELLED' bug with the new CSP, try ticking this in settings/CSP/New AI Behaviour:

View attachment 1257833

It seems to have fixed the issue for me.
Please report whether it works for you.
Fingers well and truly crossed...
well I reported this a few days ago, its related maybe, on my part unchecking the Avoid sides when raining - in New ai behavior helped.
https://www.gtplanet.net/forum/threads/assetto-corsa-pc-mods-general-discussion.307899/post-14013457
 
Last edited:
I just had some free time from all the historic stuff with some GT3 action. I could collect all ACC cars except the Aston Martin V8 Vantage GT3 2019. Was this car converted to AC?
 
Last edited:
Another version of Brabham, which was missing. The BT33/72 from the beginning of the season. Graham Hill Skins (Argentina and South Africa), Wilsinho Fittipaldi Jr. (Brazil (non-championship) and Spain)
 

Attachments

  • __custom_showroom_1684536906.png
    __custom_showroom_1684536906.png
    62.3 KB · Views: 18
  • __custom_showroom_1684536930.png
    __custom_showroom_1684536930.png
    62.2 KB · Views: 18
  • __custom_showroom_1684536959.png
    __custom_showroom_1684536959.png
    60.1 KB · Views: 15
  • __custom_showroom_1684536978.png
    __custom_showroom_1684536978.png
    47.6 KB · Views: 17
...and @samdale12, and @El Locho, and @Alguecool, and @noroardanto, and @SthrnOldskool, and @Ant78, and everyone else who has the 'RACE CANCELLED' bug with the new CSP, try ticking this in settings/CSP/New AI Behaviour:

View attachment 1257833

It seems to have fixed the issue for me.
Please report whether it works for you.
Fingers well and truly crossed...
That worked for me for a couple days, but started again a few days later. I still have problems any time I change the car/track I'm driving, or even if I change a parameter in the data.ini of the same car...
 
wow that Porsche 911 RSR GTE from Yezhrod (yzd_porsche_911_rsr_gte_2017) is something!

But I'm unable to see anything in the side mirrors (L & R) when it's raining...
Anyone know how to make raindrops on the mirrors smaller/less?
 
Bilster Berg ext_config\track skin update I made for myself because for some reason the grass and trees were over-exposed for me and I couldn't figure out why. You can give it a try if you'd like. PPFilters can make a huge difference so you might not like how things look. I just know it looks fine on my end with my own personal filter.

Bilster Berg config update

This is for the version 0.98 or 0.99 (can't recall which I have) of the track done by Fat-Alfie, Legion, nobody. It makes no changes to the track itself other than how the grass and trees look. Please make sure to rename or backup your current ext_config file so you can easily revert back if you don't care for the changes.

Notes:

-- There are two ways the grass can look, all green and patchy. I saw pictures of the track that looked both ways, so I made two versions. Patchy grass is active by default because I prefer it.
-- To change grass styles, you need to edit one thing in the ext_config. All the way at the bottom of the config is a section named Grass Styles. Set whichever one you want to try to ACTIVE = 1 and the other one to ACTIVE = 0. They are labeled so it's easy to understand. If you want to edit the ambient and diffuse values to get the grass brightness more to your liking, make sure to also change the values for the MATERIALS = trackedge?, track_edges? section by the same amount.
-- Other config additions include seasonal changes and a change to the lights so that they come on at night and when it rains. I didn't change their settings so they should look exactly as they did before.

View attachment 1257844
Got some feedback that things could be a little darker so I attached an alternative ext_config to the original post that lowers the ambient and diffuse values for the grass, trees and other things I changed. Maybe you'll like it better.
 
For some reason, some of the Python apps can't be shown even after turning it on. It so far only affects Lebleum's YATT and Prunn's ACTV.
image.png



Weirdly, this is not affecting AutoStartSystem and all of my other apps, (YATT and ACTV is a more recent app that I downloaded)
image.png
 
Sharing a mod? Host it on GTPlanet Downloads. Free, public hosting for files up to 10GB in size.
Back