Can't load my ghost in Sportmode/Daily Races/Qualifying

  • Thread starter CoyoteX
  • 54 comments
  • 11,486 views
14
France
France
That's right. I don't think that they are aware. Or they are aware but aren't able to find a solution. It's no obvious issue where all players are affected. Perhaps Faux Nul Zero's method of deleting and reinstalling the game will help. Then this would be the evidence that the players that are affected have all individual problems with the game and there's no issue with the game itself. But i wait to do this final step as my game runs stable.

Erasing and reinstalling is not the silver bullet.
The problem has reappeared. But less often.
I have multiple accounts and when I load the ghost of another account, bugs appear regularly (the ghost appears far behind)
 
33
Germany
Munich/Bavaria
Mark_McCormick
Erasing and reinstalling is not the silver bullet.
The problem has reappeared. But less often.
I have multiple accounts and when I load the ghost of another account, bugs appear regularly (the ghost appears far behind)

Thanks for the information. Didn't know that loading a ghost from another account is possible (i have only one). So i won't do this procedure as with my Inet connection the GTS Digital Version would need about 24 h to download.
 
33
Germany
Munich/Bavaria
Mark_McCormick
Was there ever a way to fix this? Still having the same issue.

As far as i know, NO. And as time goes by, i really miss this "simple feature" (which worked in the previous GT games perfectly) more and more. I can't understand it. My game works very well in all other sections, but the loaded ghosts don't work, neither in Arcade Mode nor in Sport Mode. It's a shame. A fundamental feature isn't there any more. But PD refined the options with the ghosts not knowing that some players can't use it anymore.
 
33
Germany
Munich/Bavaria
Mark_McCormick
...As I mainly use on-line time trial, I load other ghosts that work and chase them.

For me my own best lap is the best way to improve. So the problem is annoying in my case. PD focusses on GT7 and will never make an attempt to fix this issue, as it is not an obvious issue that affects all players. It would cost too much time, manpower and money. Sad but true.
 
531
Finland
Finland
As far as i know, NO. And as time goes by, i really miss this "simple feature" (which worked in the previous GT games perfectly) more and more. I can't understand it. My game works very well in all other sections, but the loaded ghosts don't work, neither in Arcade Mode nor in Sport Mode. It's a shame. A fundamental feature isn't there any more. But PD refined the options with the ghosts not knowing that some players can't use it anymore.

I got a fast time around DTG daily with the Renault and saved it then wanted to test all other Gr4 cars against it. Really quite annoying that this doesn't work. It's what I used to do a lot but then when it didn't work a few times I just did without. Along with my chase cam resetting from 3 to either 2 or 0 it's really quite ridiculous and I'm sitting there wondering why I even play this stupid game made by idiots (again).
 
165
Denmark
Denmark
I had this problem, too, last year. Then it was fixed by an update (or so I thought - reading about your experiences I'm not so sure anymore - maybe my game just "un-glitched" itself.)
 
33
Germany
Munich/Bavaria
Mark_McCormick
I had this problem, too, last year. Then it was fixed by an update (or so I thought - reading about your experiences I'm not so sure anymore - maybe my game just "un-glitched" itself.)

Then you're really lucky. The update you mentioned had no fix for sure, but in your case the issue vanished. Why? I think PD couldn't answer this question, too.
 
163
Italy
Isola della Tontola
I just had an Arcade Time Trial session at the Redbull Ring: saved a couple of Best Lap Replays and as usual the loaded ghost doesn't show up, then - just out of curiosity - I saved the whole replay and surprise-surprise, the ghost works like a charm. Apparently this is a Save Best Lap Replay bug: clicking on Save Replay (the whole lap sequence) will give the best lap ghost to load anyway, and this time fully functioning. It maybe needs to be confirmed in more different tracks and cars but it seems the only fix to this problem is to use the "Save Replay" option.
 
Last edited:
33
Germany
Munich/Bavaria
Mark_McCormick
I just had an Arcade Time Trial session at the Redbull Ring: saved a couple of Best Lap Replays and as usual the loaded ghost doesn't show up, then - just out of curiosity - I saved the whole replay and surprise-surprise, the ghost works like a charm. Apparently this is a Best Lap Replay bug: saving the Replay (the whole lap sequence) will give that same best lap ghost to load, but this time fully functioning. It needs to be confirmed in more different tracks and cars but it seems the only fix is ignoring the "Save the Best Lap" option.

Thanks for your tip. Will try it this week. Does this method works, too, if your whole replay has let's say 10 laps?
By the way: In the list of the best laps even best laps of RACES are listed (this is so since the early days of the game) and this is a bit strange, cause in a race slipstream can occur and you often drive another line e.g. when you overtake an opponent.
 
163
Italy
Isola della Tontola
Thanks for your tip. Will try it this week. Does this method works, too, if your whole replay has let's say 10 laps?
By the way: In the list of the best laps even best laps of RACES are listed (this is so since the early days of the game) and this is a bit strange, cause in a race slipstream can occur and you often drive another line e.g. when you overtake an opponent.

10 laps? I think so, though I prefer to run less consecutive laps to keep the replay smaller. I have no idea about Races best laps, or anything related to Sportmode as well. But I sure have lots and lots of ideas about things I find STRANGE in Gran Turismo... :P
 
33
Germany
Munich/Bavaria
Mark_McCormick
10 laps? I think so, though I prefer to run less consecutive laps to keep the replay smaller. I have no idea about Races best laps, or anything related to Sportmode as well. But I sure have lots and lots of ideas about things I find STRANGE in Gran Turismo... :P

I tested a 2 laps replay and it worked. Amazing!!! Thanks again for this workaround.
Regarding the races...once i had a replay of a Mission Race and when i wanted to load a ghost on the same track, the best lap of this Mission Race was always in the list.
 
163
Italy
Isola della Tontola
I tested a 2 laps replay and it worked. Amazing!!! Thanks again for this workaround.
Regarding the races...once i had a replay of a Mission Race and when i wanted to load a ghost on the same track, the best lap of this Mission Race was always in the list.

Notice that with Save Best Lap Replay it is possible to get the best overall lap ghost no matter how many times you exit and start again, or pause and retry the session without setting a faster time. With Save Replay it's different, in order to get the best lap ghost to load you must save that replay before any new Start or new Retry.
 
Last edited:
13
Australia
Brisbane
I just had an Arcade Time Trial session at the Redbull Ring: saved a couple of Best Lap Replays and as usual the loaded ghost doesn't show up, then - just out of curiosity - I saved the whole replay and surprise-surprise, the ghost works like a charm. Apparently this is a Save Best Lap Replay bug: clicking on Save Replay (the whole lap sequence) will give the best lap ghost to load anyway, and this time fully functioning. It maybe needs to be confirmed in more different tracks and cars but it seems the only fix to this problem is to use the "Save Replay" option.

Thanks for that workaround -- works for me I tried 3 different tracks, only 4 laps each, swtiched off and then back on, and each ghost loaded up. I saved the full replay and then saved the best lap replay, now I get two entries for each track, due to the two saves.
 
163
Italy
Isola della Tontola
Thanks for that workaround -- works for me I tried 3 different tracks, only 4 laps each, swtiched off and then back on, and each ghost loaded up. I saved the full replay and then saved the best lap replay, now I get two entries for each track, due to the two saves.

:cheers:
I did the same, saving first the full replay and then the best replay, two ghosts listed to load and the first looked to be always the right one, but 1 day later it turned out to be in the 2nd line, maybe there's no way to be sure you're loading the visible ghost - so I deleted the single best laps in my library.
Had some issues at Autopolis, the ghost was clearly behind me on the finish line but the new time was a couple of tenths slower :confused:. However, I don't know, that could be a common glitch even for those having no problems with the best lap replay...
 

seadog777

Premium
2,149
Malaysia
Iskandar
seadog777
I'm suddenly having this issue on Circuit Experience (where I am trying to get my last gold!).
The ghost load seems to work but when I go to ghost settings the option to use the one I loaded is greyed out.....
 
163
Italy
Isola della Tontola
I'm suddenly having this issue on Circuit Experience (where I am trying to get my last gold!).
The ghost load seems to work but when I go to ghost settings the option to use the one I loaded is greyed out.....

I tried the first time attack at Kyoto-Miyabi: in Ghost Settings the only option not greyed out is "Display Personal Best Ghost". Other 3 options greyed out: Display Loaded Ghost (On by default), Ghost Offset Seconds (1.0), Reset Ghost Position (Off). No problems here, loaded 3 ghosts, all of them working fine, the only thing is that the Offset Seconds looks to be 0.0, not 1.0.
 

seadog777

Premium
2,149
Malaysia
Iskandar
seadog777
I tried the first time attack at Kyoto-Miyabi: in Ghost Settings the only option not greyed out is "Display Personal Best Ghost". Other 3 options greyed out: Display Loaded Ghost (On by default), Ghost Offset Seconds (1.0), Reset Ghost Position (Off). No problems here, loaded 3 ghosts, all of them working fine, the only thing is that the Offset Seconds looks to be 0.0, not 1.0.

Thanks, I will check again and see what can be done..... would really like the ghost as it's only 2 seconds off gold at Nordschleife full lap. If I can keep ahead of it I stand a better chance. :lol:
 
201
Portugal
Lisbon
I just had an Arcade Time Trial session at the Redbull Ring: saved a couple of Best Lap Replays and as usual the loaded ghost doesn't show up, then - just out of curiosity - I saved the whole replay and surprise-surprise, the ghost works like a charm. Apparently this is a Save Best Lap Replay bug: clicking on Save Replay (the whole lap sequence) will give the best lap ghost to load anyway, and this time fully functioning. It maybe needs to be confirmed in more different tracks and cars but it seems the only fix to this problem is to use the "Save Replay" option.
Does this work in Sport Mode, with the leaderboard ghosts?