Fanatec - which order to connect before firmware update?

  • Thread starter FieldMat
  • 4 comments
  • 1,747 views
27
United States
United States
I got a GT DD Pro and Clubsport V3 pedals today, my first Fanatec products. My question is about the order in which to connect things before doing the firmware upgrades. Manuals are not clear enough on this; couldn't find answer on Fanatec FAQ and despite live chat showing available, it times out and says nobody is available.

Option 1: Connect the wheel and pedals to the drive, connect it to the PS4, switch everything on, connect to laptop and do the firmware upgrade.

Option 2: Connect the wheel and pedals to the drive, DO NOT connect it to the PS4, switch it on, connect to laptop and do the firmware upgrade.

Option 3: Connect ONLY the wheel to the drive, switch it on, connect to laptop and do the firmware upgrade. Then connect the pedals to the laptop and do the firmware upgrade. Then connect the pedals to the drive.

Some other option?

Grateful for any help, thanks.
 
833
JeffKill77
JeffKill
I have 2 sets of V3 pedals that won’t accept the firmware update 1.32. I’m using driver 439 and I’ve updated all my wheels, and the DD Pro base with no problem. The pedals on the other hand just won’t update. I only have the USB to PC connected (never connected USB and RJ12 at the same time).

I have an RMA for the first set already but just wondering if anyone else is having the same problem? It really is a simple process, so I don’t see why the update fails every time.

The pedals work just fine but I’m guessing it’s only a matter of time till the old firmware causes a problem.

EDIT:

Nevermind. Brought the pedals with me to work today and the firmware update went through with no problem on my pc here. Not sure why everything else updates with my laptop but the pedals wont.
 
Last edited:
1,730
United States
Illinois
no1needs2perish
I have 2 sets of V3 pedals that won’t accept the firmware update 1.32. I’m using driver 439 and I’ve updated all my wheels, and the DD Pro base with no problem. The pedals on the other hand just won’t update. I only have the USB to PC connected (never connected USB and RJ12 at the same time).

I have an RMA for the first set already but just wondering if anyone else is having the same problem? It really is a simple process, so I don’t see why the update fails every time.

The pedals work just fine but I’m guessing it’s only a matter of time till the old firmware causes a problem.

EDIT:

Nevermind. Brought the pedals with me to work today and the firmware update went through with no problem on my pc here. Not sure why everything else updates with my laptop but the pedals wont
No surprise. I’ve had to uninstall driver software and do it all over again (not with your exact dilemma). I cringe every time I update. On v434 now, but before that, I was constantly reverting to v381 due to undesirable issues … Need to update to v439 but, you guessed it, I’m cringing.