intermittent acceleration on straights with or without Traction Control

  • Thread starter Gmfowler
  • 3 comments
  • 661 views
6
United States
United States
I am losing speed on the straights because I am not getting the full acceleration that should be happening. This happens with and without traction control. Sometimes it doesn't but a lot of the times it does. I am using a Logitech G29 (it is 3-4 years old) Is it a mechanical malfunction with my pedal? This is happening at speed thru gears 3-5 and I don't think it is wheelspin because I can sense that.

Any thoughts?

Thanks in advance, Greg
 
392
Czech Republic
North Bohemia
When you're full on throttle, is the throttle indicator on the digital dash white all the way up or not? If it's not then it's definitely a throttle input issue in my opinion. Try a couple of laps or races with the controller and if it doesn't happen then it is the throttle pedal. The potentiometer in it is probably dirty and cleaning it with some contact cleaner might help. Worst case scenario, it is worn out and is eventually going to die completely.
 
Last edited:
6
United States
United States
When you're full on throttle, is the throttle indicator on the digital dash white all the way up or not? If it's not then it's definitely a throttle input issue in my opinion. Try a couple of laps or races with the controller and if it doesn't happen then it is the throttle pedal. The potentiometer in it is probably dirty and cleaning it with some contact cleaner might help. Worst case scenario, it is worn out and is eventually going to die completely.
The bar fluctuates. I think your explanation is correct.
 

Pigems

Premium
8,214
Canada
Canada
The bar fluctuates. I think your explanation is correct.

If cleaning doesn’t work, swap the gas and clutch pedals, the clutch doesn’t need to work full press, and then it cost no money to fix. Just make sure to swap the springs too, when you do it. 👍
 
Last edited: