Logitech Driving Force GT Issue

492
United Kingdom
United Kingdom
TheEvstar
I got my old wheel (A simple Logitech Driving Force GT) out from under my desk to play some good ol' GT6 with it oly to find that when I plugged it in, the wheel didn't spin round like it usually does when turned on. The buttons work but the steering doesn't. I've tried using different USB ports, i've tried plugging it into the mains first before the usb port. I've just ordered a new AC adapter to see if that could fix the issue. What should I do if it doesn't? Can anyone here help me?

Thanks for reading.
 
192
United States
Earth
I got my old wheel (A simple Logitech Driving Force GT) out from under my desk to play some good ol' GT6 with it oly to find that when I plugged it in, the wheel didn't spin round like it usually does when turned on. The buttons work but the steering doesn't. I've tried using different USB ports, i've tried plugging it into the mains first before the usb port. I've just ordered a new AC adapter to see if that could fix the issue. What should I do if it doesn't? Can anyone here help me?

Thanks for reading.

Have you tried connecting it to a PC and testing it there (logitech software if you don't have games specifically)?
But you are on the right track. A multimeter reading on the power supply may have saved you a bit of guessing before ordering a new one though. If it's not the power supply, then you are in for some technical tearing apart and chasing things down to the motor. It has been a while since I have been dealing with that wheel, but there were a lot of great threads on here about common issues with that wheel that might save you some guesswork. Just use the search.
Good luck.
 

CBH

Premium
7,566
Australia
Adelaide
fordlaser777
I got my old wheel (A simple Logitech Driving Force GT) out from under my desk to play some good ol' GT6 with it oly to find that when I plugged it in, the wheel didn't spin round like it usually does when turned on. The buttons work but the steering doesn't. I've tried using different USB ports, i've tried plugging it into the mains first before the usb port. I've just ordered a new AC adapter to see if that could fix the issue. What should I do if it doesn't? Can anyone here help me?

Thanks for reading.
Have you looked at the connection that your AC lead goes to your wheel ? If you check all connection and it still does not work it looks like the AC adaptor problem because I had a issue a few years ago with my wheel, the buttons worked on the wheel but the wheel did not spin. So I brought a new AC adaptor problem solved, and if your new adaptor does not fix well there is an issue with your wheel, but I hope it is an adaptor issue.
 
492
United Kingdom
United Kingdom
TheEvstar
I got my old wheel (A simple Logitech Driving Force GT) out from under my desk to play some good ol' GT6 with it oly to find that when I plugged it in, the wheel didn't spin round like it usually does when turned on. The buttons work but the steering doesn't. I've tried using different USB ports, i've tried plugging it into the mains first before the usb port. I've just ordered a new AC adapter to see if that could fix the issue. What should I do if it doesn't? Can anyone here help me?

Thanks for reading.

UPDATE: My fault. Turns out I was using the wrong AC adapter. It's okay now. Oopsie!