Absolutely Fed Up With This T500rs

Discussion in 'Project CARS 1' started by DJBLITZKRIEG, May 17, 2015.

  1. DJBLITZKRIEG

    DJBLITZKRIEG

    Messages:
    170
    Location:
    Australia
    Every time I plug in my T500rs 2 things happen, followed by a myriad of others. It either calibrates off center or spot on. If it happens to be in dead center and I enter a race, then in the pre race menu, the the wheel violently jerks to the left at a 45 degree angle and stays there until i re plug in it.

    Basically I am having to plug in and un plug the wheel every time I have to leave the race and go to a menu or switch cars. This is absolute crap, I should not have to be doing this every ffffff time!! Not to mention to mega violent jerks the wheel does at the end of the races.

    If you have ever seen how the wheel is built on the inside, then you would be sure these sudden wheel jerks would surely be causing it damage. I am getting really concerned about that. Is anyone else experiencing the same crap with their T500rs?
     
    VBR, G219, Ferrari458Italia and 2 others like this.
  2. DocZorze

    DocZorze

    Messages:
    1
    Location:
    Portugal
    Yep, same problem.
     
  3. GTP Parc Ferme

    GTP Parc Ferme

    Messages:
    24
    Location:
    Scotland
    Ditto
     
    DJBLITZKRIEG likes this.
  4. psychoazubi

    psychoazubi

    Messages:
    1,433
    Location:
    Germany
    I have it too, it's a known issue. Thrustmaster released a short press statement on the release they saying they are working on it with SMS
     
    DJBLITZKRIEG likes this.
  5. Fanapryde

    Fanapryde

    Messages:
    3,424
    Location:
    Belgium
    Count me in too.
    But if and when it works, it is really good, a lot better than it is (was) in the GT series.
     
    Ferrari458Italia likes this.
  6. DRambo

    DRambo

    Messages:
    349
    Location:
    United Kingdom
    My t300rs is off to the left by about 10 degrees, but only whilst racing. Very annoying.
     
  7. Fanapryde

    Fanapryde

    Messages:
    3,424
    Location:
    Belgium
    Wouldn't it be better to put this in a T300 topic ?
    I mean, OP started it for T500 and it is easier to scroll to the topics if this would apply to this wheel, no ?
     
    forspeedsake likes this.
  8. forspeedsake

    forspeedsake

    Messages:
    15
    Location:
    Australia
    yes having the same problems .i think they new about this problem before realise. might be a bigger fault then they let on .after two and a half weeks no resolve .just might be unfixable for them ? sms .if any one has a setting for this wheel what actually works on ps4 only please post here .dont want to spend any more money on a 300 .spent enough on this game already. a driving sim on controller lol
     
    DJBLITZKRIEG likes this.
  9. DJBLITZKRIEG

    DJBLITZKRIEG

    Messages:
    170
    Location:
    Australia
    I know on the T500 you can press select+start+mode at the same time whilst centering the wheel to reset the position.
     
    Brit999 likes this.
  10. Scheer

    Scheer

    Messages:
    99
    Location:
    United Kingdom
    I know we're in the wrong thread but mine was the same until I did this:

    1) Connect the racing wheel's USB cable (on PS3/PS4 or on PC), then wait for the auto-calibration phase to end. 2) Turn the racing wheel fully to the left (until you reach the stop). 3) Turn the racing wheel fully to the right (until you reach the stop).

    4) Make sure that your racing wheel is perfectly centered ; while holding it in this position, press the START, SELECT & MODE buttons simultaneously : * PS & GT WHEEL = « SE + ST + MODE » * F1 WHEEL = « BO + WET + MODE »

    * 458 CHALLENGE GTE WHEEL = « SCROLL + RIGHT LEVER + MODE »

    5) The racing wheel's LED briefly changes colour, then reverts to its initial colour. This means that the wheel's center value has been reset and automatically saved to the device's internal memory (you do not need to repeat the procedure every time you connect the racing wheel); this applies to all of the T300's wheels (PS, GT, F1, 458 GTE, etc.).

    ETA Do this out of game in the PS menu.
     
    TheClarky and Ledbetter like this.
  11. Fanapryde

    Fanapryde

    Messages:
    3,424
    Location:
    Belgium
    Well, good news for a change:
    Today my T500RS was fine, no problems at all, for 4 hours in a row :bowdown:

    Normally when opening the game, the wheel calibrates left/right, then stops about 20° to the left.
    Today not, perfectly in the middle to my surprise. Did several races in career, some invitationals, some free practice and the wheel stayed perfect, no humming, no own life, not trying to smash my fingers.
    Somebody heard about changes made ?
    Or have I been just lucky ?
     
    DJBLITZKRIEG likes this.
  12. Fanapryde

    Fanapryde

    Messages:
    3,424
    Location:
    Belgium
    Lucky I guess... :nervous:
    Today, same old problems.
    Wonder how that is even possible... ?
     
  13. teo72

    teo72

    Messages:
    39
  14. Ferrari458Italia

    Ferrari458Italia Premium

    Messages:
    1,199
    Location:
    United States
    It's a shame how buggy this game is. Such a quality game (imho), but these bugs really annoy me.
     
    DJBLITZKRIEG likes this.
  15. Fanapryde

    Fanapryde

    Messages:
    3,424
    Location:
    Belgium
  16. DJBLITZKRIEG

    DJBLITZKRIEG

    Messages:
    170
    Location:
    Australia
    Luckiest man on the internet!
     
    priesty_lfc likes this.
  17. Fanapryde

    Fanapryde

    Messages:
    3,424
    Location:
    Belgium
    For one day...:rolleyes:
     
  18. jake fangio

    jake fangio

    Messages:
    3
    Hey guys,I wouldn't hold your breath.I had the T300 and it lasted two weeks.It went back too Argos and I got a refund.I'd read about thrust masters poor customer service and crap build quality after I got the wheel!.Luckily I'm on the Pc,so I got a DFGT and it's works like a dream.
     
  19. Fanapryde

    Fanapryde

    Messages:
    3,424
    Location:
    Belgium
    TM's customer service is impeccable, in Europe this is, don't know overseas.
    TM is top quality and certainly not "crap build".
    The issues we have (maybe you should have read the topic before posting your answer) are not TM 's fault, but SMS Project cars related. Fanatec wheels have also problems with it, be it different ones.
     
    Brit999 and rclark83 like this.
  20. jake fangio

    jake fangio

    Messages:
    3
    Where's the T300 cost me nearly 300 pounds and broke after two weeks thread?Granted,perhaps crap was to strong a word.But I expect better durability from an expensive product.
     
    TJC_69 and Ian_83 like this.
  21. Wsp_timba

    Wsp_timba

    Messages:
    2
    I read today about 1.4 patch in pcars, but i dont see anything about our wheel's problem.
    About fanatec problems solved yes, but t500???????
    Are thrustmaster t500 a Black shep?????
    I dont understand
     
  22. Fanapryde

    Fanapryde

    Messages:
    3,424
    Location:
    Belgium
    It seems that PS4 users in general have to wait for patches.
    T500 works fine on PC (or so I read) and this might be the reason that they find this less urgent.
    In the meanwhile, PS4/T500RS users are left in the cold...
     
  23. Wsp_timba

    Wsp_timba

    Messages:
    2
    But is not logic. If t500 is the king of thrustmaster, Would be funtional 100 % With all platforms
     
  24. diesel97

    diesel97

    Messages:
    1,391
    Location:
    United States
    We will have to wait and see they did say "all wheels" will have patch
     
  25. molik

    molik

    Messages:
    13
  26. TenEightyOne

    TenEightyOne Premium

    Messages:
    20,234
    I guess you can't always blame add-on vendors for that, delays may be to do with development problems at the coder's end or with certification problems at Sony's end. I certainly wouldn't be surprised to find that Sony are security-mental nowadays.

    See my previous comment .We know the TMs will talk to PC, XBox and PS4. How they do it and how they react in different software is not something TM can control, they can only advise developers.
     
  27. Fanapryde

    Fanapryde

    Messages:
    3,424
    Location:
    Belgium
    Sure, I'm aware of that. Either of them (I don't think TM can help it) or both could be blamed.
    As I see it: SMS must have "overlooked" these issues while testing, have they tested on PS4 ?
    I mean, this wheel issue is a gamebreaker and it is hard to comprehend that it has not showed up somewhere before the game was released.
    Sony for that matter should allow the use of USB button boxes (or design their own if they are that security mental).
     
    Last edited: Jun 6, 2015
    forspeedsake likes this.
  28. Fanapryde

    Fanapryde

    Messages:
    3,424
    Location:
    Belgium
    For me at least, the wheel issue is gone now.:tup:
    T500 works perfect and it seems that we are going to get the use of button boxes.
    Really happy here :dopey:
     
    VBR likes this.