Buttons not working in GTS

90
United Arab Emirates
United Arab Emirates
I'm really hoping someone can help me with this. Today GTS is not responding to the X and Y buttons on my G29 wheel and also the DS4 controller... Both G29 & DS4 work fine in the ps4 menus etc, but when I start GTS.... It's dead. In GTS the pointer moves ok (by the arrow buttons) but I can't select anything in the menus because the X button isn't working. "Options" and "Share" buttons work fine and strangely the Triangle button also works (so I can go to Scapes location - yay), but the X button doesn't work at all!!! At any time I return to the PS4 home menu everything works fine on both G29 and DS4...
I've also checked that both GTS and the ps4-pro are already updated with the latest update, and cleared the PS4 cache (removed power for 2min)...

Anyone else had this problem before?
 
Last edited:

fordlaser

Premium
7,491
Australia
Adelaide
fordlaser777
I'm really hoping someone can help me with this. Today GTS is not responding to the X and Y buttons on my G29 wheel and also the DS4 controller... Both G29 & DS4 work fine in the ps4 menus etc, but when I start GTS.... It's dead. In GTS the pointer moves ok (by the arrow buttons) but I can't select anything in the menus because the X button isn't working. "Options" and "Share" buttons work fine and strangely the Triangle button also works (so I can go to Scapes location - yay), but the X button doesn't work at all!!! At any time I return to the PS4 home menu everything works fine on both G29 and DS4...
I've also checked that both GTS and the ps4-pro are already updated with the latest update, and cleared the PS4 cache (removed power for 2min)...

Anyone else had this problem before?
Have you gone to your DS4 & Wheel settings in game, and have a look at your figuareting for the X button ?.
 
Last edited:
90
United Arab Emirates
United Arab Emirates
Have you gone to your DS4 & Wheel settings in game, and have a look at your figuareting for the X button ?.
Sorry, I should have mentioned, it's been working fine for 2 years and only stopped yesterday. I haven't checked the button mappings in GTS because I can't navigate to that screen without the X button :-(
 

fordlaser

Premium
7,491
Australia
Adelaide
fordlaser777
Sorry, I should have mentioned, it's been working fine for 2 years and only stopped yesterday. I haven't checked the button mappings in GTS because I can't navigate to that screen without the X button :-(
Ok. disconnect the wheel from your PS4, and see what happens ?.
 
90
United Arab Emirates
United Arab Emirates
Ok. disconnect the wheel from your PS4, and see what happens ?.
Yes I have disconnected and reconnected several times and the problem persists. Also the same problem is happening with the DS4 controller i.e. Only in GTS the buttons aren't working, in the rest of the PS4 everything works fine

UPDATE!!! Today everything works fine... I didn't nothing different, but it's all working fine today. Maybe it just needed a day off
 
Last edited:

fordlaser

Premium
7,491
Australia
Adelaide
fordlaser777
Yes I have disconnected and reconnected several times and the problem persists. Also the same problem is happening with the DS4 controller i.e. Only in GTS the buttons aren't working, in the rest of the PS4 everything works fine

UPDATE!!! Today everything works fine... I didn't nothing different, but it's all working fine today. Maybe it just needed a day off
Most likely a couple of gremlins in GT Sport.