D3 controller's face button not functioning

Discussion in 'Gran Turismo 5' started by red ice, Nov 19, 2013.

  1. red ice

    red ice

    Messages:
    756
    Location:
    Philippines
    Help! the 4 face buttons (Square, Circle, Triangle, Cross) seem to malfunction during the actual race. I've tried playing all my other games and they're ok. I've tried making a new game and its functioning. I've tried, button resets and all other combinations but is seems all buttons can be interchanged except for the 4 face buttons.
    The Only option I have is accelerating via R3up and braking via R3down.
    This happened after I updated to the latest GT5 update. I'm at Level37-A-spec, and trying to finish all endurance races...please help.
     
  2. oink83

    oink83 Premium

    Messages:
    3,493
    Location:
    United Kingdom
    What exactly happens?

    If you go the controller settings, and to the screen where you can configure the keybindings, what does it show?
     
  3. WishIwasStig

    WishIwasStig

    Messages:
    12
    Location:
    Canada
    I have that problem if I plug any non Sony device into the PS3 (cooling fan, after market remote, anything). It's weird, but if I unplug them the problem goes away. Hope that helps.
     
  4. red ice

    red ice

    Messages:
    756
    Location:
    Philippines
    it shows normally. if i choose and press X for acceleration( the default)...i can confirm and save it. But when I start to race, practice...i does not work. (Square, Circle, Triangle, Cross) works in menu, options, pre-race and even in B-spec mode. Its really weird. I think the problem was the update. Is there a way to go back one-update lower??
     
  5. red ice

    red ice

    Messages:
    756
    Location:
    Philippines
    thanks for the info. but i have the original controller, although before my brother used the Fighting Stick (non-sony) as a controller for gt5 before i updated. Probably that messed up the default controls for my game
     
  6. oink83

    oink83 Premium

    Messages:
    3,493
    Location:
    United Kingdom
    That certainly is odd. My recommendation would be don't roll back, but try a reinstall of the game. If you delete the 'game data' save for Gt5, you won't lose your progress (which Is the one saved in 'save data'). And then run the game again and it should re-install the game to your ps3. Might take a bit of time but should work.
     
    red ice likes this.
  7. red ice

    red ice

    Messages:
    756
    Location:
    Philippines
    OK...I'll try that method after work. thanks!!
     
  8. red ice

    red ice

    Messages:
    756
    Location:
    Philippines
    yes!!!! it worked. 13 hours reinstallation and its back to normal!! thanks!!! guys!! :cheers:
     
    oink83 likes this.