Decided to use the DS4 and found a few bugs.

707
United Kingdom
London
Sparks_360
So i decided to give drifting a go with the controller, (loved it in GT6) i struggle with the wheel at the moment (i'm practicing don't worry :embarrassed:). Anyway i managed to maintain the slide the first time, tried a few more times to see if i was consistent (mission accomplished) but then, as it said "go" i pressed the R2 trigger fully only for the throttle bar to go up to 40%, could brake at 100% but 100% full throttle, it wasn't happening. I tried an arcade race to see if this still occurred, same result.

I then changed the button layout to X for drive and Square for brake (Classic GT Controls), could drive at full throttle, but no modulation whatsoever...
Gran Turismo™SPORT_20171126023729.jpg


Well 50% in this case but you get the point. (R2 trigger pressed all the way)

Does this happen for anyone else???
 
1,117
Iceland
Kópavogur, Iceland
Guffaluff
Have heard this before, but in all cases it turned out to be a fault with the controller. Sounds like it. Try mapping the throttle to the right stick and see what happens, or using another pad if you have one laying around.
 

KingFrog

(Banned)
837
United States
NOYB
Your triggers are faulty. The Dualshock 4 does not have pressure sensitive face buttons since IIRC only a dozen or so games used it last gen.