Dirt rally ps4 and a little problem

Discussion in 'DiRT Series' started by Heath82, Aug 6, 2018.

  1. Heath82

    Heath82

    Messages:
    71
    hi guys, i have a little problem with this amazing game. The first time i played in the preferences i set transmission manual + clutch and sequential so i can use both according to the car i drive (like assetto corsa). In the option i had to set each single gear on my Thrustmaster t8ha and everything worked fine. When i restart the game my gear didn’t work anymore, i opened the option menu and they were already set but it didn’t work. So i tried to set gears again and it worked!! So my question is: should i set the gears every time I restart the game?
     
  2. cjr3559

    cjr3559 Premium

    Messages:
    1,899
    Location:
    United States
    It shouldn’t be necessary to set the gears every time you start the game. I have the exact same setup and don’t have any issues.

    However, I do have to calibrate my pedals when starting the game occasionally. Out of curiosity, check which controller is active (dual shock or wheel) before starting play. If DS is selected it could be the reason for the issue.
     
    Last edited: Aug 6, 2018
  3. Heath82

    Heath82

    Messages:
    71
    What do you mean? How can i check this out?
     
  4. cjr3559

    cjr3559 Premium

    Messages:
    1,899
    Location:
    United States
    Go to the control input settings of the menu and see which controller is active.
     
  5. Heath82

    Heath82

    Messages:
    71
    I still didn’t get where is this menu you are talking about.. anyway I forgot to mention that I connected both the wheel and the gears to PlayStation by usb cable.
     
  6. user3392345

    user3392345 (Banned)

    Messages:
    529
    Its little bit annoying, you have to set wheel as active input every time you start the game. Options->controlls->device managment->input device
     
  7. Heath82

    Heath82

    Messages:
    71
    Ok i’m gonna try, even if it sounds weird because my wheel works!! I just gotta set gears every time
     
    Last edited: Aug 6, 2018
  8. Heath82

    Heath82

    Messages:
    71
    Hey i tried what you advised but it doesn’t work. In the preset device i have “thrustmaster” but if i pick automatically my preferences get changed from manual+clutch or sequential to sequential. It’s like it doesn’t detect the th8a. But if i leave everything like I already set my wheel works, the paddles work, the pedals work, only manual gears don’t work. When i open controls menu all gears are already set but they don’t work unless i overwrite settings. Help me out please!!
     
    Last edited: Aug 8, 2018
  9. cjr3559

    cjr3559 Premium

    Messages:
    1,899
    Location:
    United States
    I’m no expert, but how do you have the TH8A plugged in?
     
  10. Heath82

    Heath82

    Messages:
    71
    By usb, like i do with other games too
     
  11. Heath82

    Heath82

    Messages:
    71
    Ok i found the problem: basically when I reboot dirt rally the game only detect one device, in this case the wheel. Like i said my options control preferences are set but since the game doesn’t detect what is plugged in second usb, in this case my th8a, it doesn’t work during game but if i go to pause menu during game, or in the option menu before starting a race and i overwrite each gear again, I realized that in the device input menu i have 2 devices where i had only one. From that moment on my th8a works!! So the problem is that the game doesn’t detect the second usb till i set it every time. Can it be solved some way?