GT7 Frozen on Loading Screen

  • Thread starter TFSI400
  • 11 comments
  • 17,136 views
342
United Kingdom
United Kingdom
I’ve just tried to load up the game, and it’s stuck on the black screen (see attached pic).

It’s got the white circle spinning round the GT logo, and in the bottom right hand corner ‘Saving’ is flickering.

I’m on PS4 Slim, normal disc version. Never had a single issue with the game until now.

Has anyone encountered this? Any suggestions as to the best thing to do? I’m wary of closing the application from the dashboard and save data becoming corrupted.

Help! 🙁

EDIT: I decided to close it from the dashboard. Tried again and it was fine. Is this indicative of a problem? Should I be worried?
 

Attachments

  • CF883E18-496C-4FEC-BA39-C91FB9F1F23C.jpeg
    CF883E18-496C-4FEC-BA39-C91FB9F1F23C.jpeg
    95.8 KB · Views: 139
Last edited:
Had the same issue, just waited until I decided to just restart the game. Nothing bad happened either here. Just a weird bug I assume.
 
I had that happening twice, at the first time I thought the game files were corrupted, so I redownloaded the whole thing. At the second time I turned the console off, came back a few hours later and it was fine. I have the same setup, ps4 slim, and no ideia why that happened.
 
Happened a few times already & just yesterday. An annoying bug, just restarted the game and all was well, not worried about this in the slightest.
 
PD in their past notes (1.15 or so) mentions this very problem and the temp fix was too quit and restart, says possibility of game hanging on initial startup and to quit and restart...

I have a PS4 slim and sometimes get this very same issue, and I Q&R
 
I‘ve had this happen on PS5 3 times, but not recently, they all occurred months ago. The first time I force closed the game and restarted it and it loaded fine. The 2nd and 3rd times I let it sit there for several minutes and it eventually gave up resistance and loaded. Haven’t had any issues since so I’d say no long term issues or indications something is really wrong.
 
I experience this issue every other time I launch the game. (PS4 and disc)

This past Week its gotten worse, with the game locking not once or even twice…
Previously the remedy was to reboot the program. This past week I’ve had to restart the console.

Do we - the community - know the cause behind this phenomenon yet?
Does it appear to be PS4 related for starters?
 
This happens all the time on my 2013 PS4, digital version of GT7.
I got used to it, there's no hope.

When I want to launch the game I have to watch the clock and see if I'm in time to enter the daily races.
I know that the whole process, from the moment I launch GT7 to the moment I'm able access the Sport mode screen, takes between 4 and 6 minutes.

- If the circle around the GT7 logo spins without stopping, and "saving" is flashing at the bottom for too long (I never timed it, could be 1-3 minutes), I know that GT7 is stuck and there's no hope. I'm forced to quit and restart the game. I can wait even 10-20 minutes....it never gets to the main menu.

- If the circle around the GT7 logo regularly spins and stops, like if it's "thinking", it means that the game is successfully loading.

The infinite loading also happens (rarely) when saving a design, and it's a nightmare, especially when I lose my most recents changes and the design file becomes corrupted.

I tried to completely remove and re-install the game. Nothing works. This only happens with GT7.

For the record, many times people suggest me to put the GT7 data on an external hard drive. I don't have the patience, time or money to do that. So please don't✋

-------


EDIT: I wrote this before the new update installed. I need to do some tests and see if the issue persists.

-------

EDIT 2: It persists. 🤦‍♂️
 
Last edited:
im also having this problem now on ps5.i have tried all the fixes people advice on the web but to no avail.one thing i did notice though is that if i play offline all my loading issues is gone.🤔
 
Last edited:
im also having this problem now on ps5.i have tried all the fixes people advice on the web but to no avail.one thing i did notice though is that if i play offline all my loading issues is gone.🤔
Reset your router? Also, sometimes it takes longer and you have to just let it load.
 
Back