GTSport with Thrustmaster Sparco R383?

Discussion in 'Gran Turismo Sport' started by UrieHusky, Jun 10, 2020.

  1. UrieHusky

    UrieHusky Premium

    Messages:
    3,448
    Location:
    Australia
    Hey everyone, I'd really appreciate your assistance with a problem which has completely depleted my patience

    I'm trying to play GT Sport with my Thrustmaster T300RS which has been fitted with the Sparco R383 wheel mod.
    Their website and general results from the internet say this combination should be plug and play but it has been anything but for me..

    All buttons are correctly recognised on PC, however none of the face buttons work on the PS4 (such as the PS button for example), nor do the paddle shifters.

    I have tried both PS4 and PS3 modes, Further testing is showing if I unplug the wheel, set it to PS3 mode then plug it in, I am able to consistently have steering, throttle and brake inputs recognised, however when holding the clutch and accelerator in simultaneously, the car accelerates normally and I am unable to change gear or use any face buttons on the wheel.

    I also use the TH8A H pattern shifter, however I disconnected that to try and eliminate as many variables as possible

    The wheel synchronize as you would expect and has proper force feedback when it does work, the pedals are correctly recognised as well (although I am unable to tell if the clutch is being recognised)

    I'm at my wits end, I've scoured the internet for any help on this topic and have tried everything, firmware is up to date (30) and I've tried multiple times trying to eliminate it as a possible factor.

    Everyone is quick to respond how it worked "perfectly for them" which has been less than helpful..

    I have not attempted to use the default T300RS GT edition wheel, I do have it but given the delicate nature of the interface I don't really want to be changing wheels back and forth
     
  2. RussRobit

    RussRobit Premium

    Messages:
    352
    Maybe the wheel needs to be updated on a pc? The clutch only works on cars that have a manual transmission installed. The shifter and clutch are disabled in sport mode. That's all the help I can offer.
     
  3. UrieHusky

    UrieHusky Premium

    Messages:
    3,448
    Location:
    Australia
    Hi Rob

    As stated in the OP, the wheel has been updated on PC to the latest firmware and has been triple checked to ensure it is definitely updated

    The car in question was a standard MX5 ND, I tried multiple other cars too and I was testing this in time trial mode in the arcade
     
  4. RussRobit

    RussRobit Premium

    Messages:
    352
    I found a post on race department sounds like the same problem. It's dated Dec./19. It says the firmware should be 9. Make sense to you?
     
  5. UrieHusky

    UrieHusky Premium

    Messages:
    3,448
    Location:
    Australia
    Current firmware is 30, my firmware is up to date :)