Issue with my internet speed on the Ps4

  • Thread starter ionstriker
  • 14 comments
  • 8,853 views
355
ionstriker
Hey all, so I have a 100mbps connection. I checked my internet connection speeds through a speed test app and it's all fine and shows as being around 95mbps. But when I test the internet connectivity on the console it says my download and upload speeds are around 8-10mbps. This started to happen quite recently. The speeds shown on the console used to be the same as that on the app. And my downloads used to go at 10-12mbps. But now it's stuck at around 1.5-2mbps. I haven't changed any settings as well. Any idea why this is happening? Do I have to change any router settings? Also I'm on a wired connection. Thanks!
 
Last edited:

Rallywagon

what a long strange trip
Premium
7,689
United States
Michigan
Rallywgn81
There could be a number of factors outside of your control. While you may be paying for 100Mbps, its not guaranteed you will get that. Network bandwidth has a top limit going from your house to the headend. and the depending on saturation, you may be bottle necked from the headends CMTS out to the ISP's network. Not to mention any caps they may or may not be artificially creating because of expansion, or just because.
If you are using a coax cable modem, you might try backing off the RJ6 connector a thread or two, giving the cable a twist back and forth a bit, then retightening the connector at all of the ends you can reach, then power cycle all of your network equipment (modem, switches, routers, etc.) Test your connection at several different times during the day using several different methods, I am willing to bet you will see different results throughout the day especially around peak usage times 4-8pm on weekdays and starting around noon on weekends.
If I had to guess, I'd say you issue isnt your issue at all, and it's the ISP.
 
355
ionstriker
There could be a number of factors outside of your control. While you may be paying for 100Mbps, its not guaranteed you will get that. Network bandwidth has a top limit going from your house to the headend. and the depending on saturation, you may be bottle necked from the headends CMTS out to the ISP's network. Not to mention any caps they may or may not be artificially creating because of expansion, or just because.
If you are using a coax cable modem, you might try backing off the RJ6 connector a thread or two, giving the cable a twist back and forth a bit, then retightening the connector at all of the ends you can reach, then power cycle all of your network equipment (modem, switches, routers, etc.) Test your connection at several different times during the day using several different methods, I am willing to bet you will see different results throughout the day especially around peak usage times 4-8pm on weekdays and starting around noon on weekends.
If I had to guess, I'd say you issue isnt your issue at all, and it's the ISP.
Well I don't know most of what you're talking about, but this only started happening recently. That's why I'm trying to figure out what happened. Like last month when I use to check the speeds on the console, the download and upload speeds were about 93-95mbps. But just for this month it seems to be down to 9-10mbps. Everything else seems to be fine though. The speeds are even normal when I'm checking through the pc. They stay at 93-95 consistently.
 

Rallywagon

what a long strange trip
Premium
7,689
United States
Michigan
Rallywgn81
Ahhh. More input!
If this slow down is only through the PS then the blame likely is Sonys. I've had 75 Mbps or better for over 5 years, I've never seen my PS3 or 4 go over 15 Mbps when testing the connection. While more and more data centers are uncapping their bandwidth as speeds and capacity increase, high demand networks like Sony would be running generally cap at about 10-15 Mbps to keep their networks from becoming over saturated, meaning more people pulling data than the network can handle.
If you are seeing normal speeds across your network, other than the PS, then your network is not likely the culprit.
However, if you have some patience and decent comprehension skills, you can try putting your PS into what is called a DMZ. This will place its connection before and security features, freeing it from that overhead. A quick search for "DMZ my PS4" will get you going.
Otherwise, as long as your network is working as it should, there isnt much you can do since it's not likely your equipment causing the slow down.
 

LeGeNd-1

Premium
6,805
Australia
Australia
GTP_LeGeNd-1
I have a 100 Mbps connection and the fastest PS4 download speed I've seen in "Test Connection" is 15 Mbps (wifi or wired doesn't matter). During evening peak hours and weekends it drops down to single digits. All my other devices can hold 20-60 Mbps during off peak and 10 Mbps during peak. I've gone through various troubleshooting with my ISP and no cigar. I guess Sony servers are just borked or there is a particularly bad bottleneck between my place and wherever the nearest Sony server is.

It sucks because GT Sport seems to require 100% pristine connection to have smooth gameplay. Even the menus lag like hell whenever the speed drops.
 

Rallywagon

what a long strange trip
Premium
7,689
United States
Michigan
Rallywgn81
It's not a bottle neck, just an artificial bandwidth limit to keep their data centers DCN from getting swamped.
Remember, they are dealing with a huge volume of connections every day. 10 to 100s of thousands of connections.
 

LeGeNd-1

Premium
6,805
Australia
Australia
GTP_LeGeNd-1
Well, it's an artificial bottleneck then. It's been getting even worse as well. Last year GT Sport menus were silky smooth but nowadays during peak hours it can take up to 5 minutes to open the main menu. If their servers can't keep up then maybe they should invest in more infrastructure? Otherwise playing their games becomes more of a chore than fun. First world problems I know.
 
204
Netherlands
Netherlands
I'm experiencing the same issue in the Netherlands.
My ISP (cable) promises 200/20Mbit down/up, but the past few weeks, testing the internet through the test internet function on the PS4 I averagely get about 20-50Mbit down and 2-5Mbit up, that's 10-25% of what my connection allows, in GT Sport I get thrown out of sessions because I lost connection pretty often.
I have a very solid connection, doing a test on speedtest.net I always get up to 200/20Mbit d/u when I find a good server, and a speedtest from my ISP gives me 200/20 all of the time, even if I do the tests through the browser on my PS4, so I'm guessing it's not my PS4 or my network.
I guess it's simply because the amount of PS4 owners keeps on growing and PSN needs more or faster servers to handle the increasing amount of connections.

And it is indeed something from the past few weeks/month

More info: My PS4 is in DMZ on my modem (static IP), tried a proxy, tried changing the MTU size, tried different DNS servers, nothing seems to help.
 
Last edited:
2,913
England
UK
phil_75
Slightly different but In Sport Mode menu there is a "Test Connection" option in the top left corner but it doesn't and has never worked, stating something like "Not available please try later" yet browser speedtest and PS4 network menu speedtests work fine.

Is it just me or does this not work for others?
 

Rallywagon

what a long strange trip
Premium
7,689
United States
Michigan
Rallywgn81
Sadly, its neither an easy nor cheap venture to fix the speed/congestion issue. Best case scenario is that just the skiffs DCN is over saturated, which would only require the expansion to a new skiff in a colo (this is a data center (DC) that rents out space, very common). If it's the fiber "pipeline" feeding the whole DC or the whole DCN that is saturated, that is going to require city, county, state permits and millions of dollars, possibly a whole new facility to facilitate. And that is before we talk about the equipment. Network switches, servers, storage arrays. A single storage array housing a few petabytes of data is easily a million+, and several would be needed to balance loads. Similar numbers would be required for the rest as well. This might be easy money for Sony to cough up, but it's likely outside of PD's budget if they are not allowed to run in Sonys environment.
 

LeGeNd-1

Premium
6,805
Australia
Australia
GTP_LeGeNd-1
Slightly different but In Sport Mode menu there is a "Test Connection" option in the top left corner but it doesn't and has never worked, stating something like "Not available please try later" yet browser speedtest and PS4 network menu speedtests work fine.

Is it just me or does this not work for others?

You need to run at least one race for this to work. People say you can even enter a random lobby and back out but I haven't tested this.

Ever since the region locking update, my ping have improved dramatically (from ~200 to ~20), however the parameter pentagram hasn't changed (still shows parameter 1 lowest). Race quality, haven't really noticed any difference either. Menus still slow during peak hours. Still getting lots of random disconnections from lobby +/- error CE 34878-0.
 
355
ionstriker
Ok so I seem to have fixed the issue. Don't really know how though. I changed a couple of settings on my router to check if it would help but it didn't. So I reset those settings back to default and voilà it started working fine. Now I'm getting the speeds that I am supposed to be getting. Not really sure what the issue was though
 
204
Netherlands
Netherlands
Ok, well my situation hasn't changed much, but I get very various speeds, ranging from 20-90Mbit down and 1-10Mbit Up. Very inconsistent speeds. It can be 20Mbit one moment, and 90Mbit the other, then back to 20Mbit another moment later.
I've even had contact with my ISP and they said it might be the modem, so they sent a newer one which should work better, but for my PS4 it makes no changes.

Just noticed the PS4 and PS4 pro both had a price-drop of €100, so now €199 and €299, this will surely sell tons of PlayStations these holidays, I hope PSN is prepared to take another few million connections.
 
142
United Kingdom
London
FAST-CLAIM
I find the Lobby and it’s races very difficult to connect to or sometimes impossible, it’s really poor. The GT Sport mode seems to be fine but the connection to the servers in the Lobby is crap. This isn’t an ISP issue it’s the game servers not being up to the job IMO.