Logitech G923, loud plastic noises

  • Thread starter Greycap
  • 1 comments
  • 2,817 views

Greycap

The Flying Finn
Premium
5,653
Finland
Finland
Either I'm having some terrible luck with this (well, these) thing(s) or something else is going on. In short, I'm now on my second G923 in three weeks and it's still not looking - or actually sounding - good.

The first one sounded like this.


The official Logitech support was completely useless, I offered them the video and a description about what's happening, and they didn't even look at the video. They didn't in any way acknowledge what I told them. The best they could do was "disconnect the wheel and reconnect it again" and a troubleshooting list for the G Hub software. Then I contacted @LOGI_Rich here and the response was miles better.

Eventually I took the wheel back to the retailer, filed a warranty claim, and surely enough it was broken as I got a new one with no more questions asked. Well... it sounds like this. Further descriptions in the videos on the YouTube site.


My old G25 which I bought in 2007 and which got me through GT4-HD-5P-5-6-Sport has been tortured nearly daily over a span of 13 years, it's done some 400.000 km and that's a conservative guess, and it doesn't sound like that. It rattles a bit as it's certainly not in pristine condition anymore but it doesn't sound like someone is hitting something with a hammer inside.

I'm not terribly amused anymore. If this is the actual quality of the current flagship Logitech wheel, it's a very grim situation. If I managed to get a second defective example in a row, something is very wrong with the quality control.
 

Greycap

The Flying Finn
Premium
5,653
Finland
Finland
This case got closed for me. The second one was also replaced under warranty. I then received a third wheel, it clattered just as bad as the previous two, and at that point I called the game over, took the refund and ran.

The retailer told me that there's another customer going through a similar warranty loop with a G29, with similar symptoms. It seems like there's been a bad batch of some component and the entire production blocks may be affected. I may have another try some day but for now I'll keep going with the old G25 that still behaves better.