Please Help! GT SPORT has become unusable!

16
South Africa
Johannesburg
I dont know where else to try and get help other than here. I have had GT SPORT for nearly a year now and all of a sudden it has become very laggy in terms of online racing and menus. The game has become borderline unusable and very annoying. If anyone can help me please do!
 
1,018
United States
Phoenix, AZ
MonyB
For starters, give us more info on your network setup. Also, run some speed tests from another device on your network as well as your PS4. That'll help isolate if the issue is your PS4 or the larger network.

I'm assuming you've already done this but I'm going to say it anyway: powercycle everything in your network, then restart them in order of modem, router, playstation (make sure you powercycle the PS and not just rest mode it).
 
16
South Africa
Johannesburg
For starters, give us more info on your network setup. Also, run some speed tests from another device on your network as well as your PS4. That'll help isolate if the issue is your PS4 or the larger network.

I'm assuming you've already done this but I'm going to say it anyway: powercycle everything in your network, then restart them in order of modem, router, playstation (make sure you powercycle the PS and not just rest mode it).
Thanks for responding.

Okay so to begin with my current setup is a PS4 Slim 500GB.

My internet runs regularly at 85Mbps down and about 12Mbps up (not bad for South Africa)

So I Googled the issue and I was told to clear my caches.

So first I unplugged my modem and hard reset it back to factory settings.

I then turned off my PS4 and unplugged it for 2 minutes as I was told to.

I then plugged the PS4 back in and booted it up.

Then I was told to launch the game and whilst it was loading to hold R1 + L1 (as this would clear the games cache)

I did so and yet the game was only running a tiny bit better.

I was disconnected during a league race due to a crash not much later on.

I have reached out to different forums and chats and I have been told to let my entire garage load in first. (As before I could not see any of my Vehicles)

So at this moment I am waiting for all 252 of my Vehicles to load and I will see if that helps.
 
41
Germany
Germany
I don't know, if this might be a solution for you, but try this:

Fire up GT Sport, push the PS4 button to back out into the PS Menu
Go to Network Settings and disconnet your Internet Connection
Immediately reconnect and go back into GT SPORT

This solved my laggy menu...
 
16
South Africa
Johannesburg
You can also clear the network cache in the game‘s settings
I have done this multiple times unfortunately...

I don't know, if this might be a solution for you, but try this:

Fire up GT Sport, push the PS4 button to back out into the PS Menu
Go to Network Settings and disconnet your Internet Connection
Immediately reconnect and go back into GT SPORT

This solved my laggy menu...
I will give this a shout. I have now "updated" my garage and all cars are viewable, only took about 2 and half hours.
 
Last edited by a moderator:
386
Czech Republic
North Bohemia
Digital or disc version? I think a week back or so I came across a thread where someone had a similar issue with the game being very slow, freezing and such and it was a dirty (or scratched) disc. Who would've thought, right?
 
Last edited:
289
South Africa
South Africa
Riptide065
LMP Riptide
This problem is currently experienced throughout South Africa by most ISP's using Telkom's Openserve as a result of an underwater cable issue near the coast of Western Africa as well as close to the UK. ISP's like AXXESS, Afrihost, WebAfrica and a few others are currently re-routing internet while others have bought more broadband, but none can currently completely escape the effects of the cable issue.

The effect of the above is, unless your IPS has bought more broadband, a drop of 60% in internet speeds, heavy and regular spikes with latency of above 2500 reported as well as huge packet loss.

Unfortunately there's nothing you can do about it for now. I'm staying in South Africa on the south coast and experience exactly the same problems you have described. If none of the advice in this thread worked for you, then you're just one of a million South Africans facing the same issue.

You can google "Wasc internet cable" and "Wacs internet cable" and read all about the latest development on this.

Lets hope this get sorted soon
 
Last edited:
1,207
United Kingdom
United Kingdom
breeminator
breeminator
Digital or disc version? I think a week back or so I came across a thread where someone had a similar issue with the game being very slow, freezing and such and it was a dirty (or scratched) disc. Who would've thought, right?
And just in case the OP has their console in a vertical position, I've read that tends to cause the disc to become scratched over time, as any movement or knock of the console can move the disc enough to collide with an internal part.