Received my Drivehub. Couple questions.

Discussion in 'Sim Racing Hardware' started by nhraracer, Feb 7, 2019.

  1. nhraracer

    nhraracer

    Messages:
    80
    Hello all. Received my Drivehub today. It's very simple to use and has ffb. Does anyone have a button map setup for the csw v2 with Forza rim? I'm trying to figure out how to map things and i don't know which button correspond to the ps4 buttons. Any help greatly appreciated. Thanks
     
  2. GTPorsche

    GTPorsche

    Messages:
    20,977
    [​IMG]

    This might help for the face buttons. Everything else should be straightforward.
     
  3. nhraracer

    nhraracer

    Messages:
    80
    Thanks GTPorsche. I set it up using the Fanatec csl in game and it's still mapped to the large xbox button for look left, right and rear view even though i set it for the b, y and x button. Weird?
     
  4. GTPorsche

    GTPorsche

    Messages:
    20,977
    I know for my wheel with the drivehub, I use the G29 configuration in game, but mine isn't a CSL so I don't know if that makes a difference or not.
     
  5. gt_fan

    gt_fan Premium

    Messages:
    247
    Location:
    Australia
    With the drivehub on ps4, you can use Fanatec or Logitech emulation. When you first connect the drivehub to the ps4, look at the display on the wheel - for my Forza Hub, it displays 'F' for Fanatec or 'L' for Logitech. This will tell you if you need to go to the CSL settings or G29 settings in GT Sport. hth.
     
  6. nhraracer

    nhraracer

    Messages:
    80

    I tried that. The only thing my forza hub shows is a small "n". I'm lost. Thanks for helping.
     
  7. gt_fan

    gt_fan Premium

    Messages:
    247
    Location:
    Australia
    Also, make sure your drivehub has the latest firmware.
     
  8. nhraracer

    nhraracer

    Messages:
    80
    I just did a firmware update and it did update. Now i neither show the small "n" or anything at all. Ugh.

    EDIT:
    Ok. I just reran the update. I now have a proper working drivehub. I switched it to Fanatec mode and the : "F" shows up for a moment when i start the wheel. Here is the weird part. In Fanatec mode the video of the steering wheel in game is really slow in movement. When i put it in Logitec mode it goes away. Oh well, for some reason now my button mapping is where i put it. Really weird stuff. lol
     
    Last edited: Feb 9, 2019
  9. K1LLD0z3R

    K1LLD0z3R

    Messages:
    622
    Location:
    United States

    I have the same lag issue in F mode too L mode is fine though.
     
  10. nhraracer

    nhraracer

    Messages:
    80
    Hey. Make sure you are on 2.0.3 45 beta. I updated my firmware and miraculously everything is good now. Even the lag in F mode. Try it. For anyone that bought Vrally 4 i have a hint that will make the game work. You have to have another ps4 dual shock turned on. Thanks everyone for the help. :)
     
    super_gt and K1LLD0z3R like this.
  11. K1LLD0z3R

    K1LLD0z3R

    Messages:
    622
    Location:
    United States
    I’ll do it tonight. I might need to go back to driver v311 for my CSW V2 also.
     
    Phlano099 and nhraracer like this.
  12. nhraracer

    nhraracer

    Messages:
    80

    I am on 473 atm and all is good.
     
    K1LLD0z3R likes this.
  13. K1LLD0z3R

    K1LLD0z3R

    Messages:
    622
    Location:
    United States
    :cheers: @nhrarcer thanks the latest drive hub beta driver solved it.
     
    super_gt and nhraracer like this.
  14. nhraracer

    nhraracer

    Messages:
    80
    You're welcome. One thing i have found in "F" mode is that the ffb is pretty erratic and harsh at times. I went back to "L" mode. MUCH better ffb!
     
    K1LLD0z3R likes this.
  15. K1LLD0z3R

    K1LLD0z3R

    Messages:
    622
    Location:
    United States
    I totally concur. After trying F mode again the understeer effect is still a mess. And that’s to bad because now my McLaren and F1 2018 wheel rims work in F mode.

    If I have some time tomorrow I’ll play with some settings and see if I can dial that out. It’s weird how it hits in the middle of rotation.
     
    Last edited: Feb 11, 2019
  16. gt_fan

    gt_fan Premium

    Messages:
    247
    Location:
    Australia
    Are you guys running the latest firmware for your wheels? I found the link to the latest firmware in the CSL thread and it works very well for my CSW v2.5. Sorry posting from my phone, can't find link.

    Edit - using F mode.
     
  17. K1LLD0z3R

    K1LLD0z3R

    Messages:
    622
    Location:
    United States

    I’m on driver v324
     
    Last edited: Feb 11, 2019