PC Screen Tearing & Stuttering Issues

Discussion in 'Project CARS 1' started by Marcus96, May 27, 2015.

  1. Marcus96

    Marcus96

    Messages:
    53
    Location:
    United Kingdom
    Hi, I have been having lot's of graphical issues with Project CARS, regarding really bad screen tearing and/or stuttering. The system that I am trying to run this on is an MSI GE60-2PF Apache Pro (which sports and Intel Core i7-4810MQ & NVIDIA GeForce GTX 860M GDDR5 2GB).

    The settings that I play the game on are 1920x1080 with everything on Medium (with the exception of Texture Resolution: High, AF: 16X & MSAA with equates to 4X AA). In terms of FPS, I normally get 45-55 or around 40 in rain.

    With VSync disabled, I have the issue where there is really bad screen tearing (roughly 1/3 of the way down the screen from the top), which is very distracting.

    When I enable VSync, the screen tearing is gone, however I have a problem where there is really bad stuttering, to the point where the game is unplayable (it looks like a yuck 20fps, despite it being 40fps).

    Accoriding to my google searches for a solution, the resolution is to enable Adaptive VSync in NVIDIA Control Panel, however my system is equiped with Optimus, meaning that Adaptive VSync is not supported by my system (this cannot be the resolution, unless there is a workaround to this).

    I tried everything, Tripple Buffering with/without VSync enabled, but no avail here!

    Does anybody have any idea of a resolution to the issues I am facing making the game unplayable. I will highly appriciate a resolution to my problem. My drivers are up to date, still makes no difference. Any ideas?
     
  2. HBR-Roadhog

    HBR-Roadhog

    Messages:
    6,318
    Location:
    United States
    Try turning down some of the settings such as detailed grass, reflections, shadows, environment.

    What is Optimus?
     
  3. Marcus96

    Marcus96

    Messages:
    53
    Location:
    United Kingdom
    Optimus is where you have Intel HD 4600 + NVIDIA GTX 860M. The NVIDIA does the rendering and the Intel controls the display. I choose the computer to use the High Performance NVIDIA Graphics for everything, however the Intel is still involved in controlling the display. This renders Adaptive VSync not supported! :(

    I tried running the game on low, the game doesn't look impressive sadly. It does get 60FPS with VSync on, however in rainy conditions, it drops to about 40FPS, so stuttering is still present. Even if the game drops to 55FPS, it looks stuttery and awful!
     
  4. HBR-Roadhog

    HBR-Roadhog

    Messages:
    6,318
    Location:
    United States
    I was getting a little stuttering from the AI cars on mine at times even when running above 60 FPS. Adaptive VSync took care of the issue.

    I would not suggest to turn everything down but if you have the grass, reflections, shadows and environment all set to medium that is a good bit of a performance hit and IMO very little in terms of better quality. You may want to turn those down, VSync off and use the -fpscap 60 command line switch in the steam settings.

    What refresh rate is your display?
     
  5. Marcus96

    Marcus96

    Messages:
    53
    Location:
    United Kingdom
    My built-in laptop display and external displays are all 60Hz. I was wondering if there is a way to cap the FPS at 30???

    This means that the GPU doesn't have to work to it's full potential all of the time, the fans will be quieter and the heat/power consumption will be lower. Is this possible?
     
  6. HBR-Roadhog

    HBR-Roadhog

    Messages:
    6,318
    Location:
    United States
    Yes you can use that switch in the steam settings for the game to cap it at whatever you need

    Close your game
    Go to steam > libary
    right click on the game
    select properties
    click the set launch options button
    type into the box
    -fpscap 30

    click ok

    start the game
     
    PIP_36 likes this.
  7. Marcus96

    Marcus96

    Messages:
    53
    Location:
    United Kingdom
    Thanks! I tried this and FRAPS was reading 29 (so the FPS cap must stop it reaching 30?). So I did -fpscap 31.

    Either way, the game looks a lot smoother with less heat issues. However some screen tearing is still visible. May it be worth trying this with VSync on too?
     
  8. Marcus96

    Marcus96

    Messages:
    53
    Location:
    United Kingdom
    No, this didn't work. VSync made tearing worse and added input lag! I have changed back to -fpscap 30 and it looks smooth. Tearing isn't as much, but still present.
     
    Last edited: May 27, 2015
  9. NLxAROSA

    NLxAROSA Premium

    Messages:
    7,898
    Location:
    Netherlands
    Did you try to set 'render frame ahead' to 1 (defaults to 2 if I recall correctly) in-game? Are you on the latest nVidia driver? Did you check VRAM usage?
     
  10. Marcus96

    Marcus96

    Messages:
    53
    Location:
    United Kingdom
    Yes, 'Render Frames Ahead' is set to 1. I am using latest NVIDIA Drivers and VRAM usage is at 1062MB (Dedicated) and 177MB (Allocated). My card is 2GB I believe.
     
  11. Marcus96

    Marcus96

    Messages:
    53
    Location:
    United Kingdom
    Just found something out! When playing the game windowed, there is no screen tearing present. However in full screen, there is screen tearing! This is without VSync (for both windowed and full screen). I don't understand???