T300 RS USB Problems, no 5V from 4 Pin PSU plug.

1
United States
United States
Hi! I am pretty new to simracing and have had an issue with my T300 RS. It is 100% my fault and I accept that I messed up but complicated situation with the sim rig and my clumsiness and I managed to rip the USB out of my computers front panel breaking the front USB port on my tower and of course it ****ed the cable a little bit along the way but the connectors on the inside seem fine and overall even the metal casing on the cable is fine it's not even dented bad.

So I assumed all was fine and dumb move aside I went to go plug it in in a new USB port and continue racing and it would no longer be detected, I then tried it on a different computer and it's different ports as well as a PS5 (and yes I swapped the right modes ETC) and I tried the whole L3 + R3 USB cable trick and all, my assumptions are either I just pulled the USB cord too hard from the back of the wheel during the accident or when the front USB Panel area on my tower got destroyed and the little casing the covers the inside of the female side of the USB got broken off and the bare USB wires from the front panel were exposed they somehow shorted something in the wheels male USB end as the wires were all bent crossing over each other and stuff and just a mess.

Second possibility is that something horrific just happened and got messed up in the incident or just the stress from the accident messed the wire up internally which caused some issue.

That being said I now have opened the wheel up (I have intermediate electronics knowledge and consider myself a general hobbyist, so no expertise but I have no problem learning something I might need to know to repair this situation, I have all the tools necessary for soldering, multimeters etc etc and don't mind replacing any parts/chips possibly necessary) and was watching some videos and reading some stuff about common USB issues and it seems that if you check the little thin wires connected to the board in the PSU 4 Pin plug you should get 5 volts back which is where the USB can tell the wheel to power up basically, and if it never gets that then the wheel will never power. Well I checked this with the multimeter and instead of getting the proper 5V with the wheel plugged into mains as usual and multiple different good working USB 2.0, USB 3.0 ports it never got more than around a volt which seems to be some good way to diagnose my next move but at this point I am lost.

So I was hoping someone here might have some advise as to what my next move might should be? Should I just splice off the entire USB cable and replace it and hope that helps? Or what other angles or tests might I do to narrow it down and figure out my next move? Any advice would be greatly appreciated and I apologize deeply for the super long obnoxious post but I just wanted to provide as many details as possible incase I missed anything myself. Thank you again for any help you may be able to provide or even just insight on where to go next, I appreciate it greatly as I was really starting to love sim racing and I am so sad to see my wheel no longer be usable.