T500 with T300 wheel add on?

Discussion in 'Sim Racing Hardware' started by CarNaya, Mar 29, 2021.

  1. CarNaya

    CarNaya

    Messages:
    3
    Hi guys. That's my first post on this forum and I really need help to find solution.
    My T500 wheel is not under warranty right now and i got a problem with left paddle always activated. I tried to disconnect it but seems the trouble exists in PCB board. I'm trying to find a cheap solution. So...
    If I connect T300 wheel to T500 base will it deactivate these static paddles or all the paddles will work at the same time?
     
  2. Daz555

    Daz555

    Messages:
    1,150
    That's a tough one. I can't imagine it is a scenario anyone will have tested.
     
    Last edited: Mar 29, 2021
  3. RacingManiac

    RacingManiac

    Messages:
    1,456
    all the different rims are cross-compatible within TM's ecosystem, provided you have the up-to-date firmware..
     
  4. Daz555

    Daz555

    Messages:
    1,150
    That's not the question. The poster wants to know if the in-built paddles in the T500 wheelbase are automatically disabled when you plug in a wheel rim that has paddles included.
     
  5. RacingManiac

    RacingManiac

    Messages:
    1,456
    Oh I misread it.

    Its definitely not disabled when you plug in wheels with built-in paddles. Reading it again I assume you tried this already...

    http://ts.thrustmaster.com/download/accessories/manuals/t500rs/t500rs_remove_paddles.pdf

    Other things to try maybe, I wonder if you can use programs like antimicro to unassign/reassign the paddle to something else. Though I think the problem in that case would be you can't change the mapping of the rims on the other wheel you plug in with paddle and map something to that paddle...
     
    Daz555 likes this.
  6. CarNaya

    CarNaya

    Messages:
    3
    Unfortunately, not. This idea didn't help me.
    I tried stock T300 and Ferrari Gt one. L1 paddle still stuck as activated.
     
  7. CarNaya

    CarNaya

    Messages:
    3
    I tried to disconnect wires of pedals even in PCB. Nothing helps. It's just stuck in mainboard that's not the button problem.
    Also, I tried to remap it and deactivate and other software lifehacks but no success.

    Afterall...
    I gave up with this problem. In my country official Thrustmaster service don't have this PCB. I did request on Thrustmaster site but seems they don't hurry to answer. For now I soldered L3 button to the left paddle. At least, I can use both paddles in games. Surething I got bugged L1 button which is annoying in projectcars 3 but in most games it's ok.
     

    Attached Files:

    Last edited: Mar 31, 2021