Thrustmaster t150, brand new is the belt slipping?

Discussion in 'Sim Racing Hardware' started by imported_rik19, Oct 20, 2019.

  1. imported_rik19

    imported_rik19

    Messages:
    1,868
    Location:
    England
    Ok guys im just wondering if anyone has had this experience before, just bought a new t150 wheel and pedal set, i have had one before...anyway the previous one never did this...had years of use..

    Here`s the problem, if i turn the wheel fast left or right, as in catching a slide, the wheel is now off center to what is shown on the game, if i put the steering wheel straight, the game steering is off line, at first i thought the car on the game was damaged, you know broken steering, i was playing grid, but it happens on every game, I just tried this in gt, car not moving, interior view, quick steer to left or right, now the wheel is off line...

    If i unplug and plug it back in, the wheel does its self centering calibration thing and is fine again, untill i do a sharp quick steer then it goes off again..

    Almost like the belt has slipped if thats possible....

    thanks if anyone can help, only had it a day....

    I`ll do a video if you need to see....quite frustrating this...
     
  2. super_gt

    super_gt

    Messages:
    3,948
    Location:
    Bulgaria
    Yes please!
     
    imported_rik19 likes this.
  3. imported_rik19

    imported_rik19

    Messages:
    1,868
    Location:
    England
    Ok here you go, as you can see a quick steer and it goes off center, my old one didnt do this, when you are racing and trying to catch an oversteer moment, the wheel goes off center....also you may notice the game steering didnt react to my fast turn....

    I havent updated the firmware..





    Edit not my video, but my wheel is doing this now, non stop turning itself from stop to stop..
     
    Last edited: Oct 20, 2019
    super_gt likes this.
  4. super_gt

    super_gt

    Messages:
    3,948
    Location:
    Bulgaria
    imported_rik19 likes this.
  5. imported_rik19

    imported_rik19

    Messages:
    1,868
    Location:
    England
    Ive just updated the firmware, and its still going left and right without stopping...even plugged in to the pc it wont stop turning...just on to amazon chat about returning it...unbelievable bummer....
     
    super_gt likes this.
  6. Krassi

    Krassi

    Messages:
    558
    Location:
    Bulgaria
    The return is the right move - not saying that T150 is a bad wheel, but your unit is faulty no doubt...
     
    imported_rik19 likes this.
  7. imported_rik19

    imported_rik19

    Messages:
    1,868
    Location:
    England
    Didnt send it back to amazon in the end, i got in touch with thrustmaster, and they arranged collection and have repaired it, so big thanks to thrustmaster,:tup: seems to be ok now, didnt cost me anything...
     
    super_gt likes this.