Thrustmaster T150 No Power

Discussion in 'Sim Racing Hardware' started by PozzaP87, Oct 11, 2017.

  1. PozzaP87

    PozzaP87

    Messages:
    100
    Hi All,

    I've had the Thrustmaster T-150 force feedback wheel for a couple of years now and have experienced no issues so far, however last night during use on GT Sport all power cut out on the wheel and since then I have not been able to get the wheel to power on.

    I've tried different sockets and replaced the fuse in the plug but still no power is going to the wheel.

    Has anyone else experienced a similar issue with this wheel? Also does anyone know if I am still covered under Thrustmaster warranty?
     
  2. Herno

    Herno

    Messages:
    2
    Mine has done the same thing tonight, however, I left it for 10-15 mins and it's decided to start working again... So far
     
  3. PozzaP87

    PozzaP87

    Messages:
    100
    Mine is working again, but I am in contact Thrustmaster about the issue as its just still within warranty, if I can get a replacement before it expires and fully breaks I will be happy
     
  4. Kris Stoney

    Kris Stoney

    Messages:
    39
    Hi guys
    How strange I was playing on my Ferrari Thrustmaster T150 today did 5 hours of GT Sport also and the wheel cut out lights went off.
    I did smell the case and smelt burning apparently there is a cut out switch attached to the circuit board in the wheel base and when it reaches a certain temp it cuts out to prevent frying the circuit board. Sad thing is it's been well over an hour and my wheel won't power back up again, will keep trying. GT Sport certainly is killing wheels lol if mine works again I would recommend only a few hour sessions as it clearly the motor can't take hours of work before the cut off kicks in.
    Kris
     
  5. Kris Stoney

    Kris Stoney

    Messages:
    39
    Hi guys
    How strange I was playing on my Ferrari Thrustmaster T150 today did 5 hours of GT Sport also and the wheel cut out lights went off.
    I did smell the case and smelt burning apparently there is a cut out switch attached to the circuit board in the wheel base and when it reaches a certain temp it cuts out to prevent frying the circuit board. Sad thing is it's been well over an hour and my wheel won't power back up again, will keep trying. GT Sport certainly is killing wheels lol if mine works again I would recommend only a few hour sessions as it clearly the motor can't take hours of work before the cut off kicks in.
    Kris
     
  6. Kris Stoney

    Kris Stoney

    Messages:
    39
    Hi guys
    How strange I was playing on my Ferrari Thrustmaster T150 today did 5 hours of GT Sport also and the wheel cut out lights went off.
    I did smell the case and smelt burning apparently there is a cut out switch attached to the circuit board in the wheel base and when it reaches a certain temp it cuts out to prevent frying the circuit board. Sad thing is it's been well over an hour and my wheel won't power back up again, will keep trying. GT Sport certainly is killing wheels lol if mine works again I would recommend only a few hour sessions as it clearly the motor can't take hours of work before the cut off kicks in.
    Kris
     
  7. Kris Stoney

    Kris Stoney

    Messages:
    39
    Hi guys
    How strange I was playing on my Ferrari Thrustmaster T150 today did 5 hours of GT Sport also and the wheel cut out lights went off.
    I did smell the case and smelt burning apparently there is a cut out switch attached to the circuit board in the wheel base and when it reaches a certain temp it cuts out to prevent frying the circuit board. Sad thing is it's been well over an hour and my wheel won't power back up again, will keep trying. GT Sport certainly is killing wheels lol if mine works again I would recommend only a few hour sessions as it clearly the motor can't take hours of work before the cut off kicks in.
    Kris
     
  8. super_gt

    super_gt

    Messages:
    4,277
    Location:
    Bulgaria
    There are two things you can do to prevent this:
    1.Remove the top cover of the base and play without it.(the base is strong enough to withstand this)This option is extremely effective,you will be able to play for 5 hours non stop at the highest force feedback settings even on the warmest summer days and the motor temperature will not exceed 65 degrees Celsius.
    2.T150 improved cooling mod.

    When you are not playing you must cover the wheel to prevent a dusting!
     
  9. Racetee

    Racetee

    Messages:
    215
    Hasn't GT understeering been frying wheels lately? I can't remember in which thread I read, but multiple people's wheels died.
     
    Kris Stoney likes this.
  10. Kris Stoney

    Kris Stoney

    Messages:
    39
    Thanks for the tips however it's been 7 hours since it went off and it won't power on again no light so it's obviously blown. This is my second wheel from thrustmaster first one the gearing went and wheel became limp.

    So gone online and looked at deals not giving Thrustmaster anymore of my money gone little more premium and as highly rated at the T300 is as an upgrade from the T150 I've gone for the Logitech G29 with pedals and gear shifter knob thrown in for £219.
     
  11. Kris Stoney

    Kris Stoney

    Messages:
    39
    Yeah I said this my wheel has been fine for nearly 3 years playing all racing titles now GT Sport is killing them came online after mine blew up today and saw threads identical quoting the game.
    Better not do it to my new Logitech G29 I pick up tomorrow heard build quality and heating problems are alot lower than Thrustmaster so not going with TM anymore
     
  12. Kris Stoney

    Kris Stoney

    Messages:
    39
    Maybe it's a setup that GT Sport is killing wheels to make everyone buy the official TGT wheel for 699 pound as if
     
  13. Kris Stoney

    Kris Stoney

    Messages:
    39
    Just tweeted Kaz the developer and creator of GT Sport and tweeted Polyphony to stay we have an influx of wheels being killed by GT Sport
     
  14. pappy816

    pappy816

    Messages:
    4
    I had the exact same thing happen. I sent thrustmaster an email and they told me to down load the latest update?!?!?
    I'm hoping that after sitting a week it'll start working.
    I had this same thing happen, after a couple hours it just died and all the lights went off. I emailed thrustmaster and they told me to down load the update and install?!?!? Hope this works.
     
    Kris Stoney likes this.
  15. Kris Stoney

    Kris Stoney

    Messages:
    39
    Hope it works for you mate. Mine died last week and thrustmaster did the same asked me to connect it to the PC and download updates, connected it nothing no power from the wheel or the USB and wheels out of warranty so it's a £200 paper weight, crappy plastic crap so went out and brought a Logitech G29 and haven't looked back high quality leather wheel, great build quality and feel. Fk thrustmaster never again.
     
  16. PozzaP87

    PozzaP87

    Messages:
    100
    Im still in contact with Thrustmaster - but since I followed the instructions to download the latest firmware for the wheel ive had no further issues and on average play GT Sport around 5 hours a day.

    Im still hopeful they will replace the wheel given that its 'just' within warranty though for extra piece of mind
     
    Kris Stoney likes this.
  17. Herno

    Herno

    Messages:
    2
    Could you post the link for the firmware, if you've still got it please?

    Mine has another fit last night
     
  18. speedycruiser

    speedycruiser

    Messages:
    1
    New drivers update does not include t150 but other wheels,you see when you read new driver-firmware notes. firmware is still v5 for t150. No new firmware as i see.
     
  19. Cammiepop

    Cammiepop

    Messages:
    37
    Location:
    United Kingdom
    Just now, was doing some laps around Monza in the F1500 car, got some wheel spin, the back kicked out violently and I corrected. Suddenly bam...no force feedback on my T150 Thrustmaster....went all loose. Unplugged the usb, put it back in...now it can't even get recognised by the playstation and the calibration just goes hard right and locks up. I can hear a buzzing from a motor inside but it seems quick reactions and correcting oversteer aren't what this steering wheel is built for. Gotta sort out a return.
     
  20. super_gt

    super_gt

    Messages:
    4,277
    Location:
    Bulgaria
    You may want to try this before you send it back.
     
    FPV MIC likes this.
  21. Cammiepop

    Cammiepop

    Messages:
    37
    Location:
    United Kingdom
    Thank you! I will try it now.
     
    super_gt likes this.
  22. Cammiepop

    Cammiepop

    Messages:
    37
    Location:
    United Kingdom
    Didn't work, seems the problem is mechanical. The wheel happily spins clockwise to calibrate, then you get a little twitch and nothing more as it tries to spin counter clockwise.
     
    super_gt likes this.
  23. Cammiepop

    Cammiepop

    Messages:
    37
    Location:
    United Kingdom
    Got it replaced today by Smyths Toys, its gone up in price by 30 quid so I'm, glad I got it when I did.
     
    super_gt likes this.
  24. Corsa

    Corsa Premium

    Messages:
    1,962
    I'm happy they replaced it.
    My warranty expired last month and it has just began making a terrible gear mesh noise during initial start up. I will say it has been used hard for long sessions and has over 800 hours on it so for $200 new I would still recommend it as a great product.
    Luckily, I have my old rugged Fanatec CSR elite from 2011 that continues to act like it's brand new and is getting along with windows 10 on PC.
     
  25. kirethk

    kirethk

    Messages:
    46
    My T150 also cut out today after a two hour session (mid race unfortunately). The fuse looked ok but I replaced it to be sure, still didn't turn on, unplugged pedals and usb, still didn't turn on, plugged pedals and usb back in and it fired up.

    It is the hottest august bank holiday on record in the UK today so I suspect the cause is overheating, but still a surprise (I had to finish the race with a DS4, rip)
     
  26. matthew851384

    matthew851384

    Messages:
    1
    I am having the same problems! I was using it yesterday and today, when I turned it on it, worked fine... then it just turned off. no power what so ever. no signs of life! how do I fix this Please help me!
     
  27. JayRS200

    JayRS200

    Messages:
    500
    Having the same problems. It's less than a month old bought brand new. I already updated it on PC when I first got it but I'll connect it again tomorrow to see if it works.

    I've been playing GTS with force FF set to 5 and FF sensitivity set to 6. Has this been too much for it?

    Edit: It turned back on after the 5th reset after leaving it for a while after the 4th reset. Don't know if it had overheated. Have to say I could smell an electrical chemical smell coming from it but the room wasn't too hot really.

    Edit 2: Worked flawlessly for 4 hours today. I've turned down the FF a bit. Working well. Bit paranoid now though as it did turn off once before about a week in. Maybe I should return it to Amazon just in case or give it another couple of weeks.
     
    Last edited: May 12, 2020
  28. Furryhobn0b

    Furryhobn0b

    Messages:
    19
    My brand new t150rs Pro cut off about 4 times while playing gt sport, had to leave it a while before it would work again, decided to send it back for a full refund and bought a fanatec csl elite instead. Alot more money but we'll worth it for the difference in feel and build
     
  29. John Wells

    John Wells

    Messages:
    2,919
    Location:
    United Kingdom
    The USB cable has broken, on T150 , going repair myself, have removed all screws from base.
    But it still won't separate, to get cover off, what I'm doing wrong.

    Found a take down video on you tube, removed now.
     
    Last edited: May 16, 2020
  30. JayRS200

    JayRS200

    Messages:
    500
    My T150 overheated again and turned off in the 2nd last lap of a sport mode race. Medium FFB settings 2 hours of play. That's 3 times in 3 months. Will have to think about modding the cover or something. Was quite warm in the room, 22°C maybe but still it shouldn't be doing that.

    I would advise anyone thinking about buying a T150 to really think about it, these overheating issues are real and it's a bad design. The cover should be more open and the fan should be better. Thrustmaster should allow modding of the cover without it voiding the warranty. Yeah we will do the job for you Thrustloser.