TM Rally Sparco R383 wheel buttons not working after t300 firmware update PS4

Discussion in 'Sim Racing Hardware' started by Nick077, Apr 5, 2021.

  1. Nick077

    Nick077

    Messages:
    34
    Hello,

    I just got the TM Rally Wheel Add-on Sparco R383 Mod to go with T300 RS base, currently using on PS4.

    I tested it after fitting and it worked fine.

    The literature with the wheel said it was imperative to update the firmware, which I just did, and now none of the buttons are working, so I can't use the wheel at all. :(

    Any suggestions on a fix, contacting Thrustmaster seems to be a bit fo a waste of time.

    Cheers,
     
  2. MxFiver

    MxFiver

    Messages:
    53
    Have you tried remapping them in your game on the PS4... are the buttons recognised and you are then able to select them in the game set up/ controller mapping in the game...
     
    Nick077 likes this.
  3. Nick077

    Nick077

    Messages:
    34
    You need the PS button to log in to PS4 with the device, same as any controllers.

    So without the PS button mapped, it is non-functioning.
     
  4. super_gt

    super_gt

    Messages:
    4,417
    Location:
    Bulgaria
    Do the buttons work in the PC driver?
     
  5. Nick077

    Nick077

    Messages:
    34
    Really weird, I tried re-starting several times, and the problem persisted. I restarted a 4th time and now it's working.

    Cannot explain why this occurred, perhaps I have ghosts in the house today. :)

    Thanks for the help problem solving though, appreciate your effort and time.
     
    super_gt likes this.