B-Spec Grinder 2.5.2: Automate Remote Races

  • Thread starter yonis
  • 4,266 comments
  • 520,495 views

Dragonwhisky

Premium
5,829
United States
GTPlanet
dragonwhisky
My Widget is running races as I type this. maptidh has shown up in the drivers list as well. I run the widget exclusively on the Spain server. maptidh has been set as sole "use always" list at this point. Didn't save the list prior to the first race queuing up so will run a couple more to make sure the widget pulls his drivers with priority.

My suggestions for those of you having trouble;

Go to the Widet Preferences;
Under the Account tab, set Country to Spain. If that doesn't work keep trying different countries until one does work or none do.

Under the Races tab, set Race On: to Events of any Length. I've tried the other settings in that drop down and it's not worked on any but this one.

Under the Advanced Tab, set Concurrent Threads to 1 Thread and Driver Reservation Delay to 5 Seconds and check the box to Save race logs to disk.

While I don't think these settings are important I can't say for any certainty that they are not affecting the widget in some unknown way. Under the Window Tab, which I haven't changed from default after the last install, Set Window Level to normal, make sure the check boxes for Ignore Mouse and Prevent Dragging are clear and set the Opacity to 100%
Click Save.
Right click the Widget again and select Force Re-authentication and see if it starts working.

Also keep in mind, this thing is not instantaneous. It will take time for the widget to contact the server you've set it for and start reserving drivers. It does give a progress bar as it does so and the logs will show it as well but you have to keep closing and re-opening the log file for it to write the data. I don't think the widget can even write to the logs while they are open in an editor program. Perhaps with a newer operating system they can. I have no real empirical evidence to support this other than closing and re-opening the files myself while the widget is running.

Second round of racing about to start. Will see if it pulls new drivers list settings.

maptidh's drivers not used yet. Checking logs. Something I've noticed is on the driver's list maptidh's driver count is "?". Recommend maptidh go to his country's gt5 site and log in/log off a couple times there and see if that helps. Several months ago I had to do this with all my accounts so the driver's list would synch up to the widget.

Third round of races queuing up now. I don't think the widget functionality is dead just yet.

4th round running now. maptidh's drivers still not being pulled. Please go to your gt5 site and try that log cycle. Will try again after you've confirmed to have done so.
 
Last edited:

Rallywagon

what a long strange trip
Premium
7,659
United States
Michigan
Rallywgn81
I'll mess with the widget on my PC. I was using the one on my mac earlier, though I'm not sure that would cause an issue. Otherwise I've tried all servers and all options. My issue isn't a matter of waiting though. The widget is thinking all of my Bobs are being used. 6 out of 6. It will load a race event, it will load Bobs from my friends list and it will try to start the race. At that point my drivers list goes from 0/6 to 6/6. it will then see an error, then it will drop that session and go through the process of trying to start a race again. It loops like that for a few then just says something like session timed out. Maybe the PC will have better luck.
 

Dragonwhisky

Premium
5,829
United States
GTPlanet
dragonwhisky
Log that account in and out of the gt5 site a few times and see if it synchs up again.

You may need to do the full scrub and re-install of the widget as well.
 
661
Greece
Greece
maptidh
My Widget is running races as I type this. maptidh has shown up in the drivers list as well. I run the widget exclusively on the Spain server. maptidh has been set as sole "use always" list at this point. Didn't save the list prior to the first race queuing up so will run a couple more to make sure the widget pulls his drivers with priority.

My suggestions for those of you having trouble;

Go to the Widet Preferences;
Under the Account tab, set Country to Spain. If that doesn't work keep trying different countries until one does work or none do.

Under the Races tab, set Race On: to Events of any Length. I've tried the other settings in that drop down and it's not worked on any but this one.

Under the Advanced Tab, set Concurrent Threads to 1 Thread and Driver Reservation Delay to 5 Seconds and check the box to Save race logs to disk.

While I don't think these settings are important I can't say for any certainty that they are not affecting the widget in some unknown way. Under the Window Tab, which I haven't changed from default after the last install, Set Window Level to normal, make sure the check boxes for Ignore Mouse and Prevent Dragging are clear and set the Opacity to 100%
Click Save.
Right click the Widget again and select Force Re-authentication and see if it starts working.

Also keep in mind, this thing is not instantaneous. It will take time for the widget to contact the server you've set it for and start reserving drivers. It does give a progress bar as it does so and the logs will show it as well but you have to keep closing and re-opening the log file for it to write the data. I don't think the widget can even write to the logs while they are open in an editor program. Perhaps with a newer operating system they can. I have no real empirical evidence to support this other than closing and re-opening the files myself while the widget is running.

Second round of racing about to start. Will see if it pulls new drivers list settings.

maptidh's drivers not used yet. Checking logs. Something I've noticed is on the driver's list maptidh's driver count is "?". Recommend maptidh go to his country's gt5 site and log in/log off a couple times there and see if that helps. Several months ago I had to do this with all my accounts so the driver's list would synch up to the widget.

Third round of races queuing up now. I don't think the widget functionality is dead just yet.

4th round running now. maptidh's drivers still not being pulled. Please go to your gt5 site and try that log cycle. Will try again after you've confirmed to have done so.

Yeah looks like there was a problem but it's fine now I think.

EDIT: Actually I don't know exactly what it is. Sometimes when I log in there it said that the service is unavailable but I could see messageboard, log etc.. I tried it again now and it didn't say that, so I guess it's ok now.. ?
 
Last edited:

Rallywagon

what a long strange trip
Premium
7,659
United States
Michigan
Rallywgn81
so, I tried it on my pc this time. I had the same issue. All six of my drivers were reserved. This isn't possible though, since I use that account only for grinding and duping, my accounts are the only accounts on that ones friends list. I have one ps3, no way I can get all 6 bobs running. However, I switched to one of my secondary accounts, and managed to get 5/6 drivers reserved, so I can at least grind with that account
 

Rallywagon

what a long strange trip
Premium
7,659
United States
Michigan
Rallywgn81
I have. I've used that account to grind before. I'm also pretty sure the account im using now doesn't have 5 drivers currently in remote races either.
 
74
Poland
Poland
bartofslaves
Damn, after trying for few hours I got enough... Mine grinder cannot find any drivers://

"
2013.04.01 01:27:38.768: There's nobody to race!
Updating credits display. Difference: 0
Reserving a driver at random. Name: P.Schmidt Class: 0 Exp.: 0 Credits: 0
2013.04.01 01:28:00.483: There's nobody to race!
Updating credits display. Difference: 0
Reserving a driver at random. Name: P.Schmidt Class: 0 Exp.: 0 Credits: 0
2013.04.01 01:28:22.417: There's nobody to race!"

Can someone add me and train them a bit?

PSN: bartofslaves
 
4
United States
OvertheRainbow
Apollostar
Does anyone know why my Widget will only pick drivers from one person (I have 3 people with available drivers but the widget just picks all of one person's drivers) I have no idea why it does this and cannot figure out how to fix it. i've tried many things such as changing around the position of the drivers in the driver configuration but nothing seems to work. no errors show up in the log...Is this just a normal occurrence? Any help is appreciated.

Thanks in advance
-Starman2
 
Last edited:

Racin-Rev

Premium
688
United States
Indiana/USA
Racin-Rev
I should have come here in the first place. I have been off the grinder for months and a few days ago decided to give my guys some work. I have messed with the widget for days because my friend's drivers would not show up. If I had only come here first to discover that the Spain server is the one that works best, I could have saved myself lots of frustration.

Thanks for keeping information on the widget current:tup:
 
2
Canada
Ontario
Notorious-_-47
its too bad you stopped updating it. I would really love to use it but it seems it needs and update. I would gladly take the reins but i dont know how these computer programs work and exactly how to fix known issues and bugs.
 
Seems as the eu.gran-turismo.com domain has changed to www.gran-turismo.com yesterday, i have changed this in the widget and now can log in but unable to launch any races just errors with:

TypeError: matches.match(/gt5bspec\.selectEvent\((\d+)\)/) has no properties (Race.js: Line 112)

looks like the regex is not matching the race id in this example data:

Code:
<dl class="remote_event_list">	<dd class="course_logo"><img src="/common/images/gt5/remote_race/common/courselogo/ed2539fe892d2c52c42a440354e8e3d5.png" width="84"></dd>	<dd class="race_info_minute"><img src="/common/images/gt5/remote_race/common/time/20.png" width="80" height="54" alt=""></dd>	<dd class="entry_max"><img src="/common/images/gt5/remote_race/entry/icon_driver.png" width="20" />16</dd>	<dd class="lap"><span>Vuelta(s):</span>&nbsp;12 (en torno a 20 minutos)</dd>	<dd class="car_image">		<img src="/common/images/gt5/car/thumbnail/0a712318b3b8acc70daeb1ff71d40140.png" width="178" />	</dd>	<dd class="link"><a href="javascript:void(0);" onclick='gt5bspec.selectEvent("/116/1035200")' title="Abt Audi TT-R Touring Car '02 / Circuito de Madrid">&nbsp;</a></dd></dl>

heres the current regex but no idea on regex's:

Number( matches[ i ].match( /gt5bspec\.selectEvent\((\d+)\)/ )[ 1 ] ),

can anyone recommend a updated regex?
 
Last edited:
28
Switzerland
Basel
laserjay
has anyone an idea of how to fix the widget? or rewrite it for apple dashboard?
or is even working on a fix?

i'd like to push it... :)
 
2
United States
Columbus, OH
Twitch131
I tried booting up the widget today, and strangely it started working!

hhyXJLb.png


Working for anyone else?
 
7,352
United States
Houston, TX
ryandude2448
Can Someone help me please? I feel like I've done everything and this still isn't working.
I'm logged in to the Spain server, I've debugged, I've restarted both PS3 and PC, I've started a couple races manually, but it still doesn't show any of my friends drivers.
Using the most recent downloads.
 

kekke2000

Premium
1,934
Sweden
Sweden
kekke2000
Can Someone help me please? I feel like I've done everything and this still isn't working.
I'm logged in to the Spain server, I've debugged, I've restarted both PS3 and PC, I've started a couple races manually, but it still doesn't show any of my friends drivers.
Using the most recent downloads.

Same problem here...
 
Last edited:

Rallywagon

what a long strange trip
Premium
7,659
United States
Michigan
Rallywgn81
Please start this feature back up or tell me how to get it going again.
Goto your local collage and look for programming classes. With GT6 around the corner, I don't see this app getting much attention anymore. I still have a semester or two before I am to the point that I could take on this project. However, I will definitely be looking into doing the same thing for gt6, if its possible.
 

Rallywagon

what a long strange trip
Premium
7,659
United States
Michigan
Rallywgn81
Nothing announced as of yet, considering we have no idea how its all going to work yet anyway. The OP had stepped out like 6 or 7 months ago as well, without word if they will be making a comeback for gt6.
 
1,973
United States
Florida - USA
Flsurffisher
Nothing announced as of yet, considering we have no idea how its all going to work yet anyway. The OP had stepped out like 6 or 7 months ago as well, without word if they will be making a comeback for gt6.

Thanks Rally. Sure hope we get one! Makes filling the garage that much easier!