CSL Elite firmware

Discussion in 'Sim Racing Hardware' started by Keith2324, Jan 10, 2019.

  1. Keith2324

    Keith2324

    Messages:
    364
    Location:
    Barbados
    For the ones' using the Fanatec CSL Elite wheelbase for PS4, which firmware version are you using to get good results? I have used version 311 and 324. But using these two versions, I have to turn the DRI setting to -005 to get good turn-in in the corners. When using version 293, the turn in is much faster and I even have to use a DRI setting of 002 or 003. Anyone else have similar results?

    Keith.
     
  2. ANDRITSOULAS

    ANDRITSOULAS

    Messages:
    115
    Location:
    Greece
    476
     
  3. Knukel

    Knukel

    Messages:
    449
    How big is the difference between firmware 335 and 476? I used to notice clear difference, but now they feel very similiar.

    P.s If i set drift value to minus, i literally loose every subtle detail like rumble from curbs etc...
     
  4. Mirror_man

    Mirror_man

    Messages:
    1,319
    Location:
    Portugal
    The Dri variable should not affect that Ffb aspect at all! If you said Fei.. then I could consider as logically correct... but Dri??? That makes no sense... sincerely...
     
  5. super_gt

    super_gt

    Messages:
    3,889
    Location:
    Bulgaria
    In Drift Mode with CSL Elite PS4, you have values: -5/-4/-3/-2/-1/OFF/1/2/3/4/5. The negative values from -5 to -1 apply artificial damping, the OFF position turns off the artificial damping.
    This artificial damping recreates mechanical resistance(friction) so at lower negative values the motor recreates stronger mechanical resistance(friction) and the feeling of the fine details in the FFB will be reduced compared to DRI OFF where artificial damping is turned off.

    https://www.fanatec.com/eu-en/suppo...net&utm_campaign=General+Links&a_aid=gtplanet
     
  6. andrewhake

    andrewhake

    Messages:
    373
    Location:
    United States
    Of course it does, it acts as a damper. I prefer it at -5 personally though as it minimizes weird wobble and things.
     
  7. Keith2324

    Keith2324

    Messages:
    364
    Location:
    Barbados
    If you try the latest driver(326), all of the wobble is completely gone.

    Keith.
     
    andrewhake and Mirror_man like this.
  8. gt_fan

    gt_fan Premium

    Messages:
    259
    Location:
    Australia
    Where are you getting v326 from? The latest one I can see from the Fanatec pages is v311.
     
  9. Keith2324

    Keith2324

    Messages:
    364
    Location:
    Barbados
    Mirror_man likes this.
  10. gt_fan

    gt_fan Premium

    Messages:
    259
    Location:
    Australia
  11. Keith2324

    Keith2324

    Messages:
    364
    Location:
    Barbados
    Some people do indeed. But I had no such issues. Just give it a try. If it doesn't work for you, you can still use any of the prior updates.

    Keith.
     
  12. andrewhake

    andrewhake

    Messages:
    373
    Location:
    United States
    OhhhH! great to hear, will definitely give it a go.
     
  13. andrewhake

    andrewhake

    Messages:
    373
    Location:
    United States
    Wow I have to say the new firmware seems to be working VERY nicely. I am sort of wondering if it was an update to GT Sport or the firmware update or maybe both, but as Keith mentioned, the oscillations when letting go of the wheel when driving on straights is completely gone, and overall FFB seems to be adjusted. I actually needed to dial back my in-game settings a bit.

    Gave the new DC2 Integra and some GT3 cars a test and everything feels great. Also gear indicator now shows up on the CSL Elite PS4 steering wheel when shifting. Which may have been added in a previous GT Sport update but I hadn't seen it yet.

    No issues for me with the beta firmware using the CSL Elite PS4 wheel. The best GT Sport has felt for me using the CSL Elite so far.
     
    Last edited: Jan 19, 2019
    Mirror_man likes this.
  14. Keith2324

    Keith2324

    Messages:
    364
    Location:
    Barbados
    I also suggest driving the 'Ring with these new settings. You will feel everything. :)

    Keith.
     
    andrewhake likes this.
  15. Knukel

    Knukel

    Messages:
    449
    That doesn't work on my rim.
     
  16. Keith2324

    Keith2324

    Messages:
    364
    Location:
    Barbados
    He's using the P1 rim. The gear shift indication doesn't seem to be working on the Elite/PS4 rim. That may be the case for you also.

    Keith.
     
    Knukel likes this.
  17. andrewhake

    andrewhake

    Messages:
    373
    Location:
    United States
    No I am using the included CSL Elite PS4 rim sorry, it is the same so was just referring to it as P1. It only shows gear when shifting and then disappears after a moment, but seems to work as expected on the CSL Elite PS4 rim for me. Works when shifting with paddles or with club sport shifter.
     
  18. Keith2324

    Keith2324

    Messages:
    364
    Location:
    Barbados
    No I am using the included CSL Elite PS4 rim sorry, it is the same so was just referring to it as P1. It only shows gear when shifting and then disappears after a moment, but seems to work as expected on the CSL Elite PS4 rim for me. Works when shifting with paddles or with club sport shifter.


    Interesting. This feature doesn't work on my rim. :(

    Keith.
     
  19. andrewhake

    andrewhake

    Messages:
    373
    Location:
    United States
    Interesting. I will try to post up a video to show what I'm talking about.
     
    super_gt, Knukel and Keith2324 like this.
  20. andrewhake

    andrewhake

    Messages:
    373
    Location:
    United States
    So did some more testing and realized that the CSL Elite PS4 wheel is only showing the gear on the display when shifting with the ClubSport Shifter, not with the built-in paddle shifters, so makes sense why you guys weren't seeing it. Even when not in game, the wheel will display what gear you have shifted into on the external shifter. I would guess it is up to PD to implement speed and gear shift in-game to have it displayed on the wheel.
     
    Knukel, Keith2324 and super_gt like this.
  21. ANDRITSOULAS

    ANDRITSOULAS

    Messages:
    115
    Location:
    Greece
    Mine does not display the gears at all when using the shifter.
     
  22. andrewhake

    andrewhake

    Messages:
    373
    Location:
    United States
  23. Bowa

    Bowa

    Messages:
    17
    Thanks for that, I was not on 326, the issue I"m having is with purple mode for dirt rally ( or any game) It just does not want to work.
     
  24. AdamMorcs

    AdamMorcs

    Messages:
    81
    Location:
    Australia

    Yea feels way better on gt sport. I've noticed my cooling fan on CSL elite alot louder now during use? Anyone else noticed this ? They must of raised fan speeds . I'm on latest public driver. Not beta
     
    Mirror_man likes this.
  25. AdamMorcs

    AdamMorcs

    Messages:
    81
    Location:
    Australia
    I tried the 326 today felt good . But still bugs on McLaren gt3 rim on gt sport. Tried to do the v30 for rim but it says not compatible . Ugh guess I'll go back to 311 and wait for new drivers
     
  26. domasijus

    domasijus

    Messages:
    48
    Hello. Just noticed we have V327 beta drivers released on 12th February. maybe anyone tested yet on GT Sport or other games? some noticeable changes from V326 beta?
     
  27. Mirror_man

    Mirror_man

    Messages:
    1,319
    Location:
    Portugal
    I ve just read on Fanatec Forum... and it implements a lot of corrections and changes!

    It may be something trully cool!
     
  28. Mirror_man

    Mirror_man

    Messages:
    1,319
    Location:
    Portugal
  29. zeroasdf

    zeroasdf

    Messages:
    2
    Unfortunately, I returned to v311, because the latest firmware canceled the purple light mode, so the drive club can not play, the dirt rally psvr mode does not have a purple light mode, the yellow light mode can not reset the vr perspective
     
  30. Mirror_man

    Mirror_man

    Messages:
    1,319
    Location:
    Portugal
    No it didnt! It simply changed the way to set it!
    Now you need to press the Mode button for several (3 to 5 sec if I m not wrong) to set it!
     
    Knukel likes this.