Drive Hub Racing Wheel Converter

  • Thread starter VBR
  • 2,881 comments
  • 661,806 views
12
Canada
Canada
Thank you for the information Sir. I do recognize that the FFB is absolutely less substantial but the cars, sounds and feel of the game is great. Unfortunately the lobbies are not quite as full
 
27
United States
United States
I have no FFB with the World of Outlaws game or SRX The Game on Xbox Series S with a T300. Downloaded the lastest firmware update. Grid Legends wasn't working either but works now with beta 4 but still nothing with the other two games. Anyone else having this issue?

Well, scratch SRX off the list because it works now too. It didn't before I updated to 2.09 beta 4. Only one not working is the World of Outlaws. Weird because they are both running on the same engine, made by the same company. Figures that I've been waiting for a fix all this time and everything seems to work but the game I wanted to the most. Had a blast with WoO till the late October system update to Xbox. All was well till then. All worked. 🥺
 
Last edited:
6
Sweden
Sweden
Update on my PC -> Drive hub -> xbox 360 racing wheel adventure:
I downgraded to FW 2.0.3, it now let me use force feedback.
 
Last edited:
35
United States
Austin, TX
Thomas0x15e
DJThomasMelvin
I literally feel my wheel go dead the moment an event starts or I head out on track. It's so weird.

I am waiting for a response from Collective Minds
I’ll be interested to hear the response. When I reported an issue with Grid Legends that started around the 2.0.8 firmware, they basically said “it’s not in the compatibility list, sorry.”

Fortunately I found a workaround but that response was pretty disappointing considering how good every other interaction I’ve had with them has been.
 
6
Sweden
Sweden
Quick test on my setup shows that the wheel rotation seems off, at least in dirt 2.0, when turning fully the wheel completely switches turning direction (overlaps). Any ideas how to fix this?

EDIT: For anyone having this problem: LTS (Logitech gaming software) need to run in the background.
 
Last edited:
12
Canada
Canada
I’ll be interested to hear the response. When I reported an issue with Grid Legends that started around the 2.0.8 firmware, they basically said “it’s not in the compatibility list, sorry.”

Fortunately I found a workaround but that response was pretty disappointing considering how good every other interaction I’ve had with them has been.
Yeah, I am patiently awaiting a reply. I will attempt some other firmware updates but I suspect my new Fanatec setup will arrive before a fix does.
 
3
United States
United States
Yes that was the thing I forgot. Updated firmware but still no luck with ts-pc on ps5. Guess it isn´t supported.
I have its sister wheel the ts-xw and works fine with my ps4. You should be using a hori controller with your ps5 stock ps5 controller will not work properly.


On a separate note anyone having issues in GT7 that after a reset your e-brake is locked and your unable to move the car?
 
Last edited:
35
United States
Austin, TX
Thomas0x15e
DJThomasMelvin
I have its sister wheel the ts-xw and works fine with my ps4. You should be using a hori controller with your ps5 stock ps5 controller will not work properly.


On a separate note anyone having issues in GT7 that after a reset your e-brake is locked and you’re unable to move the car?
Do you mean with an e-brake attached? Or the game just thinks you have one and it’s locked?

Everything is fine for me on ps5 gt7 with 2.0.9 beta 6 (I think 6). I don’t have an e-brake attached.

That does remind me about something I wanted to ask about. Has anyone tried using one of the generic usb e-brakes with the DriveHub? Or one of the Arduino based ones? I’m thinking an e-brake might be cool but don’t want to shell out for something too fancy.
 
3
United States
United States
Do you mean with an e-brake attached? Or the game just thinks you have one and it’s locked?

Everything is fine for me on ps5 gt7 with 2.0.9 beta 6 (I think 6). I don’t have an e-brake attached.

That does remind me about something I wanted to ask about. Has anyone tried using one of the generic usb e-brakes with the DriveHub? Or one of the Arduino based ones? I’m thinking an e-brake might be cool but don’t want to shell out for something too fancy.
No Ebrake attached to the drive hub just the TS-XW and stock pedals connected to the wheelbase.
 
4
Hungary
Hungary
Hi All,

I have a Fanatec DD1 and Heusinkveld Sprint pedals. Is there any working solution to use them on PS5 for GT7 without any issues?
 
1,698
United States
MI
I'm on a PS4 Pro so I don't know all the intricacies of PS5 issues. I do have a friend on PS5 with drivehub on GT7 and he hasn't complained about any issues. Then again, 90% of the time we're on PC so maybe just overlooked.
I think there's been significant beta updates to the drivehub since April though. I don't think that's much of an issue anymore.
 
3
United States
United States
20221201_192818.jpg

No e brake connected ever and the game believes I have one connected and is pulled 100% all the time.

EDIT: seems like beta 7 is out and this fixed the issue.
 
Last edited:
1
Denmark
Denmark
I just bought an Asetek Simsports Invicta brake pedals to use with my Fanatic DD Pro wheel for Playstation 5. Will this combo work with a Drive hub setup to use with Gran Turismo ??

I have the same problem - Did you get it to work?
 
4
Hungary
Hungary
I got a Drive hub and a horipad, all works fine on DD1 and HE sprints, thanks guys :)

Question: in GT7 when i'm driving in a straight my wheel/ffb starts to shake from left-to right. Until I keep turning it doesnt comes, just in center position on high speed and braking.
What needs to be tweaked from factory settings to handle this?
 
124
United States
United States
Well congrats on getting your mixed equipment to work. Drive Hub is a bit of a complex solution. I would start at the FANATEC forums and go find some base settings for your DD1 in GT7. From here you can probably get pretty close to what you want. Make smaller fine adjustments to try and dial in/out certain effects.
 
1
Portugal
Portugal
Hello y'all, first post here!

I've been following GTPlanet for more than 10 years now.

Recently, I bought a second hand drivehub and I'm trying to connect a DFGT Wheel with my Fanatec Clubsport V3 pedals to my PS3, to play Gran Turismo 6. However, when I connect them to my console, Drivehub eventually shows a "0" and despite the peripherals being turned on (I know that because, for example, my wheel is calibrating) somehow it seems that all buttons are blocked. I mean, I can't even get out of the initial PS3 menu...

Is there a solution to this? I went to Drivehub's website to see the FAQ's and I couldn't encounter anything.

I recorded a video of this happening, it's here on this wetransfer link.

https://we.tl/t-ClK2HiCYkC

PS: I updated the firmware to the latest version.
PS2: If this place is not the indicated to make these of questions, I would like to know where can I get this support
 
Last edited:
35
United States
Austin, TX
Thomas0x15e
DJThomasMelvin
@TheDriver_37

I think the issue is that it’s a PS3. The DriveHub is only going to work with PS4 and later, and Xbox One and later. There’s no PS3 or Xbox 360 support.
 
Last edited:
35
United States
Austin, TX
Thomas0x15e
DJThomasMelvin
Here’s a question for a friend (lol seriously).

He’s on an Xbox One S. DriveHub 2.0.9. Thrustmaster T300 GT Edition with TH8A and the stock pedals. I’m fairly certain the wheel and shifter have current FW.

Most games, feedback seems to be fine, but when we tried to do GRID (both 2019 and Legends), he’s getting nothing in race. It all works fine for me on my frankenrig on XSX. And I’m not 100% clear on this but it may have worked fine in Legends before he calibrated / configured the wheel ffb. He says it has some spring in the menus but not in a race.

Has anyone else seen this? I’m trying to help him troubleshoot and we’ve done all the connect / reconnect stuff I can think of.

Edit: he just told me he realized Forza Horizon 5 has no feedback either, so that’s something to go on. I’ve suggested he try FW 2.0.8 or a 2.0.8 beta to see if it might have come from their XSX feedback fixes that went into 2.0.9.
 
Last edited:
152
France
Burgundy
xxflorent21xx
graoul57
Here’s a question for a friend (lol seriously).

He’s on an Xbox One S. DriveHub 2.0.9. Thrustmaster T300 GT Edition with TH8A and the stock pedals. I’m fairly certain the wheel and shifter have current FW.

Most games, feedback seems to be fine, but when we tried to do GRID (both 2019 and Legends), he’s getting nothing in race. It all works fine for me on my frankenrig on XSX. And I’m not 100% clear on this but it may have worked fine in Legends before he calibrated / configured the wheel ffb. He says it has some spring in the menus but not in a race.

Has anyone else seen this? I’m trying to help him troubleshoot and we’ve done all the connect / reconnect stuff I can think of.

Edit: he just told me he realized Forza Horizon 5 has no feedback either, so that’s something to go on. I’ve suggested he try FW 2.0.8 or a 2.0.8 beta to see if it might have come from their XSX feedback fixes that went into 2.0.9.
Hi, I've never had the opportunity to try GRID, but so far it's seem I've got the same "feeling" with forza horizon (1) running in compatibility mode, weird feeling not really FFB, some strange spring effect

For FH5, yes this is drivehub firmware related
 
4
United States
United States
Are there any plans/progress for DriveHub supporting the Logitech G Pro DD wheel/pedals?

[Update]
PS4/5 Wheel base (in G923/PS4 mode) has G27 functions at a minimum when in in all of the games tested. Xbox Wheel base is not recognized by the DriveHub and no further testing was possible.

Note: The wheel base has to be connected to a valid USB host in order to change the Compatibility and Platform settings.

Configurations:

[PS Wheel -> Xbox]
Logitech G Pro Wheelbase (Playstation) & Pedals
DriveHub
Xbox One Controller
Xbox Series X

Result:
Pro Mode (Platform: PS5, PS4, & PC) - No Handshake (Racetrack LEDs on DH)
G923 Mode (Platform: PS4, did not test PS5 mode) - Connects to DriveHub LED displays a 0, Xbox recognizes the wheel as a G923.

Games Tested:
Forza Horizon 4 & 5 - working: wheel, pedals, ffb - not working: LEDs, rotary dial controls
Forza Motorsport 7 - working: wheel, pedals, ffb - not working: LEDs, rotary dial controls
Grid (2019) - working: wheel, pedals ,ffb, TrueForce, LEDs - not working: rotary dial controls
Grid Legends - working: wheel, pedals, ffb - not working: LEDs, rotary dial controls
Project Cars 3 - working: wheel, pedals, ffb - not working: LEDs, rotary dial controls, TrueForce (greyed out in menu)
ACC - working: wheel, pedals, ffb - not working: LEDs, rotary dial controls, TrueForce

[Xbox Wheel -> PS4 & PS5]
Logitech G Pro Wheelbase (Xbox) & Pedals
DriveHub
(PS5) Hori Mini
(PS4) DS4 and Hori Mini
Playstation 5
Playstation 4 Pro

Result:
Pro Mode (Platform: Xbox & PC) - No Handshake (Racetrack LEDs on DH)
G923 Mode (Platform: Xbox & PC) - No Handshake (Racetrack LEDs on DH)

Games Tested:
GT7 - Not Possible
GT Sport- Not Possible
WRC 8, 9, 10 - Not Possible

Additional Comments:

DriveHub should recognize the Playstation and Xbox wheel bases as a Playstation G29 when looped through GIMX. DriveHub would then pass the PS wheel as a G920 to Xbox or the Xbox wheel to PS as a G29.
 
Last edited:
35
United States
Austin, TX
Thomas0x15e
DJThomasMelvin
Hi, I've never had the opportunity to try GRID, but so far it's seem I've got the same "feeling" with forza horizon (1) running in compatibility mode, weird feeling not really FFB, some strange spring effect

For FH5, yes this is drivehub firmware related
FH1 just doesn’t have very good feedback. It’s better on the TX than it was on the G29 but it’s still very basic compared to newer games.

I got my friend to try DriveHub FW 2.0.8 and it actually broke feedback more so he’s back to 2.0.9 and has sent a support ticket.
 
152
France
Burgundy
xxflorent21xx
graoul57
FH1 just doesn’t have very good feedback. It’s better on the TX than it was on the G29 but it’s still very basic compared to newer games.

I got my friend to try DriveHub FW 2.0.8 and it actually broke feedback more so he’s back to 2.0.9 and has sent a support ticket.
Thanks for the feedback, I don't miss much, I'm still hope that the Drivehub team will work on it at some point, I'm unable to remember how was the ffb back in the days when I have my xbox360 and my fanatec GT2