Fanatec Gran Turismo DD Extreme Wheel

  • Thread starter super_gt
  • 832 comments
  • 91,466 views
Update to my “controller disconnected” issue on my DD+. I repositioned the Nobsound mini amps, tightened and insulated the speaker terminals. Separated the power cables from the usb cables. 6 hours of driving time, not a single disconnection. Very thankful that I don’t have to deal with an RMA

View attachment 1360478
I wish you all the luck in the world but I had maybe 20 hours or more of no trouble, then all of the sudden.. freezing issues again. I'm on a long stretch of no problems again but I know it's still going to do freeze sometimes. I bet if I plug in my sequential shifter I'll get freezing within a few hours but it could just be a coincidence when that happens.

We're talking about PD. It might take a year...or two.
I'm not aware, but I wonder how long it took PD to implement TrueForce for Logitech after the wheel was released?
 
Last edited:
BWX
I wish you all the luck in the world but I had maybe 20 hours or more of no trouble, then all of the sudden.. freezing issues again. I'm on a long stretch of no problems again but I know it's still going to do freeze sometimes. I bet if I plug in my sequential shifter I'll get freezing within a few hours but it could just be a coincidence when that happens.

What firmware combo are you running right now? I never had a freezing or disconnection issue on 455 base + 456 wqr, only on 457 and the hotfix, and also on the trial WQR firmware that was sent to me (1.1.0.2). Had the disconnect (requiring base restart) when base was on 456, but 455 has always been perfect for me, aside from the controller disconnect issue from the amps. I also have a sequential shifter plugged into shifter 2 port on the base, as well as the sq v1.5 and handbrake.
 
What firmware combo are you running right now? I never had a freezing or disconnection issue on 455 base + 456 wqr, only on 457 and the hotfix, and also on the trial WQR firmware that was sent to me (1.1.0.2). Had the disconnect (requiring base restart) when base was on 456, but 455 has always been perfect for me, aside from the controller disconnect issue from the amps. I also have a sequential shifter plugged into shifter 2 port on the base, as well as the sq v1.5 and handbrake.
Currently running this which is the most stable for me so far.

GT DD X

Driver 457

Wheelbase FW 2.1.0.4 "CS_DD_v2.1.0.4_hotfix_disconnection_issue_test_release.eff" manually installed after installing all 457 drivers.

Wheel FW 1.0.7.0 (457)

Wireless QR FW 1.1.0.1 (457)

They never sent me that WQR test FW. I'd like to try it but I think they want me to RMA the wheel base but haven't heard back from them in 2 weeks.

I thought it was shifter 1 port you were supposed to use. Hard to even find that info in any manual for the wheelbase. On the clubsport shifter manual it says shifter 1 port. 🤷‍♂️ But I'm using old (but compatible) sequential shifter from old CSL wheel. Need to get this Clubsport shifter hooked up to rig still.

Edit - I also have handbrake hooked up.

shifter port clubsport shifter fanantec.jpg


CSR xbox wheel set sequential shifter.jpg


edit this pdf https://fanatec.com/media/pdf/3c/ca/62/CSS-SQ-QG_WebVcm5Bpzj3AlUL.pdf

edit edit edit
And here is says shifter 2 port sequential only so I guess I'll try that.

shifter port clubsport shifter fanantec DD plus page.jpg
 
Last edited:
I've said it already but the fact that an OFFICIAL GT wheel is still not fully implemented is absolutely disgusting from PD.

So disrespectful for their partners (Fanatec in this case)...and -of course- their fans who spent 1200€ in the hardware.

Outrageous.
IMO this isn't the first time they've failed to properly support an officially licensed wheel. And when you take a step back and look at how they've treated this fan base over the last few years, I don't know how anyone can defend it. Yet, I see it all the time lol.

I find it humorous that same demographic of fans that hate seeing GT categorized as sim-cade are the same people who will argue that PD should focus on controller users and that wheel-ed users should be ok with what we have. I've never seen any wheeled users clamor for or ask for PD to NOT support controller users lololol. A large contingent of this fanbase will contort themselves into knots in effort to justify Kaz's/PD's actions.
 
DON'T update the Firmware.
As long as you ONLY use the Wheelbase for Ps5, there is absolutely no need to update it.
Same goes for the FullForce implementation.
The Wheelbase IS already capable of decoding the Signal.
Even with the Factory Firmware the Wheelbase comes shipped with.
The Firmware updates are only necessary if you intend to also use the Wheelbase for PC too.
And even then, it's not absolutely necessary unless a game strictly needs it.
So my advice stays the same.
DON'T update anything unless it's required.
 
Last edited:
DON'T update the Firmware.
As long as you ONLY use the Wheelbase for Ps5, there is absolutely no need to update it.
Same goes for the FullForce implementation.
The Wheelbase IS already capable of decoding the Signal.
Even with the Factory Firmware the Wheelbase comes shipped with.
The Firmware updates are only necessary if you intend to also use the Wheelbase for PC too.
And even then, it's not absolutely necessary unless a game strictly needs it.
So my advice stays the same.
DON'T update anything unless it's required.
So, is it possible to re install the firmware that everything was shipped with? Is there any way of getting it back if you have already updated?
 
So, is it possible to re install the firmware that everything was shipped with? Is there any way of getting it back if you have already updated?
Unfortunately there is no way no revert back the OEM Firmware the Wheelbase comes shipped with.
Hence you should NOT update it as long as it works out of the box.
Especially if you only intend to use it on the Ps5.
 
Unfortunately there is no way no revert back the OEM Firmware the Wheelbase comes shipped with.
Hence you should NOT update it as long as it works out of the box.
Especially if you only intend to use it on the Ps5.
Fortunately, mine seems to be ok, apart from a little coil whine which doesn't bother me as I can't hear it over the audio system.
I use mine on PS5, XBOX and PC
 
I sure wish I had never updated the firmware from the Factory Set up. I only play on PS5. Using the Firmware on PC Driver 455, I never had any issues, even though Fanatec said the WQR was susceptible to getting overloaded and disconnecting. Luckily, I never encountered this issue. Foolishly, I updated to 457, thinking if the WQR is is known issue, why not update. For 5 weeks I had no issues until last week. Now, Fanatec says to put the base back to the driver from 455 and leave the WQR at 457. They even have a very specific way they want you to do this manually with a provided file on their forum support page. I've yet to try this, but will soon. For now I've just re-mounted my DD Pro on the rig and it's been solid. I even ran a 4 hour endurance race on ACC with no issues, which is good because the DD Pro is not affected by this new wonky firmware shenanigans. :lol:
 
FMW
I sure wish I had never updated the firmware from the Factory Set up. I only play on PS5. Using the Firmware on PC Driver 455, I never had any issues, even though Fanatec said the WQR was susceptible to getting overloaded and disconnecting. Luckily, I never encountered this issue. Foolishly, I updated to 457, thinking if the WQR is is known issue, why not update. For 5 weeks I had no issues until last week. Now, Fanatec says to put the base back to the driver from 455 and leave the WQR at 457. They even have a very specific way they want you to do this manually with a provided file on their forum support page. I've yet to try this, but will soon. For now I've just re-mounted my DD Pro on the rig and it's been solid. I even ran a 4 hour endurance race on ACC with no issues, which is good because the DD Pro is not affected by this new wonky firmware shenanigans. :lol:

Did you get the Extreme bundle? In my case, out of the box my DD Extreme was unusable with the factory firmware (2.0.0.17 base, 0.6.6.5 wqr). The wheel doesn’t display the tuning menu values, the FFB on the Extreme wheel was weak and notchy. Updating the firmware fixed all of those issues.
 
Did you get the Extreme bundle? In my case, out of the box my DD Extreme was unusable with the factory firmware (2.0.0.17 base, 0.6.6.5 wqr). The wheel doesn’t display the tuning menu values, the FFB on the Extreme wheel was weak and notchy. Updating the firmware fixed all of those issues.
Do you play on Ps5 or PC, or both?
I'm still using the Factory Firmware it came pre installed and so far didn't had any issues which happen to be the exact same ones you mentioned.
That's very strange.
 
Did you get the Extreme bundle? In my case, out of the box my DD Extreme was unusable with the factory firmware (2.0.0.17 base, 0.6.6.5 wqr). The wheel doesn’t display the tuning menu values, the FFB on the Extreme wheel was weak and notchy. Updating the firmware fixed all of those issues.
No. I bought the DD+ base as a stand alone. I already own two Fanatec wheel rims, BMW GT3 V2 and the F1 2.5. I do recall reading on the Fanatec forums that folks with the Extreme should update.
 
Do you play on Ps5 or PC, or both?
I'm still using the Factory Firmware it came pre installed and so far didn't had any issues which happen to be the exact same ones you mentioned.
That's very strange.

I play on both. Have you already tried your new base (from the RMA) with the Extreme wheel? In my case the The FFB was weak and notchy on the extreme wheel but not my other wheels. Even when using on the PS5. I’m not the only one who had the same problem.



 
Last edited:
FMW
No. I bought the DD+ base as a stand alone. I already own two Fanatec wheel rims, BMW GT3 V2 and the F1 2.5. I do recall reading on the Fanatec forums that folks with the Extreme should update.

If you never had a problem with 455, then I’d definitely roll back the firmware. I was on 455 from March 17 to May 2 and never experienced a freeze or disconnect. Prior to that I tried 456 and had the disconnection that required restarting the base. When I updated to 457 I had the freezes almost everyday but I’m not entirely sure if my bass shakers were the cause. With the shakers and amps repositioned and sorted out, I’m not about to try 457 again though, right now I’m at 455 base and 456 wqr not a single freeze or disconnection
 
Last edited:
I play on both. Have you already tried your new base (from the RMA) with the Extreme wheel? In my case the The FFB was weak and notchy on the extreme wheel but not my other wheels. Even when using on the PS5. I’m not the only one who had the same problem.




Nope I sold my Extreme Wheel.
I mainly use the McLaren v2. So it probably might be down to this specific Wheel causing the issue.
 
Nope I sold my Extreme Wheel.
I mainly use the McLaren v2. So it probably might be down to this specific Wheel causing the issue.

Yes definitely has something to do with the Extreme wheel. I remember when I first tried the DD+ with the Extreme wheel and thinking “this is it?” with the FFB strength set to the same level (5) in GT7 it felt just slightly stronger than my DD Pro. Then I swapped it out for the McLaren and my reaction was “holy $h!t!!” It was so much stronger and super smooth and that’s how I knew I needed to update the firmware
 
Did you get the Extreme bundle? In my case, out of the box my DD Extreme was unusable with the factory firmware (2.0.0.17 base, 0.6.6.5 wqr). The wheel doesn’t display the tuning menu values, the FFB on the Extreme wheel was weak and notchy. Updating the firmware fixed all of those issues.
Mine was exactly the same as that, but I didn't take a note of the F/W that was factory installed.
I'm still on 455 for everything except the wheel which is 457.
No problems that I am aware of with the exception of the OLED display which started displaying crazy stuff and now doesn't work at all. I thought it was really dim from day one but now it's taken dim to a whole new level!
 
Last edited:
Hmm
I haven’t been on much over the past month. Just once a couple days ago using the dd extreme wheel..but i have been doing a fair amount of country road driving to blow off steam. The roads are a bit more fun than the nord, for comparison. Anyway, the wheel felt light as 💩 for the ffb on the heavier side of things, which felt nuts as most settings are fairy cranked. This was really confusing as my daily driver is presently an outback…and also that no one has complained about pd nerfing things again. I think for comparison, it was kinda like driving a smaller box truck with a small steering wheel.

Wondering if the extreme wheel was part of it. Will try to hop on later and try my 330mm, or the 275mm.
 
As of today, FullForce has been implemented in iRacing, next should be GT.
Please don't get my hopes up... Please lol. I'm fully committed to making a poor financial decision if the current owners approve of the implementation in GT7.
 
Last edited:
If you never had a problem with 455, then I’d definitely roll back the firmware. I was on 455 from March 17 to May 2 and never experienced a freeze or disconnect. Prior to that I tried 456 and had the disconnection that required restarting the base. When I updated to 457 I had the freezes almost everyday but I’m not entirely sure if my bass shakers were the cause. With the shakers and amps repositioned and sorted out, I’m not about to try 457 again though, right now I’m at 455 base and 456 wqr not a single freeze or disconnection
Good advice. I will for sure do that. Hopefully, I will have time this evening. I downloaded the file from the Fanatec forum which is supposed to make rolling back to 455 a lot easier. It appears people who were uninstalling 457 then reloading 455 were having install loop issues. The manual method with the specific file appears to have made it easier. :)
 

Latest Posts

Back