Issue loading .GIF from GTP proxy

Discussion in 'Site Support' started by Moglet, Aug 21, 2019.

  1. Moglet

    Moglet Premium

    Messages:
    11,986
    Location:
    United Kingdom
    I'm having a bizarre issue on one of my most recent posts in that the .GIF file doesn't seem to be loading. Checking on Imageshack the file definitely loads and plays as expected, however if I right click the broken image in the post and open that in a new tab it doesn't load. I've tried this while signed in, signed out and on my mobile browser as well as on PC and I get the same result on all of them. I even sent the Imageshack link to my wife who was very confused as to why she was being sent a GIF of a truck crashing.

    Have I done something wrong that may have caused this to fail to load?

    The URLs in question:

    Thread post: https://www.gtplanet.net/forum/threads/spintires-mudrunner.358366/page-14#post-12838308

    GIF URL:
    Code:
    https://imagizer.imageshack.com/img924/9134/7bQeHZ.gif
    Proxy URL:
    Code:
    https://www.gtplanet.net/forum/proxy.php?image=https%3A%2F%2Fimagizer.imageshack.com%2Fimg924%2F9134%2F7bQeHZ.gif&hash=9770874aff038678f6b907b255e36728
     
  2. Jordan

    Jordan Administrator

    Messages:
    23,031
    Location:
    United States
    It's too large. The maximum size of an image or GIF you can embed into a post is 10MB, and that GIF is 12.6MB.

    For larger movie-like GIFs, it's better to use a service like Gfycat and then just paste the link so it embeds as an MP4 in a web player:

     
    Moglet and TB like this.
  3. Moglet

    Moglet Premium

    Messages:
    11,986
    Location:
    United Kingdom
    Thanks Jordan, I wasn't aware there was a limit on the size. I'll update the post :tup:
     
  4. Moglet

    Moglet Premium

    Messages:
    11,986
    Location:
    United Kingdom
    I'm having issues with .jpg and .png files this time, I've tried hosting the image on Imgur and Imageshack and neither of them seem to work when embedded, but the URL is correct:

    Original URL: https://imagizer.imageshack.com/img921/1704/j0n5of.jpg

    URL after proxy:
    Code:
    https://www.gtplanet.net/forum/proxy.php?image=https%3A%2F%2Fimagizer.imageshack.com%2Fimg921%2F1704%2Fj0n5of.jpg&hash=ba367e15b1f5c7ef9fd80f4b7f6b3e0f
    Image:
    [​IMG]
     
  5. Jordan

    Jordan Administrator

    Messages:
    23,031
    Location:
    United States
    The image appears to be loading OK for me.

    Are you still having the issue?
     
  6. Sonygamer455

    Sonygamer455

    Messages:
    4,291
    Location:
    United States
    The image didn't load for me earlier today, but it is now.
     
    Moglet and kolio like this.
  7. kolio

    kolio

    Messages:
    2,631
    Location:
    United States
    I can confirm when you first posted, I too could not see it.

    EDIT: When @Moglet first posted it :p
     
    Last edited: Sep 20, 2019
    Moglet likes this.
  8. Moglet

    Moglet Premium

    Messages:
    11,986
    Location:
    United Kingdom
    It appears to be working correctly now, thanks!
     
    Jordan likes this.