Assetto Corsa in VRPC 

  • Thread starter r3b3ld3
  • 169 comments
  • 30,558 views
404
United Kingdom
United Kingdom
It's simple, download it, open it and switch to open composite then start any compatible game in steam vr mode, job done. You can switch back to steam vr by using the switcher or just by launching steam vr from the button in the top corner of steam.
Ok. Seems easy enough. Cheers.
 
235
United Kingdom
UK
It is simple and gives a good performance boost. You clearly have a deeper problem if you haven't seen a big uplift since your upgrade, sorry I can't help further.
 
404
United Kingdom
United Kingdom
you still looking for these settings? been away poorly but can walk you through it if you still need em
Hope your getting better now. Yes if you don’t mind. Just the main settings would be a great help. Sorted one problem with windows
11 which was causing horrendous problems. Many thanks.
 
404
United Kingdom
United Kingdom
It is simple and gives a good performance boost. You clearly have a deeper problem if you haven't seen a big uplift since your upgrade, sorry I can't help further.
Hi . Now up and running on Openxr / open composte. This has helped a lot. Visual’s clearer, more stable altogether.
Replay also stable now. Just got to figure out how to stop the audio switching when I go back to desktop. Has dropped the Main T in Asseto Corsa fps app to 92 instead of 98-99 as was before. Not sure if that should be lower though. Thanks again for your help.
 
404
United Kingdom
United Kingdom
Hi All.
Does anyone know how to stop flickering on crash barriers ect . Tried a few things but not stoped it yet. It’s more obvious in replays. Cheers. Using content manager with G2 head set.
 
207
Canada
Canada
Just upgraded from Q2 to G2. Couldn't get SteamVR to see the headset no matter what (tried the tips available) so I tried OpenComposite/OpenXR toobox and bang. It works :) Thanks to all in this topic. Good discussion!
 
1,255
Quest 2 + Windows 10 --or-- Quest 2 + Windows 11 ??

What's the current assessment? Have the Windows 11 issues been fixed?

It might have been an Oculus app issue, but not sure?

I'm Currently using Windows 10. It works, but I still haven't investigated why I'm only getting 45FPS with a RTX 3070 Ti--note that this gaming system has an i7 7700K and a Z270X-Ultra Gaming-CF MB (DDR4 4130 2x8GB), so maybe it's a bottleneck issue.

I'm getting a 3090 for my new-being-built-next-week workstation PC for 3D modeling and animation. I wonder if a 3090 would be bottlenecked on my gaming system, or if it's another issue that's affecting the 3070 Ti's performance in AC.
 
Last edited:
404
United Kingdom
United Kingdom
Quest 2 + Windows 10 --or-- Quest 2 + Windows 11 ??

What's the current assessment? Have the Windows 11 issues been fixed?

It might have been an Oculus app issue, but not sure?

I'm Currently using Windows 10. It works, but I still haven't investigated why I'm only getting 45FPS with a RTX 3070 Ti--note that this gaming system has an i7 7700K and a Z270X-Ultra Gaming-CF MB (DDR4 4130 2x8GB), so maybe it's a bottleneck issue.

I'm getting a 3090 for my new-being-built-next-week workstation PC for 3D modeling and animation. I wonder if a 3090 would be bottlenecked on my gaming system, or if it's another issue that's affecting the 3070 Ti's performance in AC.
If you go to Windows 11 just make sure you stop the holographic shell from running as it affects Nvidia latest cards. If you need any help on how to do it let me know. I have informed Windows but they have not done anything to stop it yet.
 
44
Netherlands
Netherlands
Does anybody know why my shadow starts rendering from somewhere around the steering wheel, nothing behind. 







I noticed this ever since I turned off "Smart shadow>Custom shadow matrices". But I really need to turn that setting off, because otherwise in VR every shadow starts flickering massively when I'm moving my head.



Edit: I tested some more. It happens in open vr and oculus vr mode. Tried different headsets. It doesn't happen in single screen mode.
If starting in vr and changing camera view (F7) the problem remains.
 

Attachments

  • unnamed.png
    unnamed.png
    335.3 KB · Views: 9
Last edited:
269
Belgium
Belgium
It's happened. Upgraded from a GTX 1080 Ti to a 3070 Ti.

On my ulta-wide screen, the performance is incredible. Very good benchmark settings.

I just benchmarked Shadow of the Tomb Raider on my widescreen. With everything on, with the highest settings, 2450x1080 at 144Hz, I got an average of 107FPS.

I get very high FPS when playing Control, a graphic intensive "psychokenetic" game, that features ray-tracing on almost every surface. That's with the RTX effects on at the highest graphics settings.

HOWEVER...
Assetto Corsa in VR... still getting the same performance as with the 1080 Ti. 45FPS. Same results with a link cable, and with Airlink (haven't tested Virtual Desktop yet)

Guess it's time to go through the previous posts on this thread to troubleshoot the issue.

Disappointed at the moment, but hopeful.


I’m also having VR issues . Upgraded from a 1080 to a 4090 with a 12900k cpu and 32 G2 ram ect. Not much difference in performance. Would be interested to see if anybody is running on Windows 10 not 11 as I am. I got a feeling it’s a problem with Windows 11. Any ideas please.

<snip> I still haven't investigated why I'm only getting 45FPS with a RTX 3070 Ti--note that this gaming system has an i7 7700K and a Z270X-Ultra Gaming-CF MB (DDR4 4130 2x8GB), so maybe it's a bottleneck issue.

I'm getting a 3090 for my new-being-built-next-week workstation PC for 3D modeling and animation. I wonder if a 3090 would be bottlenecked on my gaming system, or if it's another issue that's affecting the 3070 Ti's performance in AC.
Hi, for all you out there using Quest 2 and getting 45fps with a beast of a pc/gpu :
this reads to me as being ASW turned on (this cuts framerate in half , 45 being exact half of 90.... )
Make sure ALWAYS to turn off ASW via Oculus Debug Tool (this setting does not save so you need to do it each time you enable PC Link !! )

And another great performance enhancing tip (for AC but also for all other race titles) :
In Oculus Debug Tool also, set FOV multiplier to "0.8; 0.4" !
You will render only 80% horizontally and 40% vertically, saving massive amounts of GPU performance, and in race titles it does not break immersion (on the contrary , you can imagine more that you are wearing a helmet and the limited FOV is because of that ;) )

Here's a screenshot of the 3 settings I change each time right after I enable my Oculus Link:

1671526928636.png



cheers and happy holidays!
 
1,255
Hi, for all you out there using Quest 2 and getting 45fps with a beast of a pc/gpu :
this reads to me as being ASW turned on (this cuts framerate in half , 45 being exact half of 90.... )
Make sure ALWAYS to turn off ASW via Oculus Debug Tool (this setting does not save so you need to do it each time you enable PC Link !! )

And another great performance enhancing tip (for AC but also for all other race titles) :
In Oculus Debug Tool also, set FOV multiplier to "0.8; 0.4" !
You will render only 80% horizontally and 40% vertically, saving massive amounts of GPU performance, and in race titles it does not break immersion (on the contrary , you can imagine more that you are wearing a helmet and the limited FOV is because of that ;) )

Here's a screenshot of the 3 settings I change each time right after I enable my Oculus Link:

View attachment 1217050


cheers and happy holidays!
I just returned from my trip and tried these settings. I'm now getting 80-90FPS with pretty good quality settings.

The only thing I didn't like was the FOV-Tangent Multiplier at 0.8;0.4. I set it at 0.8;0.8 and the "crop" is barely noticeable, if at all.

I've also just tested it with the Render Resolution in the Oculus App set to max at 1.7 (5408 x 2736), and it didn't affect the FPS in AC very much, but the quality is wonderful with almost no aliasing issues.

1672283692292.png

Now I want to take the leftover parts from my previous workstation PC (BIOS flaked, MB dead), build a secondary PC for friends to network-race, install my older 1080 Ti in it, and see what kind of performance I can get with the same Oculus Debug Tool settings. Of course it's not as powerful as the new 3070 Ti, but it should improve performance some.
 
269
Belgium
Belgium
on a 3070Ti I settled at 80Hz and 1.5 render resolution...
Together with FOV at 0.8; 0.4 this allows me to run AC at almost all max settings (including any PP filter ) and still keep a decent amount of headroom to almost never drop below 80fps...
I tend to favour that steady fps over the occasional frame drop, so I aim at +- 50% GPU headroom, on a well optimized track with 5 or so good optimized cars as AI opponents (use the CM Analyse button to check the mods Triangle count esp.)

The clarity difference between 1.7x and 1.5x is neglect-able imho...
then again this is all personal preference. You may favour the extra fidelity and don't mind the occasional fps drop/stutter.

With a 1080Ti I would certainly not aim for 90 fps in VR, but rather 80 or 72Hz (and render res. at x1.2 or 1.3) depending on how much GPU headroom you have left.


cheers and happy fine-tuning!
 
Last edited:
17
Germany
Germany
Is it normal that the FOV-Tangent Multiplier goes every PC restart to 0.0 again?
Other problem: When I change the values sometimes nothing happens.
May I missed something. :confused:
 
39
Germany
Germany
Hello,

would you please help me. I can't get OpenXR Toolkit to work correctly.

I have installed OpenXR for Windows Mixed Reality and Net Framework 4.8.

Unzipped OpenComposite.zip and OpenOVR-openxr.zip into one directory. Launched OpenComposite and VR works. OpenXR Toolkit started, program font is green but no menu appears. Keyboard works.


This seems to be due to OpenComposite.

I have OpenComposite.zip and OpenOVR-openxr.zip. When I run OpenComposite.exe, VR works with the G2, but OpenXR Toolkit shows no settings menu in the game.

Does OpenComposite need to work with OpenOVR-openxr and how can I do that?
 
404
United Kingdom
United Kingdom
Hello,

would you please help me. I can't get OpenXR Toolkit to work correctly.

I have installed OpenXR for Windows Mixed Reality and Net Framework 4.8.

Unzipped OpenComposite.zip and OpenOVR-openxr.zip into one directory. Launched OpenComposite and VR works. OpenXR Toolkit started, program font is green but no menu appears. Keyboard works.


This seems to be due to OpenComposite.

I have OpenComposite.zip and OpenOVR-openxr.zip. When I run OpenComposite.exe, VR works with the G2, but OpenXR Toolkit shows no settings menu in the game.

Does OpenComposite need to work with OpenOVR-openxr and how can I do that?
Hi . I have the same but not needed to use the toolkit yet. I thought you can use the toolkit on your monitor.
 
39
Germany
Germany
Thanks for the answer. On the monitor I have but no settings menu but only in the VR view in the game.

Or is that also possible on the monitor?
 
39
Germany
Germany
The Configs folder of OpenXr Toolkit is empty. Would someone please send me his config file. Maybe I can use them.