Fanatec Gran Turismo DD Extreme Wheel

  • Thread starter super_gt
  • 802 comments
  • 82,702 views
Mine didn't work with GT7 out of the box at all. I updated straight to 455 after reading about issues with 456 and the only issues I've had are a few fairly random connection losses. Typically I lose the functionality of some combination of the funky switch, paddle shifters, buttons and FFB. Restarting the base gets everything back to normal in about 15 seconds. Would be pretty bad if I was in a sport race or something but so far has only happened once in a low-stakes race with friends and a few times doing TTs.
 
Just had massive disconnect doing the FUJI weekly race challenge. Was using PSVR2 and on last lap it was raining, had cars all around and not only did I lose FFB and buttons on wheel, but frame-rate was like 15 fps too. DualSense was disconnected so I couldn't even pause. Had to jump out with button on VR goggles. Only thing I'm doing different is I had sensitivity slider in game at 10 instead of 5 or lower. Then when I rebooted wheel I couldn't even put it into blue PS mode, it kept jumping over that one. Rebooted again and it worked, then finished race on flat screen. Also had weird issues with PSVR2 earlier when after a race it lost room memory, and I got stuck on a screen saying to put on VR goggles and there was just that little "busy notification line" and nothing else. I wonder if there's some issue with USB bus bandwidth when using both VR and this wheel. 457 and GT7 full support for this wheel cannot come soon enough. I wonder if tonight's GT7 update will do anything.
 
So the wheel is added in the patch notes - I highly doubt it but does it add ITM support? And are the LEDs colored now? Can't check until later today
 
4 am so not going to test it but:

IMG_4668.jpeg


IMG_4669.jpeg


IMG_4670.jpeg


Looks like they added a few lines of text...
 
Last edited:
Has anyone tried it?

Is the ffb the same nerfed sadness or did they give us some actual attention?

Went out for a little rip around the back roads tuesday. Id say game ffb for gr3’s is about 1/20th of the ffb my ‘19 outback was giving. Which is confusing as 15nm was supposed to equate to most road cars, ya?

In game 8(tried 9 but wasn’t better, just artificially heavier) and 7 in game. Wheel at 100.
 
Is this the wheel that TheKie uses.....looks like it pooped on him in the middle of his stream yesterday during the GTWS race.



 
Last edited:
Is this the wheel that TheKie uses.....looks like it pooped on him in the middle of his stream yesterday during the GTWS race.




Yes, that is the bug that this is supposed to fix:
FMW
Here you go everyone. PC Driver 457 with all the new firmware for your gear is ready. Use at your own risk. Good luck all. Let me know how it goes for all those affected by 456 and 455.

..and alternate ver of Kie video from my personal favorite Kie YouTube channel:
 
Last edited:
Is this the wheel that TheKie uses.....looks like it pooped on him in the middle of his stream yesterday during the GTWS race.




I immediately imagined some nasty smelly goo squirting out of the wheel on his face. 💩
Now that would be a bad bug.
 
That Fullforce is pretty interesting. That'll probably add a lot to GT7 whenever they finally implement it. That demo is crazy, it sounds like water running though a copper pipe or something.
 
Is it me, or did they alter the FFB coding?

Was doing some GTWS testing, and I noticed more dynamic range. Especially at Daytona. I felt every nuance on the track
 
Last edited:
Driver 457 on GT DD X was working fine for a couple hours and then the wheel locked up for a few seconds, then fixed itself. Other than that it's been working great. One thing I noticed is my hand brake input is really jumping all over the place in GT7 when you look at the calibration screen even when holding it still and it wasn't on PC driver where it shows the inputs. 🤷‍♂️

So maybe there are still some bugs to work out.

This is the sequential shifter I was using from one of my old wheels (it is compatible):
CSR xbox wheel set sequential shifter.jpg



I'll just copy what I wrote in description:
------------------
Wheel was working fine for a couple hours doing some weekly challenge single player races and then that Skoda VGT Online Time Trial at Watkins Glen, then I was doing this new Trial Mountain 550pp race, this was like my 3rd or 4th time doing the race and the wheel locked up completely while FFB kept pulling to the right, then it fixed itself. All the lights on wheel stayed on and it was fine after that but this seems like a bug in the firmware or something.

Was on flat screen, not using PSVR2. I was using sequential stick shifter (no clutch), not sure if that has anything to do with it, but it was the first time using it in a while and first time using it today. I have it mapped to wheel paddle shifters in driver on PC. Not the clubsport shifter but an old one that came with old Fanatec CSR XBOX wheel, but it is compatible.

Sim rig: Fanatec GT DD Extreme - QR2 // CSL Elite v2 Pedals // ClubSport Handbrake V1.5 // ClubSport Shifter SQ V 1.5 + (not hooked up) // Sim-Seats SR-X Racing Rig // 2 x 50 watt 4 Ohm AuraSound AST-2B-4 Pro Tactile Transducers
-------------------

 
Is it me, or did they alter the FFB coding?

Was doing some GTWS testing, and I noticed more dynamic range. Especially at Daytona. I felt every nuance on the track
Don’t tease..!
Had to human all day. Will be on tomorrow afternoon…pretty sure im not going to get brave with 457 yet though.
 
I haven’t driven in GT7 for a while so can’t comment on FFB detail, but the strength level is about the same as before, stilled capped. The FullForce test in the 457 driver is definitely interesting, it’s like adding a bass shaker onto drive shaft. But before actually trying it out with an actual game, I’m not sure whether I like it or not.
 
BWX
I don't know if FFB is better but it feels really nice. It's definitely not worse!
On the Jaguar TT yesterday I also had the subjective impression it's more nuanced and there's more feedback from the track & car.
(I wish PD would add their FFB / wheel changes to the release notes... It's ridiculous (& probably one of those unexplainable PD "excentricities") that we need to second guess/tea-leaf-read this...).
I havent updated to 457 yet and will also hold for a few days. Since there s no full force other than the demo, I might test if it resolved some of the disconnection issues, but have only semi high hopes, and in no mood to brick the already fickle unit...


Also - is anyone else having this issue with the dd+ base / qr2 (I have universal hub V2 w Xbox compatibility, which might play into this as well):
The wheel never gets registered in PS5/gt7 IF I just power up the base (doesn't matter if switched on before or after PS5...).
To make it register, I always need to:
  • pull off the wheel/qr2 (metal, but not pro or lite version...)
  • only then power up the dd+
  • wait for ps5 / blue mode to engage (it always boots up in red - takes about 2-4 seconds to switch to ps5 mode automatically when PS5 is powered up)
  • only then attach the wheel & qr2, and only then the small LED blinks once & the on-universal-hub display starts to show a number briefly
  • and only then the Xbox/ps5 button on the hub works to register the wheel with PS5 as a controller...

Is that standard for anyone/everyone else ?
And/or, is there a workaround ? It's a bit tedious & annoying, and feels like it should not be like this...
 
Last edited:
BWX
Driver 457 on GT DD X was working fine for a couple hours and then the wheel locked up for a few seconds, then fixed itself. Other than that it's been working great. One thing I noticed is my hand brake input is really jumping all over the place in GT7 when you look at the calibration screen even when holding it still and it wasn't on PC driver where it shows the inputs. 🤷‍♂️

So maybe there are still some bugs to work out.

This is the sequential shifter I was using from one of my old wheels (it is compatible):
View attachment 1350234


I'll just copy what I wrote in description:
------------------
Wheel was working fine for a couple hours doing some weekly challenge single player races and then that Skoda VGT Online Time Trial at Watkins Glen, then I was doing this new Trial Mountain 550pp race, this was like my 3rd or 4th time doing the race and the wheel locked up completely while FFB kept pulling to the right, then it fixed itself. All the lights on wheel stayed on and it was fine after that but this seems like a bug in the firmware or something.

Was on flat screen, not using PSVR2. I was using sequential stick shifter (no clutch), not sure if that has anything to do with it, but it was the first time using it in a while and first time using it today. I have it mapped to wheel paddle shifters in driver on PC. Not the clubsport shifter but an old one that came with old Fanatec CSR XBOX wheel, but it is compatible.

Sim rig: Fanatec GT DD Extreme - QR2 // CSL Elite v2 Pedals // ClubSport Handbrake V1.5 // ClubSport Shifter SQ V 1.5 + (not hooked up) // Sim-Seats SR-X Racing Rig // 2 x 50 watt 4 Ohm AuraSound AST-2B-4 Pro Tactile Transducers
-------------------


Very strange indeed.
This is what is happening here after Driver 457


The sudden and random loss of FFB is still present.
Anyway I managed to open a Support ticket.
But nevertheless very very annoying 🙄

Edit :
Update 15:50
@BWX i just encountered the exact same issue as in your video.
Wheel went super heavy and just continued turning left.
Had to shut off the Wheelbase.
 
Last edited:
Very strange indeed.
This is what is happening here after Driver 457


The sudden and random loss of FFB is still present.
Anyway I managed to open a Support ticket.

But nevertheless very very annoying 🙄
I still think it's a FW thing but who knows. Mine was working perfect for hours and I had that one incident. I hope Fanatec looks into it.
On the Jaguar TT yesterday I also had the subjective impression it's more nuanced and there's more feedback from the track & car.
(I wish PD would add their FFB / wheel changes to the release notes... It's ridiculous (& probably one of those unexplainable PD "excentricities") that we need to second guess/tea-leaf-read this...).
I havent updated to 457 yet and will also hold for a few days. Since there s no full force other than the demo, I might test if it resolved some of the disconnection issues, but have only semi high hopes, and in no mood to brick the already fickle unit...


Also - is anyone else having this issue with the dd+ base / qr2 (I have universal hub V2 w Xbox compatibility, which might play into this as well):
The wheel never gets registered in PS5/gt7 IF I just power up the base (doesn't matter if switched on before or after PS5...).
To make it register, I always need to:
  • pull off the wheel/qr2 (metal, but not pro or lite version...)
  • only then power up the dd+
  • wait for ps5 / blue mode to engage (it always boots up in red - takes about 2-4 seconds to switch to ps5 mode automatically when PS5 is powered up)
  • only then attach the wheel & qr2, and only then the small LED blinks once & the on-universal-hub display starts to show a number briefly
  • and only then the Xbox/ps5 button on the hub works to register the wheel with PS5 as a controller...

Is that standard for anyone/everyone else ?
And/or, is there a workaround ? It's a bit tedious & annoying, and feels like it should not be like this...
My GT DD X doesn't do that, it acts normal as far as how the game/ PS5 detects it and it comes on in the same mode I left it every time. 🤷‍♂️
 
I followed this thread to some extend so I didn't read all the posts, so don't be mad if someone already wrote this :)

For all the guys with the disconnect issues, I had an interesting situation.

I have the GT DD Pro, McLaren GT3 v2 and V3 pedals. Didn't have any issues until recently, which somehow aligned with my purchase of the BMW GT2 v2 steering wheel. When I mounted that wheel, the disconnect issues started happening, only on PS5, not on PC. They were much more present in blue mode and more or less in purple mode, but still present and extremely annoying. Tried this driver, that driver, updated firmware, changed all the ports on PS5, nothing helped.

And then I tried to connect my base to my PS5 with a new TypeC>TypeC cable which is 1 meter long (which I bought of Aliexpress, so it's a "no name" chinese cable). And never had a single disconnect since? In the meantime I tried another C>C cable that was 2 meters long and still had some disconnects, but with this 1 meter long C>C, not a single disconnect either with the McLaren wheel or with the BMW wheel, purple or blue mode, doesn't matter. I'm currently on 455.

So I don't know what to think of this, but the issue doesn't exist anymore :D
 
And then I tried to connect my base to my PS5 with a new TypeC>TypeC cable which is 1 meter long (which I bought of Aliexpress, so it's a "no name" chinese cable). And never had a single disconnect since? In the meantime I tried another C>C cable that was 2 meters long and still had some disconnects, but with this 1 meter long C>C, not a single disconnect either with the McLaren wheel or with the BMW wheel, purple or blue mode, doesn't matter. I'm currently on 455.
This reminds me that in the early days of having my Logitech G29 wheel I would have disconnects regularly and the final solution was to change out the USB cable used to connect to the PS5. I originally ordered a USB3 extension cable and that was a disaster. What solved it was actually getting a USB2 only cable. This one in fact.


I'm not sure about fanatec but I read that the Logitech products only work on USB2 anyway and so it was best to keep with USB2 cables. I'm still using the same cable with the DD GT Pro and it has been 100% solid.
 
I’ve been using a USB switcher on my DD Extreme (and on my previous DD Pro) because I got tired of having to unplug from one device and plug to the other. Now I just have to press a button to switch to PC from PS5 and vice versa. No disconnects, works great. I even have my wireess headset dongle connected to it so I get to use the same headset for both
 
Last edited:
I used to have disconnect issues with my DD Pro using either my BMW GT2 V2 wheel or F1 V 2.5. What solved it was changing the USB port. I used to use the Type A at the front. Now I use the Type A in the rear. Both my DD Pro and my My DD+ have not once disconnected using those same wheels. That's on firmware on PC Driver 455.

As a side note: Maurice over on the official Fanatec forums (For those that are not aware is one of the most helpful firmware beta testers) Anyway, he says that if people are still have "disconnect issues" then it's a hardware problem, therefore people will need to contact support.

I have yet to update to the firmware on PC driver 457 for my DD+ (kind of scared since 455 seems to work just fine), but I did update my DD Pro Base. I will try that tonight to see how it runs.
 
Back