Fanatec Podium Direct Drive Wheel Bases Thread

  • Thread starter super_gt
  • 3,718 comments
  • 525,385 views
Yeah, what QR2 news? Did hell just freeze over or has Fanatec released information on new quick release?
Forum is back
QR2 - this is a fundamental change to the ecosystem and our opportunity to make major improvements to the quick release. While we (and BMW) are satisfied with our QR design currently being used on the M4 GT3 race car, it has been a challenge to bring this design to mass production for our full range of steering wheels and wheel bases (including a ‘Lite’ version for our CSL Series). The extended development time has ensured the best possible future for the Fanatec quick release. The latest pre-production samples are performing great, but we will only provide release dates and pricing information when we are ready.
 
Yeah, what QR2 news? Did hell just freeze over or has Fanatec released information on new quick release?
From the Fanatec website:


QR2 - this is a fundamental change to the ecosystem and our opportunity to make major improvements to the quick release. While we (and BMW) are satisfied with our QR design currently being used on the M4 GT3 race car, it has been a challenge to bring this design to mass production for our full range of steering wheels and wheel bases (including a ‘Lite’ version for our CSL Series). The extended development time has ensured the best possible future for the Fanatec quick release. The latest pre-production samples are performing great, but we will only provide release dates and pricing information when we are ready.
 
Regarding the QR2, I’ve had my own theory as to what the problem may be, but it’s purely hypothetical. Internal to the base, the direct drive systems are already delivering power and data to the wheel (or button module endurance) wirelessly. Hypothetical issue: The QR2 introduces a secondary wireless system. This can’t be easy and would explain why the QR2 works fine in the BMW.
Wondering if I can ever find out how close I was to the actual issue.
 
Last edited:
I think Im using version 439, but with the latest Gran Turismo 7 update when the feedback changed, I changed my wheel settings.

In game I now run:
7, 10, 1
Wheel base I now run:
100% FFB

groove, you are now running in game controller sens 7, wheel torque 10, wheel sens 1 with wheel base 100% FFB? with the F1 wheel too? Insane how you can stream for hours with those settings let alone a single race. I just got the DD1/PS4 and with a 32cm wheel, in game FFB 5, sens 1 with base 60-70% depending on the car. I also noted in the fanatec forum that using in game FFB greater than 6 would induce clipping, but not sure if this happens with GT7, probably not as you have been using your settings with apparently no issues.

I thought that the OLED on the base would be able to show force curves which would show clipping if present, but I have not figured out how to view that, nor other data that the manual shows, only device version/ firmware state
 
I used to run in game 5 with a wheel setting of around 50, I'm now running in game at 3 with FFB at just over 65, I'm using the Porsche GT3 rim....
 
Last edited:
I used to run in game 5 with a wheel setting of around 50, I'm now running in game at 3 with FFB at just over 65, I'm using the Porsche GT3 rim....
What was the difference going to in game FFB 3 vs 5? I'm using the 918 RSR wheel, I like the 32cm diameter, I can't get used to the F1 wheel. I wish I could fit the RSR wheel with magnetic shifters (magnetic shifters on the F1 are very nice).. I'll wait until the QR2 comes out before I look for an upgrade. I'm playing only GT7
 
F0F8DD32-AB71-4216-B5C9-D159DC71154B.jpeg
 
It seems that this thread, at one time at least, was more informative than the Fanatec forum(s) (or I didnt find the correct thread) regarding the DD1 and Podium DD1 in particular. My "issue" appears not uncommon (the below picture shows my set up);
1) OLED shows the "wheel not supported....." when booting up the base. It takes multiple power on and offs before its functional
2) If I do not get the "wheel not supported...", half the time the attached wheel icon is not present (on the OLED), pedals are always present
3) my 918 RSR wheel never has this issue
4) drivers and firmware are up to date
5) periodically, FFB is doubled, requiring option---->continue to reset, other than that (and the above symptoms), I am very happy with the system
6) I did complete a "service" questionnaire, from logged in (all of my Fanatec purchases where through Endor); no response for over a month
7) I purchased the "F1 Podium (DD1 for PS4/5)" at the end of this year, as well as the podium hub, clubsport magnetic shifters, and button pods

I would like some insight as to what the problem is and if it is correctable. Could it be the podium hub? The RSR wheel never has an issue. I much prefer the wheel pictured.
 

Attachments

  • 69173552251__AC91579A-F23D-422F-B94D-FD53A43165C0.jpg
    69173552251__AC91579A-F23D-422F-B94D-FD53A43165C0.jpg
    147.2 KB · Views: 17
Last edited:
It seems that this thread, at one time at least, was more informative than the Fanatec forum(s) (or I didnt find the correct thread) regarding the DD1 and Podium DD1 in particular. My "issue" appears not uncommon (the below picture shows my set up);
1) OLED shows the "wheel not supported....." when booting up the base. It takes multiple power on and offs before its functional
2) If I do not get the "wheel not supported...", half the time the attached wheel icon is not present (on the OLED), pedals are always present
3) my 918 RSR wheel never has this issue
4) drivers and firmware are up to date
5) periodically, FFB is doubled, requiring option---->continue to reset, other than that (and the above symptoms), I am very happy with the system
6) I did complete a "service" questionnaire, from logged in (all of my Fanatec purchases where through Endor); no response for over a month
7) I purchased the "F1 Podium (DD1 for PS4/5)" at the end of this year, as well as the podium hub, clubsport magnetic shifters, and button pods

I would like some insight as to what the problem is and if it is correctable. Could it be the podium hub? The RSR wheel never has an issue. I much prefer the wheel pictured.
Its an issue in the QR board. So a hardware issue and you have to contact the support.
 
Its an issue in the QR board. So a hardware issue and you have to contact the support.
So the problem is the hub? If all I need to do is send the hub, that will be ideal.
Appreciate the response

if you don't mind, would this also account for the periodic increase in FFB?
 
It seems that this thread, at one time at least, was more informative than the Fanatec forum(s) (or I didnt find the correct thread) regarding the DD1 and Podium DD1 in particular. My "issue" appears not uncommon (the below picture shows my set up);
1) OLED shows the "wheel not supported....." when booting up the base. It takes multiple power on and offs before its functional
2) If I do not get the "wheel not supported...", half the time the attached wheel icon is not present (on the OLED), pedals are always present
3) my 918 RSR wheel never has this issue
4) drivers and firmware are up to date
5) periodically, FFB is doubled, requiring option---->continue to reset, other than that (and the above symptoms), I am very happy with the system
6) I did complete a "service" questionnaire, from logged in (all of my Fanatec purchases where through Endor); no response for over a month
7) I purchased the "F1 Podium (DD1 for PS4/5)" at the end of this year, as well as the podium hub, clubsport magnetic shifters, and button pods

I would like some insight as to what the problem is and if it is correctable. Could it be the podium hub? The RSR wheel never has an issue. I much prefer the wheel pictured.
Not to discount the reply that you already received, but Fanatec software is a bit troublesome (I’m being nice here). It will be easier for you to do some work on your end before you send in any equipment. Uninstall the driver package and then re-install driver package. (Or if you have a previous driver version in your download folder, you can uninstall and reinstall that). Test it. From personal experience, I can tell you that there were numerous releases that didn’t work for me and I would revert back to the last driver that worked for my set up. This was a while ago, so not the v44x drivers. (I have a DD1 F1 with Podium hub with Podium Button Module Endurance and clubsport magnetic shift module.)
What has happened recently, after a windows update, my fanalab wouldn’t recognize my pedals or steering wheel. I had to reinstall the latest driver to get it to work. Typical stuff, nothing new when hiccups occur.
 
Last edited:
clearly not driver or firmware related, I recently installed driver 450 hoping that would help; it did not.

It may be my browser (firefox), but I cant figure out how to contact support, or get any info on sending it in for repair, its still under warranty. Hopefully, the repair facility is in Cali, if and when I can send it.
 
Yes, in California last I used them. You mentioned support questoinaire, if you ever had service, contact by the email address from the last time.
MOTO question: Have you looked for damaged pins in your RSR hub? With any amount of fortune, you can use the F1 wheel in the meantime. Best wishes.
 
Yes, in California last I used them. You mentioned support questoinaire, if you ever had service, contact by the email address from the last time.
MOTO question: Have you looked for damaged pins in your RSR hub? With any amount of fortune, you can use the F1 wheel in the meantime. Best wishes.
The 918 RSR wheel is functional 100% of the time. The wheel that the above pic shows (preferred wheel) requires power on and off cycles, usually four or more, before its functional. That wheel uses the podium hub, whose pins are clean and intact. I gave the F1 wheel away to an average you tuber. I like the RSR wheel, but not the shifters.
I did complete the questionaire, but have not received a reply, no contact with service otherwise. I loathe the idea of using the CLS elite base until I get the DD1 back, but it appears, as Maurice (I think that is him) mentioned, or suggested, service is familiar with this issue and the correctable problem.
 
So, when in GT7, for some reason the wheel won't shift after a lap or two, I have to restart the wheel to get it to work.

Also, the FF seems to break loose, and the feel is horrible, is anyone else having this issue?

Driver is 450
 
My lightly used Podium DD1 failed with the WQR issue during a 30 min gaming session (not from FW upgrade). Symptoms were the base powers up and rotates the wheel then shuts off. I was on driver 447 at the time and tried all the different FW versions as boot loader mode works.

After installing the 336 driver and using that version to downgrade the base firmware, the base does boot up and connect to the PC successfully with the fans running full but does not see the wheel. I can then install a different driver and it lets me update the Base or Motor FW manually, however I get the WQR initial ping error after the updating the base firmware with any recent version.

I contacted support and went through all of the usual troubleshooting and sent the base in for RMA repair (out of warranty). My expectation was that this could be repaired after reading numerous posts about this same issue on their forum and other sites, however USA support apparently is unable to repair this type of issue so now I am left with the options to return the DD1 or buy a Refurb unit at 30% off ($962).

I am not willing to shell out $962 for a refurbished unit, so is there any option to buy a WQR module from Fanatec (or other alternaive) and repair it myself as my base is low hours? I saw a good DD1 tear down video on YT, but not sure how to identify the WQR module and where it is located in the base?

Has there been any info on upgrading existing DD1's to QR2 - as I can just hang on to this base if it can be upgraded / repaired later as I already bought a CSL DD Pro Base in the mean time as a replacement.

1692639476018.png
 
Last edited:
Kind of confused with the DD1 setting for FFS (Peak or Linear). I've been running my DD1 with GT7 at 75% FFB and FFS on Peak. All recommended settings I've seen say to use FFS on Peak. However, I've also seen that with a powerful direct drive wheelbase, to use Linear. So, which is the proper setting on a DD1, is it Linear or Peak?
 
Installed the PS4/DD1 to play GT7. Anyone here know if you can still map the buttons using the GT wheel from the DD Pro while attached to the DD1? When I go into the in game tuning menu for the DD1 base on GT7 is shows the F1 wheel. There does not seem to be a way to select the GT wheel to program unless I'm just missing something?
 
Installed the PS4/DD1 to play GT7. Anyone here know if you can still map the buttons using the GT wheel from the DD Pro while attached to the DD1? When I go into the in game tuning menu for the DD1 base on GT7 is shows the F1 wheel. There does not seem to be a way to select the GT wheel to program unless I'm just missing something?
Not possible.
 
Not possible.
PD should really flip around the way button assignment works in GT. It's so annoying to have to assign functions to buttons instead of buttons to functions (like how it works in every other game I know).
For any custom wheels I now need to know exactly how the buttons map to the wheel that's shown in game. And I can't configure any additional buttons my wheel may have.
On the other side PD needs to add another config screen for every single wheel base they support, which is just extra work for them as well.
 
PD should really flip around the way button assignment works in GT. It's so annoying to have to assign functions to buttons instead of buttons to functions (like how it works in every other game I know).
For any custom wheels I now need to know exactly how the buttons map to the wheel that's shown in game. And I can't configure any additional buttons my wheel may have.
On the other side PD needs to add another config screen for every single wheel base they support, which is just extra work for them as well.
Agreed!
 
Thanks for confirming. I was afraid of that.
Untimely reply, but I’m using a wheel with the podium hub and the button pack, and I am able to map buttons. The wheel shows up as the F1 wheel, I just matched button to button with the function I want. Example; X on F1 wheel, choose function, and X on the wheel I use operates that function. same with the RSR wheel that I have except I reference the csl wheel
 
Back