GT Sport Undocumented Changes Thread (Update 1.50)

  • Thread starter RACECAR
  • 42 comments
  • 9,850 views
365
Fragglecommader
There was a bug in which the hud would change tyres if you paused the game to whatever tyres you started session on.

For example you start on meds, pit for hards, leave pits press pause and hud would change back to meds although you were still actually on hards.

There was no advantage to be gained but in FIA races where a certain tyre compound was required it could fool the game into thinking you hadn't used it.

Anyways this has been fixed
 
15
Australia
Australia
Fethmus_Mioma
I've noticed that driving cars with a DCT shift a bit quicker (it's noticeably surprising!). For instance, I decided to take the Porsche 911 GT3 RS on the Nurburgring, and the upshifts are quicker when changing up gears, like there is no noticeable delay followed by the paddles clicking. They're not harmoniously connected but more rather simultaneously connected. Even when you shift really quickly up gears whilst flooring or lugging the engine, the gears follow each other that tad quicker. I also tried the Dodge SRT Challenger and it too shifts quicker. Other examples I've tested are the Nissan GTR, Lamborghini Huracan, McLaren 650s and I'm sure other DCT/DSG cars would shift quicker now, as opposed to the single clutch transmissions, for example in the Lamborghini Aventador or Maserati Gran Turismo, which have been previously addressed in the previous update (can't remember which one though). I gotta upload some videos to show you ladies and gents what I'm talking about. Might create a thread for that!

P.s. I also found that the supercharger whine is louder in all views, but more noticeable in the hood cam view!
 
1,692
United States
California, USA
Mistah_MCA
There was a bug in which the hud would change tyres if you paused the game to whatever tyres you started session on.

For example you start on meds, pit for hards, leave pits press pause and hud would change back to meds although you were still actually on hards.

There was no advantage to be gained but in FIA races where a certain tyre compound was required it could fool the game into thinking you hadn't used it.

Anyways this has been fixed
Thank goodness it got fixed! I remember Kie mentioning how someone in one of his races got screwed over because of that. That poor soul was in first and the bug gave him a 20 second penalty.
 
248
India
India
Transmission whine sound is now once again being able to hear in bumper cam, but also in chase cam. Probably a mistake.
 
2,913
England
UK
phil_75
If tyre temp goes down, the tyres on indicator gets a blue surrounding edge. Never noticed, is that new or new gfx? :dopey:

It's always been there but is almost invisible for some reason, i didn't even know until someone said and I looked very closely.
Another weird nonsensical quirk from PD.
 
92
Sweden
Gothenburg
kisuhoudai
Thank goodness it got fixed! I remember Kie mentioning how someone in one of his races got screwed over because of that. That poor soul was in first and the bug gave him a 20 second penalty.

That happened to me last night in nations. But I didn't even go to pause menu once. Came here after the race to see if somebody else had the same experience but seems only the pause thingy happened to others. Anyway, I did 9 laps hard, swapped to medium and won the race I thought. But 20s came in the mail.
 

FoRiZon

(Banned)
8,645
Singapore
Singapore
Seems like people hasn't check their museum lately.

Like a year ago of 2018, this year of 2019 saw some updated general museum section once again.

Gran Turismo®SPORT_20191209035245.jpg

@RACECAR

All 2019 museum items:
Gran Turismo®SPORT_20191209035228.png

Gran Turismo®SPORT_20191209035233.png


Gran Turismo®SPORT_20191209040205.png

Gran Turismo®SPORT_20191209035252.png

Gran Turismo®SPORT_20191209035257.png

Gran Turismo®SPORT_20191209035301.png

Gran Turismo®SPORT_20191209035306.png

Gran Turismo®SPORT_20191209035310.png
 
46
New Zealand
Auckland
spazmos
When you are in the garage, it used to display the name of the livery currently applied to the car on display in the bottom-left corner of the screen. I noticed last night that it's no longer displayed at all. Don't know which update this would have come with, I'm sorry if this is old news. It was definitely there before though so it has changed at some point.