What's wrong with Forza Hub?

I live in China, my Hub before could still load even if the youtube video was blocked. I could get my rewards are dlc cars. But now it's over 2 weeks and the HUB doesn't work at all! It says Forza Hub is UNAVAILABLE. There's also a thread about this in the official forza horizon 2 forum (I don't know if I can paste the link here, just go check it). I followed all the instructions to try to solve the problem: hard shut down, uninstall and re-install, change dns etc... Nothing.

They told me I could still get the rewards from the website https://rewards.forzamotorsport.net/en-US but now here I see that to get some cars you needed the application. I fear for some new FH2 and FM6 content if they don't fix this.

Relax bud 🙂

Forza Hub ain't working in all regions where YouTube doesn't work. I've been getting the exact same message since the FM6 message started popping up. Before that, it used to work without any issues whatsoever.

For now, you'll have to get rewards from the official site. Until FM6 gets released, The Hub isn't working. So relax, and look forward to the FM6 demo. 😁
 

UnshavenYapper

GT Die Hard Fan
Premium
410
Denmark
Denmark
GTP_UnshavenYapp / UnshavenYapper
UnshavenYapper
I cant connect too Forza 5 servers, so no leaderboard and multiplayer for me...maybe the same reason?
 

UnshavenYapper

GT Die Hard Fan
Premium
410
Denmark
Denmark
GTP_UnshavenYapp / UnshavenYapper
UnshavenYapper
Hmm i tend to lose connection to Forza servers all the time when playing in Career, but when im in a lobby i can stay connected for hours without trouble. Is that the way it is in forza?

When i lose connection, i can just restart the game and im connected again, no need to reboot console.
Im on a wire btw.
 

CAMAROBOY69

Premium
18,567
United States
Michigan
CAMAROBOY69
Hmm i tend to lose connection to Forza servers all the time when playing in Career, but when im in a lobby i can stay connected for hours without trouble. Is that the way it is in forza?

When i lose connection, i can just restart the game and im connected again, no need to reboot console.
Im on a wire btw.
I have honestly never ever had any problems with Forza game servers. Maybe there is something with your connection or router? What is your download and upload speed? http://www.speedtest.net/

Their websites on the other hand, have never been very good. But the games work incredibly well.
 

UnshavenYapper

GT Die Hard Fan
Premium
410
Denmark
Denmark
GTP_UnshavenYapp / UnshavenYapper
UnshavenYapper
Leaderboard and driveravater goes away, plus livery for the opponents cars goes away.

Then if i exit/finishes the race and tries to go online to the lobbys or looking at leaderboards i get the message "Cant connect to Forza 5 servers"

Im still connected to xbox live, can use store and chat with friends. Only Forza online features goes.
 
13,309
United States
Los Angeles, CA
lImaRobotl
Leaderboard and driveravater goes away, plus livery for the opponents cars goes away.

Then if i exit/finishes the race and tries to go online to the lobbys or looking at leaderboards i get the message "Cant connect to Forza 5 servers"

Im still connected to xbox live, can use store and chat with friends. Only Forza online features goes.
Hmm, odd. You did say you run a wired connection right? Or are you wireless?

I wonder if it's a incident isolated to your region.
 

UnshavenYapper

GT Die Hard Fan
Premium
410
Denmark
Denmark
GTP_UnshavenYapp / UnshavenYapper
UnshavenYapper
Hmm, odd. You did say you run a wired connection right? Or are you wireless?

I wonder if it's a incident isolated to your region.
Yes the XB1 is wired, the test above is from my laptop running on wifi.
But will the XB1 use the wire by default when plugged in or do i need to config it?
 
13,309
United States
Los Angeles, CA
lImaRobotl
Yes the XB1 is wired, the test above is from my laptop running on wifi.
But will the XB1 use the wire by default when plugged in or do i need to config it?
I'm not exactly sure, really. You might want to go to your network settings and give it a look, and try to set it up as a wired connection just incase.

Is this the only game you have multiplayer connection errors with?
 

UnshavenYapper

GT Die Hard Fan
Premium
410
Denmark
Denmark
GTP_UnshavenYapp / UnshavenYapper
UnshavenYapper
I'm not exactly sure, really. You might want to go to your network settings and give it a look, and try to set it up as a wired connection just incase.

Is this the only game you have multiplayer connection errors with?

I take a look at that, thanks.

I cant really tell, i only have forza and PCARS, only played PCARS a few hours but after some practice i went online with no problems.
 

CAMAROBOY69

Premium
18,567
United States
Michigan
CAMAROBOY69
Leaderboard and driveravater goes away, plus livery for the opponents cars goes away.

Then if i exit/finishes the race and tries to go online to the lobbys or looking at leaderboards i get the message "Cant connect to Forza 5 servers"

Im still connected to xbox live, can use store and chat with friends. Only Forza online features goes.
Your connection above seemed perfectly fine.

I have had the vinyl problem happen before where you cant see friends or other players vinyls. That one is quite common and has been since F4.

Back in the previous Forzas there used to be a loading bar for the vinyls. That loading bar has been hidden in the recent games. I believe if the game loads too fast before all the vinyls load for all the players in the game, you wont see some the other players vinyls. It will default to a stock color car. It also happens if you have your xbox live settings set to "friends only".
 

UnshavenYapper

GT Die Hard Fan
Premium
410
Denmark
Denmark
GTP_UnshavenYapp / UnshavenYapper
UnshavenYapper
Your connection above seemed perfectly fine.

I have had the vinyl problem happen before where you cant see friends or other players vinyls. That one is quite common and has been since F4.

Again, its only in Career. Guess when i lose connection to the servers it cant download livery's from "the cloud"

In lobbys everything is fine, lots of cool designs on cars, no lag, no disconnects..... only happy days 🙂
Thats why i find it strange, but anyways its no biggie. il stop complaining for now. might return if i get the same issue in Forza 6 🙂