B-Spec Grinder 2.5.2: Automate Remote Races

  • Thread starter yonis
  • 4,266 comments
  • 520,289 views
There seems to be some sort of problem hen you manually start a remote race in game an then set it to enter server standby after the race completes. The problem is that it won't add the racers from a person on my always use list on the first race after it enters server standby. After that race completes it seems to be fine but on the first one it won't add the racers from my always use list.

Other than that thanks for making this app, it is awesome.
 
703
Netherlands
The Netherlands
SpeedQber
How can I make sure that my widget only runs La Sarthe? I've read something about changing the preferences, but the debug window is gone in 2.5.2
 
171
RKTSCI-HR
Anyone having issues using the widget today?

My widget will reserve drivers but is unable to actually start the races...the debug report shows this:
Command hasn't gone through. Trying again...

After this it then goes through the process to reserve drivers again and it keeps repeating.

Its been like this for the last 2 hours.
 

frason

Premium
1,092
keptang
keptang
Anyone having issues using the widget today?

My widget will reserve drivers but is unable to actually start the races...the debug report shows this:
Command hasn't gone through. Trying again...

After this it then goes through the process to reserve drivers again and it keeps repeating.

Its been like this for the last 2 hours.

What does the PS3 do? The problem is probably there.
 
298
United States
Gaylord Michiga
I've read that, but where do I put it? The debug window is gone.

When Yahoo widgets is opened, it's icon should appear in the system tray of Internet Explorer-(usually at the bottom of the screen).
Hold shift+control+ right click the icon at the same time.
That should bring up the debug window.
 
703
Netherlands
The Netherlands
SpeedQber
When Yahoo widgets is opened, it's icon should appear in the system tray of Internet Explorer-(usually at the bottom of the screen).
Hold shift+control+ right click the icon at the same time.
That should bring up the debug window.

I'm sorry to bother you again but I have Firefox, any idea how to get to the debug window there?
 
I'm sorry to bother you again but I have Firefox, any idea how to get to the debug window there?

The Yahoo Widget gear icon (looks like a couple of little gears) appears in the system tray in windows and in the tool bar thing on a mac (near where the time/date is displayed). It isn't part of the yahoo widget thing itself.

It isn't anything to do with Internet Explorer or Firefox.
 
538
United States
Pensacola, FL/USA
SoCal_Senator
Devin93
There seems to be some sort of problem hen you manually start a remote race in game an then set it to enter server standby after the race completes. The problem is that it won't add the racers from a person on my always use list on the first race after it enters server standby. After that race completes it seems to be fine but on the first one it won't add the racers from my always use list.

Other than that thanks for making this app, it is awesome.

I've noticed this as well. My first race seems to only have like 10 people in it, then it gives full fields after that.
 
703
Netherlands
The Netherlands
SpeedQber
My debug window looks like this:

http://i56.tinypic.com/2wci8tz.png

2wci8tz.png

Would that do the trick?
I inserted the 'preference line' with the code 24196 (NL - La Sarthe).
 
44
invalid76
My widget only comes up blank:

ran debug and got this:

SyntaxError: syntax error (JSON.js: Line 27)
[JSON.js:27] SyntaxError: syntax error:
[JSON.js:27] ()
[JSON.js:27] .^



are the computers taking rising up?


edit - did a /clear command and now it just says line 28 error instead of all that stuff underneath the first line.
 
Last edited:
The widget seems to be looping:

Starting race (20 seconds)
Race ended (1s)
Loading race events (1s)
Reserving drivers (1s)
...

And no race is started. :-/

My parameters are

Concurrent threads: 1
Driver Reservation Delay: 0 seconds
Race: Events of any length

Am I doing something wrong ?

EDIT: I changed the country to USA, threads to 4 and delay to 20s. And now it works just fine.

Great tools !

I don't use it for money (well, it's still a nice bonus), but just to gain a lot of XP for my main B-Spec driver (he is level 34).

Are there any advices to maximize the XP won ?
 
Last edited:

DaveTheStalker

Vinyl Addict
Premium
6,283
United States
Michigan
DaveTheStalker
I don't think prioritizing friends is working. I know it's not storing the parameter if the widget is opened again.
 

tadlock

Corvette Enthusiast
Premium
815
United States
Houston, TX
tftadlock
nichonifroa
Are there any advices to maximize the XP won ?

Run races at Le Sarthe for max $ & max XP. See page 1 post 3 for how to change the race id in debug mode.
 
Run races at Le Sarthe for max $ & max XP. See page 1 post 3 for how to change the race id in debug mode.

Thanks, I will try that.

Other thing: is that normal that even if I set a user at "always use", it only select 3 of his drivers even if I'm 100% sure that his 6 drivers are free ? And that it start a race with 4 or 5 drivers, even if I'm sure that among my friend's drivers, there is enough for a 16 drivers race ?
 
298
United States
Gaylord Michiga
Thanks, I will try that.

Other thing: is that normal that even if I set a user at "always use", it only select 3 of his drivers even if I'm 100% sure that his 6 drivers are free ? And that it start a race with 4 or 5 drivers, even if I'm sure that among my friend's drivers, there is enough for a 16 drivers race ?

use less threads, and/or increase delay
 
911
United States
Calipornia
GTP_Toymdngn / toymdngn
Killed the DFGT the other day and have been running the new grinder pretty much non stop since then. Still working great with few hiccups!
 
use less threads, and/or increase delay

I already use 25s of delay.

But using less threads only makes things worse: in that case, it's always 4 drivers: mine + 3 of the account set to "always use" that I know all 6 drivers are free. :-/

And if I try to setup a race manually, I have plenty of drivers available from different friend's accounts.

Now I'm back using 4 threads and 25s delay. It starts a race with 12 drivers (even if more are available), with still 3/6 drivers from the "always use" account. I'll let it run like that until I find an improvement or a solution.
 
522
buggs1a
Buggs1a is my psn name. Add me so we can race bobs.

Widget is working but it'd be nice if it'd auto retry forever. Then I can do other things on ps3 and come back to remote without having to manually start all the time.
 
146
ProjectVRD
I just wanna say I am really not happy with this widget, the problem is that I did not create it and thus I will not enter God status.

Yonis, you are a genius! Amazing work!

I have one suggestion but not sure if has been suggested, it would be nice to specify how many opponents showed be selected and have that work in tandem with the Race Driver Delay.

i.e
You can select 8 oppenents, but if only 7 or less available after one minute reserving drivers it will race anyway because it could take 20 minutes for another one to become free.

I am happy with all 15 opponents selected, but thinking that others might have a slow internet connection and so it relieves strain for their home network. :)
 
223
thecla246
This is great but how do I change up the drivers being used? Most of the time the same drivers of my old friends are being used when I went to use some of my new friends drivers. Help?