PS4 Fanatec and PS4 Troubleshooting/Settings

Discussion in 'Project CARS 1' started by Smoothherb, May 7, 2015.

  1. sik180sx

    sik180sx

    Messages:
    374
    Location:
    Australia
    Thankyou so much @Bealdor you WMD guys are amazing as are are the devs and the whole SMS team

    :bowdown::bowdown::bowdown::bowdown::bowdown::bowdown::bowdown::bowdown::bowdown::bowdown:
     
    VBR and Bealdor like this.
  2. Goruk

    Goruk

    Messages:
    929
    Location:
    Portugal
    I think you can turn deadzone to 0 in the FFB calibration menu...
    I did it for the T500....
     
  3. sik180sx

    sik180sx

    Messages:
    374
    Location:
    Australia
    Tried that mate,first thing i do in any race game :tup: Appreciate the suggestion :) but is definitely specific to the fanatec wheels.
     
    Goruk likes this.
  4. WadeOhh

    WadeOhh

    Messages:
    36
    Location:
    Australia
    Another annoying bug...

    With the CSR, when you go into the garage and try to change car livery, you click the directional arrow once, and it jumps by 2 liveries. Example: say you're on livery 1, you click right once, and it jumps to livery 3, with no way to get to livery 2, or 4, or 6 and so on). So there is no way to get to 50% of the liveries.

    Not a game breaker, but still annoying.
     
  5. xDama

    xDama

    Messages:
    7
    I'm having problems with Fanatec-gear as well. The Fanatec Porsche GT3 V2 + Fanatec CSR elite pedals aren't working properly on the PS4-version. As soon as you power on the wheel, the game has HUGE lag. The PS4-controller is completely useless as well, because the game doesn't recognize the controller anymore.

    The game is completely unplayable at this stage, unless I use a controller...
     
    VBR likes this.
  6. fuzzmeisterr

    fuzzmeisterr

    Messages:
    4
    Update the firmware of the wheel... mine did that before I updated
     
  7. sik180sx

    sik180sx

    Messages:
    374
    Location:
    Australia
    What firmware are you on fuzz?i'm on 756 and using a 911 turbo s which i'm sure is internally identical to the gt3 rs v2,i have a massive deadzone,don't get a calibration option,can't map buttons properly but all my pedals work lol i have clubsport v1's.
     
  8. fuzzmeisterr

    fuzzmeisterr

    Messages:
    4
    Im on 756 now too... Just had a bit of a play, haven't really noticed a dead zone yet. Comment above was in reference to it slowing down/Freezing isuue. - did have to turn the damper settings up a bit to get a bit more feel to it.... will keep having a play around and see what I can work out, lack of clutch takes some of the fun out of ithoho....
     
  9. xDama

    xDama

    Messages:
    7
    Ow fuzzmeisterr, you made my day! Fixed the problem! Didn't notice Fanatec released new firmware/drivers.

    Thank you!
     
  10. Smoothherb

    Smoothherb

    Messages:
    432
    Another bug: The sound from your pit crew is not working with the fanatec wheel plugged in. To fix that you have to force the game to recognise the pad. Fastest way seems to go to free practice and then in the bit menu select "pit strategy" create new. This will bring up the keyboard. Now exit and the speakers should work.
     
  11. J-PaP

    J-PaP

    Messages:
    2,573
    Location:
    Australia
    I've got a CSR Elite on Firmware 757. Project cars won't recognise the wheel at all.

    Nevermind....
     
  12. fuzzmeisterr

    fuzzmeisterr

    Messages:
    4
    Stupid question, but are you putting it in pc mode? (Turn it on and then hold the back button for about 3 secs, tuning display Should change from 3 dots)
     
  13. Gabba73

    Gabba73

    Messages:
    69
    Location:
    Italy
    Fanatec porsche 911 GT2: huge dead zone and lack of calibration and FF wheel menu.
    I own both PC and ps4 versione of the game so i know how the wheel should works and reacts in the game and which menu should be in the ps4 version.
    Posted this morning on WMD forum hoping they could resolve
     
    PhaedrusSocrate, sik180sx and VBR like this.
  14. xDama

    xDama

    Messages:
    7
    Yep, I've got the same problem after the firware-update. Huge deadzone and in general a bad feeling on the pedals/wheel.
     
  15. imported_Orbit

    imported_Orbit

    Messages:
    16
    Ugh. Bought CSW v2, CSP, SQ2, 918 RSR and I am utterly pessimistic...
     
    VBR likes this.
  16. pjrblue

    pjrblue

    Messages:
    23
    No problem, I have a PSN friend that has the CSW v2 and the CSS SQ (clubsportshifter SQ), don't know what wheel and pedals, he was playing yesterday on twich, currently offline (Luxman_) without problems.
     
  17. imported_Orbit

    imported_Orbit

    Messages:
    16
    It's submissive hackville not being able to use the menus properly along with all the rest.

    It's Day One, but here's hoping they sort it. I can drive, but not skip H gears nor use sequential. Never buy high-end!
     
    VBR likes this.
  18. pjrblue

    pjrblue

    Messages:
    23
    He was using the sequencial, the game said "Invalid Input" but accepted that. He had some problems but the H and Sequential were both working, if it's the same shift model.
     
  19. PzR Slim

    PzR Slim Premium

    Messages:
    6,706
    Location:
    England
    Worry not. Just seen this posted over at fanatec.com.

     
    Last edited: May 7, 2015
  20. pjrblue

    pjrblue

    Messages:
    23
  21. imported_Orbit

    imported_Orbit

    Messages:
    16
    Good stuff, just try shifting 4th to 2nd. Or switching to sequential. Or navigating menus with L2/R2 (!). That's such a basic oversight.

    Then count the buttons on the 918 RSR wheel. They simply need to enable the use of the DS4 alongside the wheel.

    Early days, but I've dumped an enormous budget into a rig for this game. My fault, all will be good in 24 months I'm sure.
     
    WadeOhh and VBR like this.
  22. pjrblue

    pjrblue

    Messages:
    23
    For the FFB:
     
    PhaedrusSocrate likes this.
  23. imported_Orbit

    imported_Orbit

    Messages:
    16
    Irrelevant. Have not mentioned FFB. Certainly not interested in someone's view of FFB in a build 5 MONTHS ago when we're discussing PS4. Wake up.
     
  24. pjrblue

    pjrblue

    Messages:
    23
    I'm wake, but I'm working and following several forums at same time and mistaken the message. Sorry.
     
  25. Smoothherb

    Smoothherb

    Messages:
    432
    I have updated post 1 with my settings. I you have Better settings please let us know. The OP might sound horrible but once you have set up everything its working very well... with some room for improvements ;)
     
  26. Clark

    Clark Premium

    Messages:
    8,008
    Location:
    England
    Any way to get rid of the massive deadzone yet?
     
  27. Voxalizer

    Voxalizer Premium

    Messages:
    79
    Location:
    Netherlands
    My CSR Elite gets recognized as a standard CSR although it works pretty great ingame, no issues at all. its on firmware 737. My biggest issue is not being able to control the menus with my DS4 controller.

    How on earth did WMD think it would be ok to not have a working DS4 to control the menus while amwheel is connected?! Fix this and ill be very happy.
     
    VBR likes this.
  28. Makaaveli

    Makaaveli

    Messages:
    2
    Hi all, I have the same issue.. big deadzone on my GT2 =( and L2/R2 don't work. I try all is possible and I think we must wait a patch.. =( I'm desperate
     
  29. xDama

    xDama

    Messages:
    7
    Yeah, I forgot to mention the L2/R2 buttons bug. I've got the same problem...

    I've been wondering: would it be possible to use a keyboard with PCARS? It's impossible to map all the functions to a controller or steering wheel.
     
  30. VBR

    VBR Premium

    Messages:
    7,348
    Location:
    England
    Is it possible to go back to an earlier firmware that works better?