The Bugs & Glitches Thread (New OP)

  • Thread starter KiroKai
  • 1,986 comments
  • 239,601 views

Maddens Raiders

Undead
Premium
223
Netherlands
Hoofddorp
Maddens_Raiders
I've twice had the sound disappear from my game entirely while driving online at Mount Panorama, the first time it lasted for two hours then froze my game while taking the left turn before the second checkpoint and turning my wheel all the way to the right. I was driving the 15th Anniversary GT-R GT3. It's a digital copy from the Canadian store courtesy of a good friend, if the version is important.



It is pretty extreme with racing brakes if you haven't tried them yet, at least on lower grade tyres. Not really what I'd call a glitch though.

@mistersafeway - yeah I've had the sound drop out of my '96Nismo GT-R and my Team Phoenix LMS Ultra R8. I've either had to slightly bump a car's bumper in front of me (or get slightly bumped from behind) to have the exhaust note kick in. Sometimes it would inadvertently come back in after hitting gravel or drifting through a corner causing a lot of tire screech. I have the utmost confidence that PD will have this worked out soon as they usually always do. :)
 
1
Brazil
Brazil
whoamilivingfor
What about the completely wrong HUD of the BMW M5 and the exchange of the speedometer and tachometer dials on the ferrari 365 GTB4? Has anyone noticed it? :lol:
 

Maddens Raiders

Undead
Premium
223
Netherlands
Hoofddorp
Maddens_Raiders
Man, currently im really glad I didn't buy GT6 day one, I didn't expect quite this many bugs and issues.

Yeah but GT5 had as many glitches if not more at launch and as many complaining threads (if not more) and it turned out to be great. If anything is noteworthy in RL, turn to the internet to watch it go from noteworthy to, "zomg the sky is falling and there is no one that can stop it or help us...we're all doooooomed....dooomed I say." I'm not a programmer, but I've heard that sometimes there are glitches, bugs, and hiccups in software. Amazingly, I've even read where these things can actually be patched.... I think. 💡
 
1,089
grrlpurple
Career race on Matterhorn just saw me cross the line in 1st place after 3 of 3 laps but the game kept going for a 4th lap after which I came in 10th of 10 cars. I restarted the same race again and it worked fine the second time around.

Very 1st run at Goodwood Festival and my screen was black as the countdown beeps went and I missed my start by around 10 seconds before the game screen displayed, restarted and all was fine.

Also noticed in another thread about body rigidity deterioration after around 300-350 miles of driving, seems to be causing an issue for quite a few people and the costs to restore rigidity are almost prohibitively expensive - surely this classes as an error on PD's part.
 
701
United States
Tennessee
I put a custom transmission in my Challenger SRT8, and the clutch and h-shifter will not work after this is done. I can put the stock auto transmission back in and it works fine, which by the way is crazy. I don't know if it is exclusive to the Challenger or if it does it with all custom transmissions. I did the custom transmission, so that I could adjust the ratios as close as the game will allow to a stock 6-speed Challenger, like my personal car, but it sucks not being able to properly shift it.
 
382
England
Mushroom Valley
Dean200271
If you change the settings sheet from A to B or C to A (any combination really) on any Car or Kart that has a custom race number (i.e. base model etc.) then the number resets back to blank and you have to put your number in again. A bit of a pain if you did this at the beginning of a race and wanted to take an in-race photo.
 
65
United States
Florida
Doober50569 - SkylineR34Nissan
there is a bug where if you are completely stopped online the car still moves. Like if you still have the E brake enabled you are slowly drifting off course very slowly.
 
777
Canada
Toronto
boitcon
If you change the settings sheet from A to B or C to A (any combination really) on any Car or Kart that has a custom race number (i.e. base model etc.) then the number resets back to blank and you have to put your number in again. A bit of a pain if you did this at the beginning of a race and wanted to take an in-race photo.
Or maybe it can have multiple numbers depending on which setting sheet you pick. That would be an awesome glitch (I'm thinking GT maybe treats every setting sheet as a different car, thus, different number)
 
1,582
Gambleboyen
New stockyard glitch. As we know cars put in the stockyard may disappear randomly or after online race. Now I have an instance of all but one car disappearing. This one car is impossible to sell, and if I try to move it to the garage the stockyard "crashes" and I skip straight to the main menu.
 
1
United Kingdom
United Kingdom
CurtisRS
Not sure if this has been mentioned or not, but on the Willow Springs circuit on multiplayer, I created a lobby and put the time to about 10:00am and the weather at 0% with 1 change on both. I went on the track and it started fairly dark and when I went out of the pits, I couldn't even see the edge of the track! I went to change the time to about 5:00pm, and it went dark, but, when I changed the weather to 100% with 0% change, it stayed on 0% rain forever. Never changed a bit. It's too bright to even race and they need to fix it. I'm not sure whether the tracks inacceptable to changes in weather, but they shouldn't allow those tracks to change it when it does nothing. Also, when I changed the weather, the time reverted back to 10:00 every time I went out of the menu. - Latest Version.
 
14
Finland
Kempele
I've played through the NB races just so far that I unlocked the NA licences, so only the 400PP Clubman Cup and 1 or 2 of the City Trials.

When I got the licences completed and returned to main menu, I got the "Careerist:National B" trophy.

A bit early trigger for that one?
 

todd8137

(Banned)
56
United Kingdom
Earth
todd8137-1LI
Hi another annoying glitch or problem ,international A licence,world circuit tour,ascaris track racing round get in to first on 2nd lap every thing is fine go over the start finish on 3rd lap boom I am 16th ,restarted the race again this time 2nd lap in 3rd position go over start finish to do the 3rd lap,puts me back to 12th position , I did some other races on this track it did the exact same only on this track any one else have this problem? .i did not come of the track or hit any other cars or any thing bit of a glitch me thinks
Pat
 

JEMcG

(Banned)
639
Scotland
Glasgow
The wheel size of the McLaren F1 Euno Clinic model goes funny on replays. Kind of wobbles and goes bigger and smaller.

And I can't be specific but there is a lot of pop up on a lot of tracks, don't know if that counts as a bug.

Also trophies that I won on on other PS3's aren't showing on my PS3. Same sign in ID btw.
 
470
Tahiti
Paradise
Ship_Monster
I have seen that before
there is a bug where if you are completely stopped online the car still moves. Like if you still have the E brake enabled you are slowly drifting off course very slowly.
Interesting because online if you take the shifter karts and do ANYTHING other than keep the tires on the tarmac your steering looses input and takes a few seconds to reset. Drop a wheel too far and it's a penalty of flying across the track into a wall were you sit to think about what you've done wrong :lol:

EDIT: somewhere I have a replay of my bud going into turn one at grand valley and this happening. It's comical because it looks as though he's sitting in the corner pouting.
 
65
United States
Florida
Doober50569 - SkylineR34Nissan
So I bought I bought a 500k card (don't judge) I spent all but 10k and tried to go to the gt store to re-download the anv cars and I was able to download my 500k card again.. so free money lol.

So you are keep re downloading the money that that you paid for? So the 7 million buy out pointless