XLink proper setup tutorial. (GT4 Online Mode)

Discussion in 'Gran Turismo 4' started by MortICi, Feb 23, 2005.

  1. MortICi

    MortICi

    Messages:
    68
    Just to let you know for this past day there has been chaos in the XLink arena over how to get GT4 online working. Thanks to efforts of 3 (acidburn1942, PoolShark, 2fast2furious) people they have finally discovered how to connect and actually play. For best performance pings <50 are recommended (So look for poeple in close areas) and 2 player is the best of all cause it produces the least lag, 3 player is doable but laggy beyond belife. So that being said have fun. Here are the proper set ups. This is according to my setup for which i have been playing with a few buddies for the past 3 hours.

    FIRST:

    Make sure that your XLink setup is correct and that you are reachable and all the ports and configs are correct im not going to explain how to do this read the faqs on the web page they tell you the details.

    SECOND:

    Setup your Lan settings accordingly. Click Host and select yes. Then choose Player #'s choose 1 then choose Monitor # and Select 1 then Change Network traffic to Light. Now if you are gonna host then leave it just like that if your going to join then select host and change to no. (The changes you made will stay but will be gray)

    THIRD:

    Go to course registration and select all of them (they'll be orange once selected)

    FOURTH:

    Save the settings in your PS2 and reset both your ps2 and your xlink.

    FIFTH:

    Once both are booted up DO NOT i repeat DO NOT go into the lan screen yet.

    First if you are hosting go to the GT4 arena create a private arena with a pw or not whatever and wait for someont to join the arena.

    Once both of you are there (assumeing you created the arena so your gonna be hosting) and are correctly setup, the Joinee should proceed to the lan screen and connect, wait till the waiting for connection screen shows up. (Both of you should have the same config in the lan options except one will have host yes and one will have host no.)

    Once the Joinee sees the screen he should notify the host. which then the host will Connect (THIS HAS TO BE DONE IN THIS ORDER, and make sure your lan settings are set to host) once the HOST is in the waiting for connection screen it should take less than a minute for them to esablish a connection if its longer than a minute somone messed up and you have to restart the ps2's and xlink and start the process all over (the connection process not the settings) It has to be in that order it won't work otherwise.

    If all goes well you should see a wonderfull course select screen so enjoy the ring :)

    -MortICi-

    P.S. Sorry if grammer is wrong but i just spent the past hour racing on the Ring it's amazing how 6 laps can wear you out even if it's a game.

    If you have any questions drop me a pm or stop in the Arena.

    Thanks for the notice fixed that. :)

    --------------------------------------------------------------------------------------------------------
    THIS HAS TO BE DONE IN A TIMELY MANNER IN THE SAME ARENA IN THAT EXACT ORDER!
    --------------------------------------------------------------------------------------------------------


    ####################################################
    ####################################################
    VERY IMPORTANT!!!!! IF YOU DISCONNECT FROM THE GAME OR THE CONNECTION FAILS YOU MUST RESTART YOUR PS2 AND KAI BEFORE ATTEMPTING ANOTHER CONNECTION!!!!!!!

    SO IF YOU PLAYED WITH JOHN DOE AND NOW YOU WANT TO PLAY WITH JANE DOE YOU MUST RESTART YOUR PS2 AND KAI AFTER YOU DISCONNECT FROM JOHN DOE IN ORDER TO PLAY WITH JANE DOE, THE SAME GOES FOR HOSTS YOU HAVE TO RESTART BOTH KAI AND THE PS2 AS WELL!!!!!!!!
    ####################################################
    ####################################################
     
  2. NK

    NK

    Messages:
    303
    Location:
    Netherlands
    Nice one!

    Just a tiny point, think you meant to say <50ms for a ping, as opposed to >50ms.

    Cheers.
     
  3. Hajaz

    Hajaz

    Messages:
    206
    thanks for clearing that up man, its been a nightmare last night
    *headache*
     
  4. MeM

    MeM

    Messages:
    389
    Oh man, thanks so much. Im just going to direct people to this thread. ( i shouldnt of made a tutorial without my ps2. I was just eager for people to start playing )
     
  5. flip_kc79

    flip_kc79

    Messages:
    51
    Thanks for making this topic dude.
     
  6. exhaust_note

    exhaust_note

    Messages:
    1,896
    where can we get XLink???
     
  7. MeM

    MeM

    Messages:
    389
  8. MortICi

    MortICi

    Messages:
    68
    Your welcome and ^Bump.
     
  9. IAG

    IAG

    Messages:
    65
    can i play online even though i have a modded ps2 with the duo chip? i installed it for gt4 Japanese, and now i can t play socom online. it says i have a disc infor error and to call sony. now im wondering if that will stop me from playing gt online?
     
  10. MortICi

    MortICi

    Messages:
    68
    Have no idea i don't have a modded ps2.... Sorry...
     
  11. Rism

    Rism

    Messages:
    45
    its kind of worthless considering u cant even load ur own garage in LAN mode. PD are a bunch of lazy ****s
     
  12. SRT-4

    SRT-4

    Messages:
    60
    Wait a second....You can't load your own garage on LAN mode??!?!?!

    WTF...
     
  13. MortICi

    MortICi

    Messages:
    68
    You can't load your own garage, however if you go to arcade mode single play pick a random track and when your selecting a car you just press up on the dpad to add that car to your fav list, which is then loaded when your in lan play. Weird i know but i have yet to figure out how to load the garage into the lan...... still working on that.... So far this is the best solution for more cars during the races.....
     
  14. tazzer

    tazzer

    Messages:
    48


    What a bunch of crapola


    Anyway what hardware do you guys have.

    I know I need to go and get a router or another NIC card but I was just wondering what everyone else has. Also what is a good wireless setup as well.
     
  15. allsops

    allsops

    Messages:
    80
    Thats too bad that you cant load your garage in LAN battles, but since you can at least bring one of your garage cars in then thats good enough for me.
     
  16. the Interceptor

    the Interceptor Premium

    Messages:
    3,988
    Location:
    Germany
    You can? How?
     
  17. allsops

    allsops

    Messages:
    80
    Well, isn't that was Mortici was basically saying?

     
  18. the Interceptor

    the Interceptor Premium

    Messages:
    3,988
    Location:
    Germany
    Nope, he was just describing how to add arcade cars to your favourites list. As far as I know you can't use garage cars in LAN mode at all. That would've been cool, but then again you couldn't do that in GT3 as well, so it's not really a drawback, is it?

    Cheers,
    the Interceptor
     
  19. exhaust_note

    exhaust_note

    Messages:
    1,896
    what exactly do I need to make this work? Im so lost...
     
  20. MortICi

    MortICi

    Messages:
    68
    Xlink Kai

    A PS2

    A network adapter for your PS2

    A CAT 5 cable

    A router

    A Computer

    An internet Connection (Cable or higher)

    GT4

    And some basic networking knowledge.
     
  21. sunnybwoy

    sunnybwoy

    Messages:
    33
    once again, Thanks for all the help and everything man, and great races. Dont worry, ill tame that RUF for the next time we meet again on the Ring, now to do something about getting a wheel, lol.
     
  22. MortICi

    MortICi

    Messages:
    68
    That RUF looked like it was on ice skates there was no turn that it was not puffing up smoke. My poor BMW z4 had to struggle on the up hills :/ but it was still fun :D The s2000 tore it up :D
     
  23. SaintKamus

    SaintKamus

    Messages:
    617
    excuse me? it was a drawback then.. it is a drawback now, same goes for online play, sucked that GT3 didn't have it, sucks that GT4 doesn't have it, specially since there's a network adapter for it now. (back then there wasn't one when GT3 shipped.)

    I won't lose any sleep over garage cars, but it would've been nice and add lots of replay value, you could have "tuning battles" with your friends... evryone on the same budget, pick a car, and tune it with the rest of the cash on the budget, to see who's the better tuner.. oh well, maybe next time. -_-
     
  24. hgplayer1

    hgplayer1

    Messages:
    25
    woohoo I got it to work. hosted a game and got about 5 straight races in before it started to lag a little. had to try a couple different things but heres where all my setting ended up.

    I have a cable modem and a Linksys router

    DHCP is enabled on router

    in GT4 Options under lan settings I had host set to yes, No of players set to 1, No of monitors set to 1, and network traffic light. everything else is default.

    in Options under Network settings auto connection is set to no. i think that was default but I might have changed it trying to get it to work so just to make sure, its at no.

    when I went into multi lan race i created a new network configuration and used these settings

    hardware settings
    hardware SCE/Ethernet (network adapter)
    Phy Config auto detect

    network configuration
    Name LAN
    Authentication No
    Use DHCP YES
    Use Auto DNS YES

    I didnt forward any ports on my router or tell it to ignore the PS2 MAC address and it worked fine.
     
  25. Gravity

    Gravity

    Messages:
    38
    I just got done racing MortICi on the 'Ring... what a race... WRX STi Spec C vs. M3... it was back and forth, MortICi got me at the end by .146 or something. Freakin sweet.

    I noticed a tiny bit of lag... but not jumpy lag like we see on XBox.. more like a reduced frame rate. Either way fun as hell!
     
  26. the Interceptor

    the Interceptor Premium

    Messages:
    3,988
    Location:
    Germany
    Agreed, what I meant was that it's not worse now than it was in GT3, as it was the same there.
     
  27. IAG

    IAG

    Messages:
    65
    My ps2 is successfully configured, i am reachable and i have all lan settings correct. BUT every time i try to host i get stuck on the screen "network initialization-connecting" i followed the steps and still nothing. The only time i can get to the next screen which is...waiting for connection(with the lan pic) is when i dont have Kai running. i even created a new network config identical to playa's. perhaps it has something to do with dchp? how do i put the dchp to the router? i have windows xp and everything is hardwired. ps2 to router pc to router and router to modem. please help :guilty: :guilty:
    k i got past the connecting, but now stuck on waiting for connection
     
  28. MortICi

    MortICi

    Messages:
    68
    That was one hell of a race i must admit, next time get a cap card going so we can show the people how much fun the ring can be :D
     
  29. SRT-4

    SRT-4

    Messages:
    60
    I got it to work today with my friend but when I tried to have more then 2 It wouldn't work...

    Does 3 ppl work????
     
  30. Savanna

    Savanna

    Messages:
    3
    Ok, this is pissing me off, me and my friend have been trying to connect for a good 2 hours. First hour would let me reach, but not connect, did a new config, everything perfect it says. Now we try to conect, he goes to be host, we just sit in that waiting forever. After about 10 tries, I go host, same thing happens. Are settings are fine Xlink says so I have no clue. When I went to select all the tracks, it would not let me select all the tracks. So all but 6 were in Orange.

    Just to make sure also, the Host should have Player to 1 and Moniter to 1, and the Guest should have 0 or one set for both?