Assetto Corsa PC Mods General DiscussionPC 

  • Thread starter Paiky
  • 131,018 comments
  • 34,036,428 views
Either a bad setup in the ai.ini or bad suspension settings causing this. If fixed that in this patch you can compare the fix with the original: https://www.mediafire.com/file/v0aubajk0j7po5i/Mercedes-Benz_AMG_One_2021_v0.92_%28MNBA%29_better_AI_behavior_by_Rainmaker.7z/file
Thanks for the info. Could be a little of both. I had some success making it better by reducing the GAS_BRAKE_LOOKAHEAD value from 10 to 0 (the other cars I compared it to had this at 0). They still run off the track from time to time, but not every time like before. I'll also compare suspension files to see if I see anything there.

BTW, i've seen the TRAIL_HINT value vary widely between different cars. The ones that seem to work the best have it at 1, others have it really low, like 0.29. Do you know which is better, higher or lower?
 
A few tweaks to an old classic, coming soon...

1697718892497.jpeg
 
Last edited:
1. unpack data with CM and try again (delete data.acd).
2. if it fails, rename extension folder to something else like 1extension so that CM does not read the extension folder

Should work.
no chance with these cars. Tried both ways
 
CSP 0.1.80-preview428 appears to have solved a lot of annoying issues for me.
Daylight headlights seem resolved and it's great to finally have the ghost back, but the biggest improvement is in stability. For quite a while now I've had frequent loading issues, often resulting in a meaningless and misleading 'GPU may have overheated or be overclocked' message, even from a cold boot. Plus, I was getting a lot of random hard crashes out on the track, with a frozen screen and unresponsive task manager, necessitating a risky power-button PC reboot. All of those issues seem to be fixed now.
Fingers crossed..!
 
If you are still working on it, a hangover from the original car is that the tacho needle isn't centred on its pivot, you can see the silver disc at the centre move off-axis as the revs increase.
I think I corrected the tachometer needles, and the speedometer too (it was also crooked, it just moved slowly, and the curvature was almost not noticeable). If it’s not difficult, test it, is it so well centered? Regarding the lod, I’ll do it when I have more time. Thank you.
 
CSP 0.1.80-preview428 appears to have solved a lot of annoying issues for me.
Daylight headlights seem resolved and it's great to finally have the ghost back, but the biggest improvement is in stability. For quite a while now I've had frequent loading issues, often resulting in a meaningless and misleading 'GPU may have overheated or be overclocked' message, even from a cold boot. Plus, I was getting a lot of random hard crashes out on the track, with a frozen screen and unresponsive task manager, necessitating a risky power-button PC reboot. All of those issues seem to be fixed now.
Fingers crossed..!
428 is pretty good except for the blurring of the tree textures. I haven't been able to figure out what new option he added to fix\disable that effect because it looks terrible.
 
I think I corrected the tachometer needles, and the speedometer too (it was also crooked, it just moved slowly, and the curvature was almost not noticeable). If it’s not difficult, test it, is it so well centered? Regarding the lod, I’ll do it when I have more time. Thank you.
Nice one! The tacho is still a tiny fraction off but you'd need to be looking very hard to spot it, whereas it was very obvious before. Makes a big difference - thanks!
 
Thanks for the info. Could be a little of both. I had some success making it better by reducing the GAS_BRAKE_LOOKAHEAD value from 10 to 0 (the other cars I compared it to had this at 0). They still run off the track from time to time, but not every time like before. I'll also compare suspension files to see if I see anything there.

BTW, i've seen the TRAIL_HINT value vary widely between different cars. The ones that seem to work the best have it at 1, others have it really low, like 0.29. Do you know which is better, higher or lower?
I don't have experimented with that TRAIL_HINT value yet.
 
428 is pretty good except for the blurring of the tree textures. I haven't been able to figure out what new option he added to fix\disable that effect because it looks terrible.
There was a weird glassy/holographic effect in VR when some trees overlapped previously, which now seems fixed. Might be related to that.
 
There was a weird glassy/holographic effect in VR when some trees overlapped previously, which now seems fixed. Might be related to that.
That's possible. When I have more time this weekend, i'll dig deeper or just ask for help on discord. For now, i'm just using an older version until I can figure it out.
 
Lp racing Maserati MC20 replica skin Fanatec GT2 European series 2k/4k

Hated doing this skin but also really enjoyed it, its been the most challenging skin i have done to date i have had to take a few liberties with this but i am happy with the overall result. I have had a NIGHTMARE with upscalers with this, the upscaler that i used and have always used up until this point is wanting to charge me so i have only been able to upscale stickers to 4k so i am unable to offer a 6k as it does not upscale to that res well at all so 2k or 4k only. There are many upscalers out there and i have tried most if not all they either want to charge you or put a 4k limit or they ABSOLUTELY RUIN the colour, some of them upscales and they look all good in CM showroom but in game it looks like the laquer has peeled of the paint, in the end i gave up trying to find somewhere that upscales over 4k for free and does not ruin the picture/paintwork.

CM drag and drop to install after you chosen what res you want, avaiallble in the downloads section with a link to the patreon (pay mod) by lp design........and no lp design are not anything to do with lp racing :) i already checked that one :)


edit nearly forgot the 3 people that helped with the stickers i couldn't find you no who you are, thankyou again

enjoy
Screenshot (237).png
 
Last edited:
I dl'd this skin from Race Dept on Sun. 15th, I can't find the car it goes with. (can't find the skin there anymore either) Anyone know what car this is? (EDIT: NOT Audi A4, but Audi RS3) the skin dl was "NLS_#830_SchererSport.rar")

preview.jpgI downloaded a file named TCR.7z (damned if I can find it now) that had an audi RS3 that works with this skin! Touring car folks probably already have the car...
This TCR.7z contained these cars:
Audi-RS3.JPG
Maximeerkat, yes, that's the one!
 
Last edited:
What's the best version of current-day Jerez around ?
They are all really subpar. I think the one on RD is the best, but comparing to the AMS2 version is hugely unflattering.

RaceDepartment Jerez by Alex Meyer

Inaccurate corners and elevation changes, and the AI is deathly slow.

Unfortunately, this is the best one. It's one of the major holes in the AC track library. I just drive AMS2 if I want to do Jerez.
 
X90
They are all really subpar. I think the one on RD is the best, but comparing to the AMS2 version is hugely unflattering.

RaceDepartment Jerez by Alex Meyer

Inaccurate corners and elevation changes, and the AI is deathly slow.

Unfortunately, this is the best one. It's one of the major holes in the AC track library. I just drive AMS2 if I want to do Jerez.
Except of Jerez, I also dont like the versions of Aragon and Portimao. Three tracks I personally really like in real life. And Im pretty sure I have tried all of the versions out there. Would be happy if someone brought them (in todays stadards) to AC.
 
Hi I would like to let you know about a problem I am having with Assetto.
I have a rather efficient PC but I cannot exceed 60 fps in races with 30 AI. I realized that my CPU and GPU are only running at 30%.
Do you know if an adjustment is restricting the machine ?

My config is as follows:
AMD Ryzen 7 3700
Nvidia GTX 3070 TI
32 GB of RAM

Thank you for your comeback
 
Hi guys,

just wanted to know if you are also experiencing an error when using the CSP showroom with the latest version of CSP 1.80 preview 428. I had to downgrade to load the showroom with the option "use CSP showroom" ticked.

Thanx for your feedback.

Daniel
 
Hi I would like to let you know about a problem I am having with Assetto.
I have a rather efficient PC but I cannot exceed 60 fps in races with 30 AI. I realized that my CPU and GPU are only running at 30%.
Do you know if an adjustment is restricting the machine ?

My config is as follows:
AMD Ryzen 7 3700
Nvidia GTX 3070 TI
32 GB of RAM
How are we really supposed to know why your getting 60 FPS? There are a thousand settings. Hundreds of check boxes and sliders. With your hardware you have, you could get 13 FPS or 120 FPS depending on what your settings are. We don't even know what resolution you're using to start with.
 
24H
you know whether there is any chance to create previews for cars with that error?
CSP preview is not working with these cars
View attachment 1296330
Try to rename the folder and remove all capital letters. Same goes for spaces. Both can't be processed when generating new previews with CSP enabled. Just remember to edit both files within the sfx folder accordingly.

EDIT: The solution above works sometimes but not for that precise error message you get. Did you by any chance edit the original data.acd? Did CM automatically create a backup? If so, try to restore it.
 
Last edited:
Since I've been quiet for a while now, I'd like to give a short progress update of my work on the Ultima, Mantis, Vertigo and BMW.
I currently have not much time to work on the Ultima and the updates for the three other cars, as I am writing an exam at the beginning of November and also have another exam at the end of November. Accordingly, I am preparing for the exams in the free time I have available. If there is still a little time left, I still work on the cars in small steps. I'm currently remodeling the side air intakes of the UItima because I didn't like in the last version and it wasn't entirely correct. So be patient a little longer. The work goes on, but slowly. And once again a big thank you to everyone who supports me with the cars, be it bug reports or AI fixes, for example. No matter how and no matter what, I am grateful for any help. :cheers:
good luck with the exams!
Hi I would like to let you know about a problem I am having with Assetto.
I have a rather efficient PC but I cannot exceed 60 fps in races with 30 AI. I realized that my CPU and GPU are only running at 30%.
Do you know if an adjustment is restricting the machine ?

My config is as follows:
AMD Ryzen 7 3700
Nvidia GTX 3070 TI
32 GB of RAM

Thank you for your comeback
Do you achieve higher fps with less AI ? Or is it always 60? If you are running at 30% cpu and gpu I'm guessing there is just a fps limit turned on somewhere (in CM: Assetto Corsa - Video - Limit framerate and in NVidia control panel : Max Frame Rate and Background Application Max Frame Rate). Also check Vertical Sync is off (if you have that on and your monitor is set to output 60Hz it will also cap your fps at 60 if not mistaken).
 
Hi guys,

just wanted to know if you are also experiencing an error when using the CSP showroom with the latest version of CSP 1.80 preview 428. I had to downgrade to load the showroom with the option "use CSP showroom" ticked.

Thanx for your feedback.

Daniel
All good here

1697756438969.png
 
Sharing a mod? Host it on GTPlanet Downloads. Free, public hosting for files up to 10GB in size.
Back