Assetto Corsa PC Mods General DiscussionPC 

  • Thread starter Paiky
  • 132,387 comments
  • 34,672,953 views
It’s not only VR, I can assure you.
3D trees are in 99% of the cases horrible looking on triples too.
I do have a couple of tracks where the modder did a really good job in choosing the right kind of trees, fitting the real environment, using the right shaders, no popping, still looking OK in stronger winds and in wet night conditions, and all that without affecting FPS too much. But it is very rare…

Was driving today my custom 1950 F1 championship, on a track with only 2D trees and what I do like, put away those cardboard trees from the track, but hell in my VR headset, these trees were shimmering like Vegas neon light. :crazy:
In my country we say, it doesn't matter bitten by the dog or the cat, both do hurt you.
Just get what you prefer on you system and take the best from the worst.
 
Last edited:
I see my actual problem is when I export to FBX that particular material is not registering in the FBX file. So KSeditor is randomly assigning it its own material. So I can't see how to assign a material to the object in the config file, only the existing materials. Very annoying.
I think you're better off deleting the whole ini file
 
what I did with my Sunday :
preview.jpg
preview.jpg
preview.jpg
preview.jpg
preview.jpg
preview.jpg
preview.jpg
preview.jpg
preview.jpg


download

cheers all and have a good week!
 
So I recently moved my AC installation to a brand new SSD and lost some of my old settings.
I was able to restore most of them... albeit with one caveat that's actually served to be rather irritating so far.

The rear camera (look behind) placement is suddenly far higher than it used to be.
View attachment 1345536

I use the "BACC - Forza Horizon" Chaser Camera script from RaceDepartment (Overtake) and had been using it prior to the game being moved, and never had this problem before. For context, this is how I have it currently set up when looking in front from third person.

View attachment 1345537

Anyone know how I can fix this? This is present on every vehicle and is not related to the mod shown here.
I apologize to keep bumping this, but I've been desperately trying to figure out why this has been happening, my installation has never properly been the same since moving the game and re-verifying everything.

Been trying to ask around and I haven't been getting any response. Its something that badly sets off my OCD.

Happens to any vehicle, including Kunos cars.

acs_hGduZ5274I.jpg


acs_7KRDwsh2rP.jpg


Despite my best efforts, I just can't seem to find the fix for it.
 
I apologize to keep bumping this, but I've been desperately trying to figure out why this has been happening, my installation has never properly been the same since moving the game and re-verifying everything.

Been trying to ask around and I haven't been getting any response. Its something that badly sets off my OCD.

Happens to any vehicle, including Kunos cars.

View attachment 1349003

View attachment 1349004

Despite my best efforts, I just can't seem to find the fix for it.
Could you describe what the issue is ?
 
I apologize to keep bumping this, but I've been desperately trying to figure out why this has been happening, my installation has never properly been the same since moving the game and re-verifying everything.

Been trying to ask around and I haven't been getting any response. Its something that badly sets off my OCD.

Happens to any vehicle, including Kunos cars.

View attachment 1349003

View attachment 1349004

Despite my best efforts, I just can't seem to find the fix for it.
I've a dumb question, but do you have the drive(s) that your original Assetto install was on? Your ACTools folder, Documents, and the main AC folder in Steam dir?
 
Could you describe what the issue is ?
Since I moved my installation over when I obtained a new SSD, I noticed a few things broke, notably with steering lock causing several cars' tires to completely break and cause bizarre bugs when using CSP for creating previews.

Removing the steering lock fixes it, so I've been using that for now.

The main issue I am currently having is that the camera for looking behind is much higher than it should be, as I tried to show there with the pictures I attached, compared to when looking forward. Despite any of the settings I've tried in the 'Chaser Camera' options, I can't seem to find a fix for it. It did NOT use to be like this for me.

I've a dumb question, but do you have the drive(s) that your original Assetto install was on? Your ACTools folder, Documents, and the main AC folder in Steam dir?
I still have the drive.
The ACTools folder and Documents are still where it was last time, on the C drive.
The game (in the Steam dir) was already installed on the D drive on my previous setup, the new SSD has been assigned to that same letter (the previous SSD now sits as the E drive.)
 
Last edited:
Wasn't the 'cars getting stuck on the grid' thing supposed to be a thing of the past with the latest CSP preview?
I just tried to race the ASR 1992 cars at the 1992 Kyalami, and I was the only car to move at all...
 
Since I moved my installation over when I obtained a new SSD, I noticed a few things broke, notably with steering lock causing several cars' tires to completely break and cause bizarre bugs when using CSP for creating previews.

Removing the steering lock fixes it, so I've been using that for now.

The main issue I am currently having is that the camera for looking behind is much higher than it should be, as I tried to show there with the pictures I attached, compared to when looking forward. Despite any of the settings I've tried in the 'Chaser Camera' options, I can't seem to find a fix for it. It did NOT use to be like this for me.
Ah, didn't think of that since I never use chase cam. But I just checked, it looked OK and I can change it in the chase cam app...
 
Since I moved my installation over when I obtained a new SSD, I noticed a few things broke, notably with steering lock causing several cars' tires to completely break and cause bizarre bugs when using CSP for creating previews.

Removing the steering lock fixes it, so I've been using that for now.

The main issue I am currently having is that the camera for looking behind is much higher than it should be, as I tried to show there with the pictures I attached, compared to when looking forward. Despite any of the settings I've tried in the 'Chaser Camera' options, I can't seem to find a fix for it. It did NOT use to be like this for me.
It's not here, is it?
1713738813562.png
 
New Indycar aeroscreen for RSS Formula Americas 2020 WIP

There's a good progress yet left. I'm also planning to improve the halo mesh. It will have a new UV layout texture so for those who do liveries for this car should know the parts in the aeroscreen of the original chassis texture won't match in the new mesh for obvious reasons (I tried but it's impossible to fit it).

If you plan to do skins for this car, you can PM me to talk about using this.

1713745554041.png

Before anyone ask, I can't do this on VRC car where kyle did the skinpack as I don't have that 3d model to make the mesh fit it.
 
Last edited:
Guys, I have a car that in 1st person cockpit view, there are goggles in front of my face/view. Is there a way to disable that?
 
Another finished and adjusted pack.

The Mirage M6 and GR7 (are adaptations) from other models, joining and modifying the dimensions of the parts.

Improved textures (when possible by MrHunt), and also a great help from the mate "lorelord" who managed to add a "dark texture" on the panel, otherwise it would be completely transparent.

Always remembering, I hope that more experienced modders can develop these Mirages much closer to the real thing, for now let's have fun with these.
The Mirage GR8,
the group's 3d model ( ABSOLUTE MODDING TEAM - GTR2) was partially used.

The Ligier JS2, all 3d models by ( ABSOLUTE MODDING TEAM - GTR2 ), and possible improvements to textures by "MrHunt".
In relation to the previous pack, I made some small adjustments and also slightly changed the dimensions of the 1974/1975 models.

That's it for now, pack 2 ( MIrage, GR8(1977), M9(1978) and M10(1979) ) will come later, after the track tests.For now, let's have fun with these models, even though they're not 100% perfect.Below are some prints of the "skins" present in each model.

LIGIER JS2 Le Mans Pack Final
MIRAGE Le Mans Pack 1

Mirage GR8-Ford - LM 1975 - Ickx/Bell - TvCam

Mirage GR8-Ford - LM 1975 - Ickx - onboard TV
 

Attachments

  • __custom_showroom_1713755218.jpg
    __custom_showroom_1713755218.jpg
    99.9 KB · Views: 11
  • __custom_showroom_1713755262.jpg
    __custom_showroom_1713755262.jpg
    84.7 KB · Views: 9
  • __custom_showroom_1713755312.jpg
    __custom_showroom_1713755312.jpg
    87.8 KB · Views: 8
  • __custom_showroom_1713755352.jpg
    __custom_showroom_1713755352.jpg
    88.3 KB · Views: 10
  • __custom_showroom_1713755424.jpg
    __custom_showroom_1713755424.jpg
    85.3 KB · Views: 10
  • __custom_showroom_1713755502.jpg
    __custom_showroom_1713755502.jpg
    103.5 KB · Views: 10
  • __custom_showroom_1713755532.jpg
    __custom_showroom_1713755532.jpg
    82.8 KB · Views: 11
  • __custom_showroom_1713755617.jpg
    __custom_showroom_1713755617.jpg
    100.8 KB · Views: 10
  • __custom_showroom_1713755994.jpg
    __custom_showroom_1713755994.jpg
    65.4 KB · Views: 9
  • __custom_showroom_1713755962.jpg
    __custom_showroom_1713755962.jpg
    106.7 KB · Views: 12
  • __custom_showroom_1713756060.jpg
    __custom_showroom_1713756060.jpg
    103.8 KB · Views: 13
Last edited:
Guys, I have a car that in 1st person cockpit view, there are goggles in front of my face/view. Is there a way to disable that?
Hi Teddie! Check the driver3d.ini in the cars data-dir. There should be lines like this:

[HIDE_OBJECT_0]
NAME=DRIVER:HELMET

[HIDE_OBJECT_1]
NAME=DRIVER:Driver_Body_SUB0

[HIDE_OBJECT_2]
NAME=DRIVER:GEO_Driver_FACE

But of course without knowing what car your are talking about, I cannot tell you what is missing. Of course you also can move your "head" a little bit forward to avoid seeing the glasses, but that is just a bad workaround.
 
Does anyone know what's up with the version of Long Beach that keep popping up then getting deleted from RD? long_beach_2023 and _2024, I saw people had been praising the surface textures but they're gone again...
long_beach_2023 by @LuisB updated link : https://www.gtplanet.net/forum/downloads/long-beach-2023.6838/

@LuisB tracks
 
Last edited:
I think you're better off deleting the whole ini file
Found my problem. In blender I can't seperate the item from the body model, I need to actually create a new item to replace it instead. When I seperate it its still keeping its association to the main body texture, even though I've assigned a new texture to it. Live and learn!
 
Hi Teddie! Check the driver3d.ini in the cars data-dir. There should be lines like this:

[HIDE_OBJECT_0]
NAME=DRIVER:HELMET

[HIDE_OBJECT_1]
NAME=DRIVER:Driver_Body_SUB0

[HIDE_OBJECT_2]
NAME=DRIVER:GEO_Driver_FACE

But of course without knowing what car your are talking about, I cannot tell you what is missing. Of course you also can move your "head" a little bit forward to avoid seeing the glasses, but that is just a bad workaround.
You sure about that?

adult swim look GIF
 

Attachments

  • Screenshot 2024-04-22 053942.png
    Screenshot 2024-04-22 053942.png
    50.4 KB · Views: 4
  • Screenshot 2024-04-22 053950.png
    Screenshot 2024-04-22 053950.png
    1.4 KB · Views: 3
If anyone's grabbed Sergio Loro's new '60s Pukekohe, you'll want to add the following lines to the ext_config.ini for proper car shadows:

[SHADER_REPLACEMENT_...]
ACTIVE=1
MATERIALS = grilla, paint?, grid_start, road?, sand_fu
BLEND_MODE = ALPHA_TEST
IS_TRANSPARENT = 0
Also, if you generally find his tracks a little low-contrast and washed out (which might be a vintage design choice, who knows) then try adding this to the end of the config to darken the grass and trees slightly. I find it helps.

Code:
 [SHADER_REPLACEMENT_...]
DESCRIPTION=darken trees
ACTIVE = 1
MATERIALS = ?tree?, ?TREE? ;assumes 'tree' naming convention, any non-compliant will need adding manually
MESHES = ?tree?, ?TREE? ;assumes 'tree' naming convention, any non-compliant will need adding manually
PROP_...=ksAmbient, 0.15
PROP_...=ksDiffuse, 0.12

[SHADER_REPLACEMENT_...]
DESCRIPTION=darken grass
ACTIVE = 1
MATERIALS = ?gras?, ?GRAS? ;assumes 'grass' naming convention, any non-compliant will need adding manually
MESHES = ?gras?, ?GRAS? ;assumes 'grass' naming convention, any non-compliant will need adding manually
PROP_...=ksAmbient, 0.25
PROP_...=ksDiffuse, 0.15
 
Last edited:
That's what I was trying to change.
Works well when looking forward, but the camera sits too high when looking back;

View attachment 1349080
UPDATE

Fiddled around with the 'Chaser Camera' some more, seems like the issue was the 'Pitch' option. I zeroed it out and now its giving me results I'm much more satisfied with.
acs_cEhBIyZojE.jpg



Can't recall changing it before, but I suppose something must've changed when moving stuff over.

Thanks for the help regardless!

Now all that's left to solve is why applying a steering lock is causing physics freakouts like this when rendering previews through CSP mode..
preview.jpg
 
Last edited:
Guys, I have a car that in 1st person cockpit view, there are goggles in front of my face/view. Is there a way to disable that?

Hi Teddie! Check the driver3d.ini in the cars data-dir. There should be lines like this:

[HIDE_OBJECT_0]
NAME=DRIVER:HELMET

[HIDE_OBJECT_1]
NAME=DRIVER:Driver_Body_SUB0

[HIDE_OBJECT_2]
NAME=DRIVER:GEO_Driver_FACE

But of course without knowing what car your are talking about, I cannot tell you what is missing. Of course you also can move your "head" a little bit forward to avoid seeing the glasses, but that is just a bad workaround.
in CM Showroom , you can go to car tab and click the checkbox to show driver...
then you can go 1 step back (clicking the arrow left ) and then click on the driver part that is visible, then you get the name of the mesh you need to enter as NAME in the HIDE_OBJECT_ sections (above example).

1713793681609.png


For completeness, in case
- you cannot unpack the data.acd file (encrypted mod) so you can't recreate the data folder and change the driver3d.ini file
OR
- you do not want to unpack / repack the data.acd file because you wanna be able to join online sessions with this car

you can add in a ext_config.ini file something like:

[DRIVER3D_MODEL]
NAME=driver_no_helmet_cuir ;your own choice of driver
POSITION=0.0,0.0,0.0

[DRIVER3D_HIDE_OBJECT_0]
NAME=DRIVER:HELMET ;the object you do not want to see in FPV

[DRIVER3D_HIDE_OBJECT_1]
NAME=DRIVER:GEO_Driver_FACE ;the object you do not want to see in FPV

this will overrule the driver selected by the author , and hide the parts in FPV which you want...
Cosmetic changes like driver etc. do not affect the performance and should be OK to change even for online use.
 
Sharing a mod? Host it on GTPlanet Downloads. Free, public hosting for files up to 10GB in size.
Back