Assetto Corsa PC Mods General DiscussionPC 

  • Thread starter Thom Lee
  • 100,877 comments
  • 20,670,731 views
5,349
Ukraine
Ukraine
Anyone else notice that if you spend a while editing a few mods in CM (even just deleting cars and tracks, or changing previews) then things very soon slow down to a crawl? CM gets extremely unresponsive and takes ages updating its UI.
Signs of a significant memory leak perhaps? Any way to check this?
Restarting CM doesn't even clear it, the whole PC has to be restarted.
(not related to the new CM update, it's been like this for as long as I can remember. Not a PC issue either, it did this on my old PC too)
 
570
Argentina
Argentina
Anyone else notice that if you spend a while editing a few mods in CM (even just deleting cars and tracks, or changing previews) then things very soon slow down to a crawl? CM gets extremely unresponsive and takes ages updating its UI.
Signs of a significant memory leak perhaps? Any way to check this?
Restarting CM doesn't even clear it, the whole PC has to be restarted.
(not related to the new CM update, it's been like this for as long as I can remember. Not a PC issue either, it did this on my old PC too)

I'm a heavy CM editor and it happens to me aswell. Functions like dragging a car/track to, say, the content tab, stop working.
I always blamed it on the size of my skin previews jpg, but I've been reducing them to no visible consequences.
Maybe a windows resources wizard could tell use how to assign more memory to it.
 
1,616
Finland
Helsinki
Anyone else notice that if you spend a while editing a few mods in CM (even just deleting cars and tracks, or changing previews) then things very soon slow down to a crawl? CM gets extremely unresponsive and takes ages updating its UI.
Signs of a significant memory leak perhaps? Any way to check this?
Restarting CM doesn't even clear it, the whole PC has to be restarted.
(not related to the new CM update, it's been like this for as long as I can remember. Not a PC issue either, it did this on my old PC too)

I have never experienced this issue, and I rarely reboot my gamebox (maybe once every few weeks unless AC crashes in a way you cant recover from)

This laptop I am typing this on has not been rebooted since:
C:\Python27amd64>systeminfo | find "System Boot Time"
System Boot Time: 5/13/2020, 9:47:47 AM

my other laptop:
root@nwsecnb1:~# uptime
20:19:59 up 158 days,
 
440
United Kingdom
London
Anyone else notice that if you spend a while editing a few mods in CM (even just deleting cars and tracks, or changing previews) then things very soon slow down to a crawl? CM gets extremely unresponsive and takes ages updating its UI.
Signs of a significant memory leak perhaps? Any way to check this?
Restarting CM doesn't even clear it, the whole PC has to be restarted.
(not related to the new CM update, it's been like this for as long as I can remember. Not a PC issue either, it did this on my old PC too)

I only use my PC for gaming, and haven't downloaded anything on in a while, except the CM update. Not sure if related, but I did a scan with Malwarebytes this morning, and it found about 6 bitcoin mining trojans...
 
1,616
Finland
Helsinki
I guess everyone's mileage varies...
I have not run AV on my systems in 20 years, lol. (but then again... I used to make trojans/rats) and now they will delete large parts of tools I use in my work as an "ethical hacker". I have had a total of 3 infections in those 20 years and was attacked by 0day MSblaster
(before it was unleashed on the planet... read about it here)
 
594
Italy
Italy
I only see changes on track after editing ext_config.ini, not in the CM Showroom :(
Yes, pbr can only be seen in-game, not in showroom since they use two different engines (they are two separate softwares). You can however keep the config file opened with a text editor in the background and edit it while ingame. You can see ant change you make in real time
 
923
France
France
I noticed that I lose engine sounds from other mods when I remove or add new mods :confused::boggled::odd:
Hi ! :)

If you replaced a sound by a sound of a modded car (with CM obviously) and you deleted the car where you got the replaced sound, It’s a "normal" issue.

Cheers ! :cheers:
 
1,681
Portugal
Tatooine - Outer Rim Territories
Anyone else notice that if you spend a while editing a few mods in CM (even just deleting cars and tracks, or changing previews) then things very soon slow down to a crawl? CM gets extremely unresponsive and takes ages updating its UI.
Signs of a significant memory leak perhaps? Any way to check this?
Restarting CM doesn't even clear it, the whole PC has to be restarted.
(not related to the new CM update, it's been like this for as long as I can remember. Not a PC issue either, it did this on my old PC too)


And I thought it was an issue on my side.
I can confirm. After some installations and running some different tracks/cars, CM seems to start losing its normal fluidity work.
It seems all working with some lag.
 
5,899
Canada
Ottawa
Pyano1132
This is completely useless to most people, but something I recommend doing for anyone interested in having a car encyclopedia in Content Manager is to copy and paste car descriptions from the Gran Turismo Wiki. That's something I've been doing recently and they are written much better than the stock Kunos flavour text.

I used to have the old "beyond the apex" library app for GT6 on my old phone back in the day and I would pull it out on the bus all the time and just read pages upon pages of car descriptions. It's pretty nostalgic having those same descriptions on Content Manager now.
 

iks

110
Canada
Canada
I'll post my OCD edited Arctic Circle Raceway later on. I like the layout of this track quite a lot, so I fixed some tree line issues added grassfx, and also added AI lines so I can keep it on my SSD. More later.

whoa many thanks man! Looking forward to it! :bowdown:
 
383
United States
United States


Bruxton - Always looking for Oval tracks. Tried it out today and this track is basically setup only for doing Drifting and not a circuit track. The graphics are a good start for the oval part, but very basic right now - so track still needs allot of work. That is if they even plan to do more with it. Most drifting tracks they do the basic design and then just leave it at that.

Track has both Oval and figure eight possible routing, and a large pit area with a single pass thru gated road entrance..

One thing about most these small oval tracks is the entrance-exit to the track are just one pit road making it hard to have AI work properly if you want them to do pit stops. Right now there are no AI lines, side lines, etc - cause it is a drift track.

But thanks for the link to the track to try. I saw a you tube link to track also.
 
5,349
Ukraine
Ukraine
Riddle me this. Why won't this car centre itself in the preview? I imported it to Blender to look for rogue floaters that would give a false model centre, but if they were there then I couldn't find them.

Bastard.PNG


Any ideas?
Nice little car if you haven't got it, BTW. And by 'nice little car' I mean 'batdung crazy suicide machine'.
http://www.mediafire.com/file/5s7s82j3lj1tabi/file
 
2,430
United Kingdom
United Kingdom
Riddle me this. Why won't this car centre itself in the preview? I imported it to Blender to look for rogue floaters that would give a false model centre, but if they were there then I couldn't find them.

View attachment 952118

Any ideas?
Nice little car if you haven't got it, BTW. And by 'nice little car' I mean 'batdung crazy suicide machine'.
http://www.mediafire.com/file/5s7s82j3lj1tabi/file

Go into the CM showroom settings and click the EYE symbol. Then click Auto-Align Car and see if it does anything
 
5,349
Ukraine
Ukraine
Go into the CM showroom settings and click the EYE symbol. Then click Auto-Align Car and see if it does anything
Nope.. unless I was supposed to save something? I just want to have it centred with my default preview. I fixed one the other day by deleting copies of the headlights that were orbiting the planet, but this one doesn't appear to have the same issue.
 
2,430
United Kingdom
United Kingdom
Nope.. unless I was supposed to save something? I just want to have it centred with my default preview. I fixed one the other day by deleting copies of the headlights that were orbiting the planet, but this one doesn't appear to have the same issue.

Thats odd, normally that resets the car to the center of the screen - I'll check it out on my end and see what happens.
 
Last edited:
573
United States
United States
iks
whoa many thanks man! Looking forward to it! :bowdown:

It will need additional work from our guys here probably, though. I'm just getting it to where I can keep it and not bin it. I'm a little short on time, but hopefully my effort will be continued on our great home here. :)

Riddle me this. Why won't this car centre itself in the preview? I imported it to Blender to look for rogue floaters that would give a false model centre, but if they were there then I couldn't find them.

View attachment 952118

Any ideas?
Nice little car if you haven't got it, BTW. And by 'nice little car' I mean 'batdung crazy suicide machine'.
http://www.mediafire.com/file/5s7s82j3lj1tabi/file

omg, I hate when that happens. I have a couple of cars like this where I needed to specifically make a separate showroom preset to get it in the center. Sorry that doesn't help, but you're not alone. Hope we get an answer, Mascot
 
2,430
United Kingdom
United Kingdom
Nope.. unless I was supposed to save something? I just want to have it centred with my default preview. I fixed one the other day by deleting copies of the headlights that were orbiting the planet, but this one doesn't appear to have the same issue.

Ok, so go to manage car, and click the drop down arrow next to Update Previews and click on options (like you did the other day to get the settings box)
then recenter the car with the mouse, and then click on the eye or the multiple + in a box symbol to the right - this will update all the previews at once for this car

@Teddie taggin you in this as you seem to have the same problem
 
5,349
Ukraine
Ukraine
Ok, so go to manage car, and click the drop down arrow next to Update Previews and click on options (like you did the other day to get the settings box)
then recenter the car with the mouse, and then click on the eye or the multiple + in a box symbol to the right - this will update all the previews at once for this car

@Teddie taggin you in this as you seem to have the same problem
Thanks, but that's treating the symptom, not the cause. I'm more interested in why it happens in the first place and fixing it at source, but I'll bookmark your workaround in case a proper solution can't be found. Cheers dude. :)
 
2,430
United Kingdom
United Kingdom
Thanks, but that's treating the symptom, not the cause. I'm more interested in why it happens in the first place and fixing it at source, but I'll bookmark your workaround in case a proper solution can't be found. Cheers dude. :)

But the cause is the mod author and him not making the previews properly. The only way to fix it is to contact the author and get him to redo his previews or fix it yourself using the method I posted.

Or am I misunderstanding what you want and you want to actually fix the model so it is in the centre?

EDIT: I have just learnt that the model needs fixing if it doesn't centre in the preview so ignore everything I said except maybe the "contacting the author part"
 
Last edited:
229
Italy
Italy
Hey there!
Since i got a a LOT of updates for tracks, and even some complete track reworks in the pipeline,
i decided to start my own patreon for my projects.
When it will go good, and i get enough supporters, i will post all of my work in progress updates there, until they are finished for public release.



JOIN ME:
https://www.patreon.com/mike08

Thank you!
Mike08


Well done Mike :cheers:👍👍👍
 
1,366
Australia
Australia
Bruxton - Always looking for Oval tracks. Tried it out today and this track is basically setup only for doing Drifting and not a circuit track. The graphics are a good start for the oval part, but very basic right now - so track still needs allot of work. That is if they even plan to do more with it. Most drifting tracks they do the basic design and then just leave it at that.

Track has both Oval and figure eight possible routing, and a large pit area with a single pass thru gated road entrance..

One thing about most these small oval tracks is the entrance-exit to the track are just one pit road making it hard to have AI work properly if you want them to do pit stops. Right now there are no AI lines, side lines, etc - cause it is a drift track.

But thanks for the link to the track to try. I saw a you tube link to track also.

Yeah oval hot rods in the UK don't really do pit stops.
The bit in the middle is where you go if your car breaks or you get scared. :lol:
 
5,349
Ukraine
Ukraine
But the cause is the mod author and him not making the previews properly. The only way to fix it is to contact the author and get him to redo his previews or fix it yourself using the method I posted.
Mmm.. is that really how it works? Surely how the modder made the original previews doesn't matter when I try to override his with my own preview from the car model? If he made his preview off centre then it should be centred when I apply my preview, as cars are centred properly in my preview?
Isn't it more likely that CM thinks the model is bigger than it should be (rogue geometry somewhere? Or whatever CM uses to centre the model) so it looks off centre when technically it IS centred?
I don't know. The same problem was solved by correcting the model the other day, but this one LOOKS okay. No rogue floating geometry messing up the centre of the model.
 
2,430
United Kingdom
United Kingdom
Mmm.. is that really how it works? Surely how the modder made the original previews doesn't matter when I try to override his with my own preview from the car model? If he made his preview off centre then it should be centred when I apply my preview, as cars are centred properly in my preview?
Isn't it more likely that CM thinks the model is bigger than it should be (rogue geometry somewhere? Or whatever CM uses to centre the model) so it looks off centre when technically it IS centred?
I don't know. The same problem was solved by correcting the model the other day, but this one LOOKS okay. No rogue floating geometry messing up the centre of the model.

It's cool, I have edited my comment as I didn't realise it's down to how the model is made etc as to if it centres or not in the preview. I really didn't know and just thought it was fixed by re-centering in the preview window
 
1,313
Germany
Germany
Hi Paulo ! :)

I got the update yesterday evening (in France).
I didn't noted something's wrong but with the billions of hardware and software combinations, who knows !?

As usual (!?), the release note isn't inside CM, It stills only previous and useless notes for now.

Cheers ! :cheers:

EDIT
Thanks to @MrB00 for the direct link about the release note ! 👍 ;)

Version : 0.8.2149.36611
  • New setting to change Assetto Corsa language;
  • Controllers management reworked, now relies on instance GUIDs;
  • Support for CSP-only servers (for Custom Shaders Patch v0.1.62 or newer);
  • Support for cars having custom camera trajectories for Custom Showroom;
  • Message showing after successfull link sharing (optional, enabled by default);
  • Rating and notes in context menus for cars and tracks;
  • Skip executable with FTP upload;
  • New items in main menu to download or install from a downloaded archive;
  • New “acmanager://launch” command for simply launching Content Manager;
  • Steam ID changing uses Steam API again;
  • Custom Shaders Patch: share a link to settings in a certain section only;
  • More encrypted KN5s are now supported;
  • Fixed:
    • CM downloading CSP configs even if it’s not active or even installed;
    • Objects toggling getting stuck;
    • Missing items in “entry_list.ini” causing issues with original manager;
    • Scrolling in installation section of the menu;
    • Saving of shared post-processing filters;
    • AC version check for CSP;
    • Servers packing into a single executable;
    • Sorting by name online;
    • Nationality in race grid table got a dropdown list (still editable);
    • Some of crashes;
    • Few UI issues here and there.

Thanks for the changelog. I can confirm the Alfa 75 from Mike Goulioumis now is no longer encrypted in showroom. Will test with some more candidates.