Assetto Corsa PC Mods General DiscussionPC 

  • Thread starter Thom Lee
  • 109,350 comments
  • 23,809,606 views
388
United Kingdom
United Kingdom
Hi Stefan. I experienced an issue just like this over recent days and it turned out to be the 'Dynamic Shadows' module in CSP. I toggled it on an off a couple of times and then hit the reset button at the bottom of the Dynamic Shadows settings page in the CSP Settings and everything was right again after that.
Where is the Dynamic shadows setting in CSP. Many thanks.
 
228
Scotland
Glasgow
Where is the Dynamic shadows setting in CSP. Many thanks.


Lighting FX, at the bottom.

Screenshot (4).png
 
Last edited:
272
United Kingdom
United Kingdom
Hi Stefan. I experienced an issue just like this over recent days and it turned out to be the 'Dynamic Shadows' module in CSP. I toggled it on an off a couple of times and then hit the reset button at the bottom of the Dynamic Shadows settings page in the CSP Settings and everything was right again after that.
Cheers mate I’ll definitely give this a look! Fingers crossed it sorts it out
 
Last edited:
42
Italy
Italy
Are there alternative Lienz track layouts? Are they difficult to create?
My heart belongs to Lienz Altstadt, when I was young I used to play rFactor and I always competed there.
 
151
Germany
Franconia
I've recorded a new pit_lane.ai for Sergio Loro's historic version of Watkins Glen "watkins_f3ct" to prevent the AI cars from crashing into the hay bales at the pit exit. Just remove .txt from the file and copy it to the "ai" folders of the track.
 

Attachments

  • pit_lane.ai.txt
    40.1 KB · Views: 89
Last edited:
3,977
Canada
Ottawa
The latest @ArchKyuubeey physic for the M3 E30, taking advantage of all the latest physic tricks from CSP, with this new Colombian track road mesh, is truly remarkable and such a nice demonstration of the strength and realism achievable in AC today.

https://www.racedepartment.com/downloads/autódromo-de-tocancipá.41397/
https://www.racedepartment.com/downloads/data-replacement-bmw-m3-e30-improved-physics-by-arch.27533/

It will give your nicely set up rig a refreshing feeling of authenticity and immersion.
AC will never cease to amaze me.



8619471880BA4D4057B420CBBFDA62756F2F4FD8


@SimRacing604 I hope you will have a chance to try it, might be worth sharing.
 
Last edited:
256
Canada
Canada
I've recorded a new pit_lane.ai for Sergio Loro's historic version of Watkins Glen "watkins_f3ct" to prevent the AI cars from crashing into the hay bales at the pit exit. Just remove .txt from the file and copy it to the "ai" folders of the track.

Sadly, the cars I'm using are still crashing into the hay bales... 917/512 and Legion's Can Am cars. It's "oh soooo close" and a significant improvement over the original, but still "no cigar" for me. Thanks anyway!
 
151
Germany
Franconia
Sadly, the cars I'm using are still crashing into the hay bales... 917/512 and Legion's Can Am cars. It's "oh soooo close" and a significant improvement over the original, but still "no cigar" for me. Thanks anyway!

I've tested it with the 1967 GPL cars like the Lotus 49 and the Ferrari 312 and it works without a problem for me.

EDit: I've tested it with several other cars now and the distance to the hay bales was always more than big enough. Did you copy the file to the correct "ai" folders "watkins_f3ct/watkins_gp/ai" and "watkins_f3ct/watkins_sc/ai" ?
 
Last edited:
256
Canada
Canada
I've tested it with the 1967 GPL cars like the Lotus 49 and the Ferrari 312 and it works without a problem for me.

EDit: I've tested it with several other cars now and the distance to the hay bales was always more than big enough. Did you copy the file to the correct "ai" folders "watkins_f3ct/watkins_gp/ai" and "watkins_f3ct/watkins_sc/ai" ?


Yes, I did. If it's working on your end, the problem must be mine - so thanks for having a look at it.
 
151
Germany
Franconia
Yes, I did. If it's working on your end, the problem must be mine - so thanks for having a look at it.

I have one last idea. Maybe the CSP option "NEW AI BEHAVIOR" causes the problem. Try to deactivate "Cache generated grids" and "Cache generated payloads" under "Extra options for AI splines" and delete all files in the "ai" folders except of "fast_lane.ai" and "pit_lane.ai".
 
367
United States
United States
Yes, it is sort of the 'definitive' Terra21 version. It is the same base track with the NAGP update for improved track surface and many other improvements by Zwiss.

Got a link to the zwiss version? I have the terrain one but am always looking to upgrade.

Nevermind: I am an idiot and have now found it.
 
Last edited:
1,082
Western Sahara
Arrakis
Hi Stefan. I experienced an issue just like this over recent days and it turned out to be the 'Dynamic Shadows' module in CSP. I toggled it on an off a couple of times and then hit the reset button at the bottom of the Dynamic Shadows settings page in the CSP Settings and everything was right again after that.

Cheers mate I’ll definitely give this a look! Fingers crossed it sorts it out

@Stefan Clift (... and anyone else who took note of my original reply.)
Hi again Stefan. In my first reply, I mistakenly wrote 'Dynamic Shadows', but what I actually meant to write was 'Smart Shadows', which has a CSP settings module all of its own. Try toggling/resetting that one and hopefully you'll get a positive result like I did.

Is Mid-Ohio by Zwiss better than the Terra21 version?

Yes.
 
Last edited:
256
Canada
Canada
I have one last idea. Maybe the CSP option "NEW AI BEHAVIOR" causes the problem. Try to deactivate "Cache generated grids" and "Cache generated payloads" under "Extra options for AI splines" and delete all files in the "ai" folders except of "fast_lane.ai" and "pit_lane.ai".
You're a genius! Turning those off fixed it - the AI is actually making it out onto the track. Now the only bad driving is mine... :(
Thanks for your excellent help!
 
679
Canada
Canada
evilgloomy
Happy easter guys!

Put my hands on it a bit. Still far from perfection, but a quite big step. To much to write a changelog anyway ;-)
Motec and Ext-config based on 991.2 GT3-R by crash.

Known bugs are:
-Cockpit is wrong
-Holes in cockpit mesh
-Physics are still from 2016 car.


View attachment 1002505 View attachment 1002506

https://www.mediafire.com/file/ym9o973vgd4mwd6/porsche_911_gt3_cup_2021.zip/file

Stay safe!

It seems the 991.2 GT3R physics would be a good fit for the 992 Cup as the suspension layout is double wishbone like the GT3R and not Structs like the 991 Cup.
 
202
Germany
Germany
Anyone with a working "camera_facing.ini" for acu_hungaroring by any chance? Neither a search inhere nor GIYBF was helpful, but maybe someone has somenthing laying around. :cheers:

The tracks looks a lill bit empty without spectators. :rolleyes:
 
Last edited:
3
Hungary
Hungary
I don't know this track well but noticed that there are several layouts for this track. It would be a pleasure to make a camtool set. Which one are you interested?

It would be fantastic, thank you for your feedback.

I think the best version is GP Version clockvise (folder "a") which I believe is also in the linked video.
 
4,791
Belgium
Belgium
There isn't an alternative to Kyalami is it ? That track just destroys my FPS everytime - 49 max and as low as 35 when I'm near the pit buildings.
Alone on track ?
My system is not the most beefy (and running triple screens isn't helping either) but in practice mode I get 103.1 FPS AVG and a 69 MIN. So there is a definite FPS drop near the pits but - at least on my side - nothing really worrying. I can see it in the FPS numbers but it's not translating in stutter or visible lag.