Assetto Corsa PC Mods General DiscussionPC 

  • Thread starter Thom Lee
  • 87,361 comments
  • 16,460,839 views
4,934
Iceland
Iceland
I was deleting a bunch of old photos and noticed quite a difference with Sol. I always tend to use the 'Windy' weather preset as it used to create a nice mix of blue sky peppered with white clouds and really dark stormy rain clouds, the type of sky that'd be making you nervous if you were out on a long walk without a brolly. These days though, all the dark moody rainclouds seem to have been removed from the preset and it's mainly just slightly greyer clouds in the mix. Is there any way to increase the contrast of the clouds to bring back this threat of rain?
Here's what it used to look like. There no longer seems to be a preset that looks anything like this any more:

Screenshot_legion_shelby_daytona_289_sx_lemans_5-11-119-11-26-54.jpg
 
Last edited:
20
Italy
Italy
guys, soon I'll have a car meeting on ac, but every mod I see seems too mainstream for me, so I gotta ask, does anyone have some crazy bodykitted cars/sleepers in their collection to share with me?

Shutoko discord has crazy bodykitted and heavily tuned japanese cars with pretty good physics, in case you're not aware of them already.
 
2,337
United Kingdom
United Kingdom
I was deleting a bunch of old photos and noticed quite a difference with Sol. I always tend to use the 'Windy' weather preset as it used to create a nice mix of blue sky peppered with white clouds and really dark stormy rain clouds, the type of sky that'd be making you nervous if you were out on a long walk without a brolly. These days though, all the dark moody rainclouds seem to have been removed from the preset and it's mainly just slightly greyer clouds in the mix. Is there any way to increase the contrast of the clouds to bring back this threat of rain?
Here's what it used to look like. There no longer seems to be a preset that looks anything like this any more:

View attachment 997944

What CSP version you on? Apparently there is a problem with cloud shadows in 0.1.73 and Peter Boese recommends using 0.1.72 for now. He did also say that a lot of the current issues will be fixed in the public 0.1.74 release (and not the previews for now). I'm just hoping he fixes the shadow bias problem.
 
Last edited:
4,196
Belgium
Belgium
I was deleting a bunch of old photos and noticed quite a difference with Sol. I always tend to use the 'Windy' weather preset as it used to create a nice mix of blue sky peppered with white clouds and really dark stormy rain clouds, the type of sky that'd be making you nervous if you were out on a long walk without a brolly. These days though, all the dark moody rainclouds seem to have been removed from the preset and it's mainly just slightly greyer clouds in the mix. Is there any way to increase the contrast of the clouds to bring back this threat of rain?
Here's what it used to look like. There no longer seems to be a preset that looks anything like this any more:

View attachment 997944
Well, I mostly use Broken Clouds, but here's Windy on my system (3D clouds - CSP 0.1.74):

windy.png


It does indeed not look as if you would need an umbrella...:)
 
Last edited:
4,934
Iceland
Iceland
What CSP version you on? Apparently there is a problem with cloud shadows in 0.1.73 and Peter Boese recommends using 0.1.72 for now. He did also say that a lot of the current issues will be fixed in the public 0.1.74 release (and not the previews for now). I'm just hoping he fixes the shadow bias problem.
I'm on CSP 0.1.74 p22, so hopefully it's just a temporary glitch, although 'cloud shadows' seems to suggest the shadows they cast on the ground, not how they actually look. Maybe not - time will tell..! Cheers.

Well, I mostly use Broken Clouds, but here's Windy on my system (3D clouds - CSP 0.1.74 p22):

View attachment 997961

It does indeed not look as if you would need an umbrella...:)
Mine look a lot more washed-out than that, but I can't seem to find a setting to increase the contrast of the clouds to darken the rainy bits.
I guess it could be any one of a gazillion settings at fault, although I did try resetting Sol as well.
Too many options!
 
Last edited:
2,337
United Kingdom
United Kingdom
I'm on CSP 0.1.74 p22, so hopefully it's just a temporary glitch. Cheers.


Mine look a lot more washed-out than that, but I can't seem to find a setting to increase the contrast of the clouds to darken the rainy bits.
I guess it could be any one of a gazillion settings at fault, although I did try resetting Sol as well.
Too many options!
I was browsing the SOL discord cause for the life of me I can't seem to get a decent blue sky and whatever I set the sky to in sol_config makes no difference to colour. I read about the clouds issue too. I'm also not that happy with how they look and can't figure out how to make them look less pants.
 
33
Belgium
Belgium
They pit after a few laps, was a race at Spa. It think some after around 9-10 laps.
Did you do a weekend with practice? I read somewhere the ai calculate how much fuel they use during practice, no idea whether that's true, maybe they pit standard without that calculation
 
4,934
Iceland
Iceland
Vairano Circuit v009 http://www.mediafire.com/file/gmgazy4821yq9jm/vairano009.7z
original by thestrobe8 https://www.drivingitalia.net/index.php?/forums/topic/67240-vairano-by-thestrobe8-v008/
nobody added phys. walls, pitboxes, now 27, adj. hotlap pos, changed shader settings, movable distance markers, flags
working start+tracklights, ai line by gladbecker82, track map, simple camera set, fixed crowd and trees, one skin that replaces the billboards with ac logo
View attachment 837591
Any lawn/water experts fancy doing GrassFX and RainFX for Vairano? It's a great little track.
I'll work on a billboard skin and maybe add some airborne stuff.
Deal?
 
1,078
Germany
Germany
Any lawn/water experts fancy doing GrassFX and RainFX for Vairano? It's a great little track.
I'll work on a billboard skin and maybe add some airborne stuff.
Deal?

Here, as a start, use this ext_config.ini, rainfx and grassfx included. Trees should be overhauled (*cough* @slider666) and I have the spectators removed.

EDIT: config updated!
 

Attachments

  • ext_config.ini.txt
    2.7 KB · Views: 37
Last edited:
4
Scotland
Scotland
Why does the AI still pit altough I set fuel use to 0?
And any idea how to avoid that?

I have sent you a PM. Try it, it sometimes works with the AI.
...used to drive me NUTS before I worked it out!

out of curiosity- what types of cars are you racing and what laps are AI pitting (on your SPA race) with your current setup?

Basically - assuming you have CM, dev mode unlocked, damage is off (?)and you know how to edit data files...
I am hoping your track data file has no ideal_line.ai file?

Copy the fast_lane.ai file in the track AI folder.
Rename it to ideal_line.ai
Paste/copy this into the track data folder


Hopefully AI no longer pit. If the race was a (kunos) SPA 10 lap, my Ai do not pit on my version with this setup for example.....

You will need to do this with all tracks you want to race the AI on without pits.
Changing the fuel usage to 0 will NOT work
Setting tyre usage/wear to 0 will NOT stop them pitting.
Making the fuel tank bigger and adding more fuel will NOT work either.

This is the only solution that USUALLY works for me. If damage is on, turn it off to try for now...
Let me know how you get on.
If they STILL pit, may be some car.ini specific file or other...
If you need more help, PM me.

SOULFIRER (Kev)
:yuck:
 
338
Germany
Germany
So I tested v1.31, and still find the lights too dim, maybe was a design choice? or maybe a problem on my end? But I find the ligths in v1.0 much better in my opinion...
View attachment 997755 View attachment 997756 View attachment 997757 View attachment 997758
i think its clear it should not be as dim as in your screenshots.

Do you by any chance have this enabled for "sol_weather" app?
"Load & Save this per track" ?
upload_2021-3-15_20-17-35.png


then please update the app from this.
sol_weather app v11.0 ...

EDIT: link removed, that was a broken app version, please ignore this post!
 
Last edited:
1,194
Australia
Australia
I have very distorted mirrors in some cars.

1. I use real mirrors in CSP
2. in most cars its fine
3. in some cars i get :
a. vertical "squishing" which might be intentional with car having a curved mirror?
b. horizontal displacements

In this clip the RSS Formula Hybrid 2019, has both, cars in mirrors are vertically challenged, and if you open full screen and keep an eye on the mirrors you will also see the tyres flare to the left at the bottom bit of the mirrors.

This car is the most obvious but it seems to affect a few cars I drive. Any clues? probably need triple screen guys to fullscreen this, was not sure how else to capture the mirrors


edit. doh.. i can capture stills from the clip..


upload_2021-3-16_7-1-40.png
 
Last edited:
4,934
Iceland
Iceland
I have very distorted mirrors in some cars.

1. I use real mirrors in CSP
2. in most cars its fine
3. in some cars i get :
a. vertical "squishing" which might be intentional with car having a curved mirror?
b. horizontal displacements

In this clip the RSS Formula Hybrid 2019, has both, cars in mirrors are vertically challenged, and if you open full screen and keep an eye on the mirrors you will also see the tyres flare to the left at the bottom bit of the mirrors.

This car is the most obvious but it seems to affect a few cars I drive. Any clues? probably need triple screen guys to fullscreen this, was not sure how else to capture the mirrors

Download BLM Car from RD, you can change mirror angle, position, aspect ratio, FOV, flip etc. on a per-car basis.
Can't understand how you've managed without it thus far TBH, it's pretty much essential.

https://www.racedepartment.com/threads/blm-car.159934/
 
Last edited:
1,194
Australia
Australia
Download BLM Car from RD, you can change mirror angle, position, aspect ratio, FOV, flip etc. on a per-car basis.
Can't understand how you've managed without it thus far TBH, it's pretty much essential.

https://www.racedepartment.com/threads/blm-car.159934/

see edit in post second image, i have BLM, but does not fix that "shifted" glitch

EDIT: Confirm that if i use regular mirros the glitch goes away, normal, no banding. Ill jsut disable realmirrors for now, lesser evil. fwiw the "banding" happens in a few cars, I think might be related to facets in the mirror geometry on some cars perhaps? No idea.
 
Last edited:

iks

109
Canada
Canada
Is there any decent version of Milwaukee Mile for AC? I know of the RTB-built Rex Mays 150 version but it is subpar and not at all historically accurate (not sure why they named it Rex Mays 150?).

If not, I could get started on an rF conversion, which would end up being much better.
 
4,934
Iceland
Iceland
Here, as a start, use this ext_config.ini, rainfx and grassfx included. Trees should be overhauled (*cough* @slider666) and I have the spectators removed.

EDIT: config updated!
Nice job - the flag shader works well too, they look great all flapping in the wind.
I can't seem to extract textures to do a billboard skin and edit the trees etc due to the weird naming convention used. Every texture is named in the same format "Texure.XXX" with the 'XXX' being a unique number identifier, but as it's after a full stop CM thinks they are all unique file types.
Very odd, never seen this before on any other track.
 
651
Fiji
Fiji
Nice job - the flag shader works well too, they look great all flapping in the wind.
I can't seem to extract textures to do a billboard skin and edit the trees etc due to the weird naming convention used. Every texture is named in the same format "Texure.XXX" with the 'XXX' being a unique number identifier, but as it's after a full stop CM thinks they are all unique file types.
Very odd, never seen this before on any other track.
Malaysia had that too. I'm on it, but can't fix it today. Hope I can fix it tomorrow.
Some screenshots from that trees over pm would be nice. :)
 
1,068
From Fecebook. Apparently needs work. Request from post to finish it.

Wuoold Wiee
tSp1oSfnsuorhed ·

Hello there!! This 765LT needs somebody to finish it, the physics seems okay (a bit high on power, other than that it seems decent, feels great, try it.) Textures on this car is pretty messed up so I need somebody to finish that off. No gauges, no skins, no shift animations, driver position and steering is weird. U'll find more stuff when you take a look at it. When somebody successfully converted it and make it looks good, dont credit me at all, just use your very own name, remember to announce it so we all know who it is first! Here is the link to the car, (blend files, textures, original fbx are included in the folder)

https://mega.nz/folder/3oBDHCCa#dnFhu8y2oA-QMJjS9gqwUg

(Please tell me if the link doesnt work =.=, thank you for helping out)

 
Last edited:
4,934
Iceland
Iceland
Malaysia had that too. I'm on it, but can't fix it today. Hope I can fix it tomorrow.
Some screenshots from that trees over pm would be nice. :)
The overall effect of the trees isn't too bad, I was probably going to just darken the textures a bit, but on closer inspection maybe the normals are fubar?

Screenshot_nrms_porsche_996_gt3_2004_vairano_15-3-121-23-47-56.jpg Screenshot_nrms_porsche_996_gt3_2004_vairano_15-3-121-23-49-1.jpg Screenshot_nrms_porsche_996_gt3_2004_vairano_15-3-121-23-47-36.jpg

edit: oops, sorry, didn't spot that you asked for pics over PM.
 
Last edited:
338
Germany
Germany
i think its clear it should not be as dim as in your screenshots.
Do you by any chance have this enabled for "sol_weather" app?
"Load & Save this per track" ?
ok this update of sol_weather app does do jack shoot, dont use any CSP 0.1.74-previewX if you want to have lits working as intended
 
Last edited:
82
Brazil
Brazil
Well, I mostly use Broken Clouds, but here's Windy on my system (3D clouds - CSP 0.1.74 p22):

View attachment 997961

It does indeed not look as if you would need an umbrella...:)

I was experiencing a similar problem using CSP 1.74 preview3, the clouds simply did not cast shadows on the track, while version 1.72 worked normally. Now with version 1.74 preview22 and Sol 2.1 Alpha 22 the problem seems to have been solved, I have back those dynamic shadows projected by the clouds and darkening the scenery in a frequent way, as in real life.

Open the Weather Debug and go to Clouds Shadows, see if there is any texture there.
 
338
Germany
Germany
can anyone confirm by using the "reset car" function found in:
https://www.racedepartment.com/downloads/custom-shaders-patch-debug-app-advanced.29060/
that if you reset to pit (not escape to pit) on "Besaid Temple"
(or any track with a downhill pit) the car will start rolling on its own.

If true, this could be a valuable bug for doing some interesting track/car mods.
The app is based on the original from x4fab and the reset button (it has no reset to pits) resets you to nearest point of ai-line, if downhill at this point of track it may roll a little, but not really.
Edit: Oh and it only works in practice/hotlap, latter one rendered invalid if you use the button
Edit2: yes, confirm one thing: you will have a speed>0 (<10km/h) when using it
Edit3: this is all mentioned in the description of ...Advanced app on RD (except the speed and rolling from Edit2)
 
Last edited:
195
United States
co.
jamesst99
Hey modders, anybody have a problem running 3dsimed on win10? Keep getting d3dx9_43.dll errors. Googled the fix, downloaded directx9, ect. still no luck.
 
Last edited: